Overclock.net › Forums › Intel › Intel Motherboards › ASUS Z170-AR, No Display
New Posts  All Forums:Forum Nav:

ASUS Z170-AR, No Display

post #1 of 2
Thread Starter 
Good Morning everyone,

I am hoping for some assistance troubleshooting my setup.

I have put together a new Z170 build about three weeks ago, and it went perfectly. Been running windows ten, using the PC everyday for coding, light gaming. However yesterday I went to boot, and got no display. Checked video card, didn't seem to have anything wrong with it, removed video card, tried just using on board video. Still nothing. Removed all peripherals, would not display and boot to bios. Removed and reseated DIMMs, tried each DIMM individually in the correct memory slot. Cleared CMOS, when that didn't work, removed CMOS battery for half an hour. No display. I have tried both display port, and HDMI, on three separate monitors.

I've pretty much exhausted everything but reseating the processor, but I did such a great job this time, and am short on paste and would like to avoid it. Additionally, literally nothing changed between me turning off the computer and booting it ten hours later. I've got a EK Supremacy MX waterblock on it, and that thing is so snug that I can't believe it would become unseated. At the time the system went dead I was running my 24/7 overclock, the 6600K at 4.4 and 1.27v, pretty tame.

Current behavior of the system is as follows:

Upon boot, all fans and water pump connected to the water pump header come on. The fans attached to the cpu fan header do not come on, but they never did until the system was under load anyway.

The motherboard has cpu, memory and i think pci bus boot error lights, they come on in their normal sequence, and none stay on just perfectly normal behavior.

If i have the ethernet plugged in, it will turn on and show it's normal activity lights.

I'm really at my wits end, I hate going through RMA (mobo is from tigerdirect) but can't possibly think of another thing to do to attempt to resurrect the comp.

Hardware:

I7 6600K
Asus Z170-AR
G. Skill Ripjaws V 2 x 8GB 3200
Radeon 290X
Custom Water Loop
post #2 of 2
Hey there, I'm working on a 6600k and 170-ar build and I had the same problem. Turns out one of my RAM modules was bad... back to Frys I go. I tried placing one stick in the A2 slot. No luck, swapped out with my other stick and it posted. So maybe see if you can find another stick of RAM, it would suck if you had to buy it just to test it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › ASUS Z170-AR, No Display