Overclock.net › Forums › Video Games › PC Gaming › Star Wars Battlefront Performance Discussion
New Posts  All Forums:Forum Nav:

Star Wars Battlefront Performance Discussion - Page 4

post #31 of 33
Quote:
Originally Posted by SlackerITGuy View Post

How is it running for you guys?

The game itself runs surprisingly well at Ultra settings for me (HD 7970 GHz Edition) but I get these random screen flickers that can be VERY annoying, plus the Score/Progression screen after-round is stuttery as hell, but other than that it's running very well.

This is with the latest AMD drivers.

How are things on the NVIDIA side?

Constant, rapid, horizontal, flickering with SLI 780 Ti. Had to delete the SLI profile for the game with nvidia inspector so the default profile will be used instead. This solved the issue and the game still runs fine with decent FPS. (Running 5880x1080 @144hz with HIGH settings, fps stays around 110-130 most of the time)
post #32 of 33
Runs butter smooth but I allow Geforce Experience to determine the settings for me. Silky smooh with great visuals though.
post #33 of 33
I recently started getting the black screen after a quick death and some uncharacteristic hangs. I have 2 x 980ti's in SLI with mild o/c and using global control settings. Getting 90+ frames in 4k with everything on ultra except shadow (high) and AA (off).

Anyone else with this issue? Solutions? I "repaired" the game through Origin but may try reinstalling Origin itself as an earlier post recommends.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Star Wars Battlefront Performance Discussion