Overclock.net › Forums › Intel › Intel Motherboards › Overclocking issues on ASRock Z170 OC Formula
New Posts  All Forums:Forum Nav:

Overclocking issues on ASRock Z170 OC Formula

post #1 of 29
Thread Starter 
Hi, I just got the ASRock OC Formula Z170 board as I had a defective ASUS Maximus VIII Hero board before. I'm attempting to OC on this new board and I'm having a few problems that I can't seem to figure out.

I'm trying to just get to 4.5 as a base, I'll point that out first.

So here's one issue, it seems that Turbo Mode is tied to the multiplier. I disable turbo mode, but when I go to edit the multiplier to 45, it re-enables turbo mode. Disabling turbo mode makes the multiplier go back to 'Auto'. This is just one problem, as even if i keep Turbo enabled, when I go into Windows to check my speeds, things are very off. First off, I am not clocked to 4.5, but instead the CPU(i7 6700k) fluctuates wildly from 0.75, 1.8, 2.3, 3.3, to 4.0Ghz. It's just random, and it's constantly changing.

I have Speedstep and C-State off in the BIOS, and I'm not seeing anything else that would be power related in there. CPU Vcore is at 1.35v. Am I missing some other feature that would cause CPU speeds to fluctuate so much??


This is quite frustrating because I got this board specifically because the ASUS board I had was defective when it came to overclocking, that board simply refused to update my OC values, and so I got the OC Formula, hoping my troubles would go away. No such luck it seems. The fluctuating never happened on this other board either, so this is new.


If there's any help anyone can provide, I'd be very appreciative. This is driving me crazy, no idea why it's happening.


Edit: Upon further testing, it seems that this motherboard has built in power saving features I can't disable for when the CPU is idle. This is an annoyance, if anyone has figured out how to disable them, let me know. BUT, with that, It still will not update to 4.5Ghz for me even with 45 multiplier(doing stress testing right now and instead of fluctuating, the speed remains at 4.0Ghz). No idea what's going on, I must be doing something wrong because I don't believe I could have two completely different mobos with the same exact issue.
Edited by Enad1 - 10/16/15 at 11:12am
post #2 of 29
Quote:
Originally Posted by Enad1 View Post

Hi, I just got the ASRock OC Formula Z170 board as I had a defective ASUS Maximus VIII Hero board before. I'm attempting to OC on this new board and I'm having a few problems that I can't seem to figure out.

I'm trying to just get to 4.5 as a base, I'll point that out first.

So here's one issue, it seems that Turbo Mode is tied to the multiplier. I disable turbo mode, but when I go to edit the multiplier to 45, it re-enables turbo mode. Disabling turbo mode makes the multiplier go back to 'Auto'. This is just one problem, as even if i keep Turbo enabled, when I go into Windows to check my speeds, things are very off. First off, I am not clocked to 4.5, but instead the CPU(i7 6700k) fluctuates wildly from 0.75, 1.8, 2.3, 3.3, to 4.0Ghz. It's just random, and it's constantly changing.

I have Speedstep and C-State off in the BIOS, and I'm not seeing anything else that would be power related in there. CPU Vcore is at 1.35v. Am I missing some other feature that would cause CPU speeds to fluctuate so much??


This is quite frustrating because I got this board specifically because the ASUS board I had was defective when it came to overclocking, that board simply refused to update my OC values, and so I got the OC Formula, hoping my troubles would go away. No such luck it seems. The fluctuating never happened on this other board either, so this is new.


If there's any help anyone can provide, I'd be very appreciative. This is driving me crazy, no idea why it's happening.


Edit: Upon further testing, it seems that this motherboard has built in power saving features I can't disable for when the CPU is idle. This is an annoyance, if anyone has figured out how to disable them, let me know. BUT, with that, It still will not update to 4.5Ghz for me even with 45 multiplier(doing stress testing right now and instead of fluctuating, the speed remains at 4.0Ghz). No idea what's going on, I must be doing something wrong because I don't believe I could have two completely different mobos with the same exact issue.

Ya that is strange because whatever I set in the bios or windows it stays exactly the same whether idle or load. There probably is a setting you are missing in the bios. Can you upload screenshots of your bios settings?
Bench Rig
(20 items)
 
  
CPUCPUMotherboardGraphics
Intel i7 core 5960x intel i7 core 4770k Rampage V Extreme Asus GTX 980 Strix 
GraphicsRAMRAMHard Drive
Asus 780 ti Matrix G-Skill Ripjawz 4 G-Skill Trident X Samsung 840 Evo 120gb 
Hard DriveHard DriveCoolingCooling
Corsair Neutron 120gb Corsair Neutron 120gb Kingpin Tek 9 Fat GPU Pot Kingpin F1 Extreme CPU Pot 
CoolingCoolingOSOS
EK Universal GPU Water Block EK Supremacy CPU Block Win 7 64 bit Win XP 32 bit 
MonitorPowerCaseOther
Samsung S27A950D Corsair AX1200 Dimastech Easy v3 Bench and Armaflex Gigabyte Z97 SOC Force Motherboard 
  hide details  
Reply
Bench Rig
(20 items)
 
  
CPUCPUMotherboardGraphics
Intel i7 core 5960x intel i7 core 4770k Rampage V Extreme Asus GTX 980 Strix 
GraphicsRAMRAMHard Drive
Asus 780 ti Matrix G-Skill Ripjawz 4 G-Skill Trident X Samsung 840 Evo 120gb 
Hard DriveHard DriveCoolingCooling
Corsair Neutron 120gb Corsair Neutron 120gb Kingpin Tek 9 Fat GPU Pot Kingpin F1 Extreme CPU Pot 
CoolingCoolingOSOS
EK Universal GPU Water Block EK Supremacy CPU Block Win 7 64 bit Win XP 32 bit 
MonitorPowerCaseOther
Samsung S27A950D Corsair AX1200 Dimastech Easy v3 Bench and Armaflex Gigabyte Z97 SOC Force Motherboard 
  hide details  
Reply
post #3 of 29
If you are oc'ing using the bios... In one of the menu's a drop down box will have two options: fixed or dynamic.

If you pick fixed it will disable some of the settings you mention by default and they can't be enabled. I was using "fixed" on my Z170 OC and never saw the issue you are describing.

The problem with the ASRock board is that there are at least two places you can change settings for some things (like the cpu and ram). Depending on which menu you do this in... you have more or less options. In other words the box with "fixed/dynamic" exists in only one of the menu's that allow you to change cpu settings.

If you are using the software.. I never used it, so I have no idea.
post #4 of 29
Thread Starter 
Quote:
Originally Posted by strong island 1 View Post

Ya that is strange because whatever I set in the bios or windows it stays exactly the same whether idle or load. There probably is a setting you are missing in the bios. Can you upload screenshots of your bios settings?

How do I capture images of my BIOS? Surprisingly, I've never had to do that before.

Quote:
Originally Posted by Digitalwolf View Post

If you are oc'ing using the bios... In one of the menu's a drop down box will have two options: fixed or dynamic.

If you pick fixed it will disable some of the settings you mention by default and they can't be enabled. I was using "fixed" on my Z170 OC and never saw the issue you are describing.

The problem with the ASRock board is that there are at least two places you can change settings for some things (like the cpu and ram). Depending on which menu you do this in... you have more or less options. In other words the box with "fixed/dynamic" exists in only one of the menu's that allow you to change cpu settings.

If you are using the software.. I never used it, so I have no idea.

I'm 99% sure I've went through all of the BIOS options. The only place to OC on here is in the OC Menu, then there's an advanced tab with a few other things related to CPU features, but not actual overclocking.

I'll take another look though.

The main issue I'm having is the CPU simply not updating to 4.5. I can deal with the weird idle fluctuations but I usually run SuperPi as a quick test(and works perfectly in this mobos case with their weird idle stuff) and the max Mhz is ~4000Mhz. My multiplier is at 45 so it SHOULD be going to 4.5 max.

Do any of you know about the link between turbo boost and not being able to edit multiplier without it being enabled? I'd love to disable it.
post #5 of 29
Your core/CPU speeds changing constantly has two general causes. One is all the CPU power saving options, including SpeedStep, C1E, and all the C States including Package C States. The other is the Processor power management settings in your Windows Power plan. Minimum processor state must be set to 100%, or the core speeds will drop under low load conditions.

Actually, you can have all the power saving options I listed above enabled, but if you set Minimum processor state to 100%, the core clocks will be at the core multiplier setting constantly. In reality in this configuration, the processor cores will still go into their highest C State core sleep state, although the core "speed" is still shown as the full speed.


No offense, but your perspective on over clocking is that of the original Intel Turbo boost functionality, of the i7-9xx/X58 platform, or the Sandy Bridge processor generation.

At that time, disabling Turbo was common, and the core multipliers on unlocked processors could be adjusted freely.

But at least since the Haswell processor generation, and possibly starting with Ivy Bridge, we are now dealing with Intel's Turbo 2. Skylake processors are also Turbo 2 processors.

Turbo 2 requires Turbo Boost to be enabled in the UEFI/BIOS in order to increase the core multipliers beyond their Processor Base Frequency, as Intel calls it. That is why you are stuck at 4.0GHz., Turbo is disabled.

With Turbo enabled and the core multipliers set beyond the maximum Turbo Boost speed, the maximum core speeds will only go up to whatever multiplier you have chosen. They will not be Turbo boosted beyond that speed.

There is nothing you can do to change the behavior of Turbo 2, it is locked by Intel, it is simply how Intel CPU over clocking works with newer Intel processor generations. There is no down side to this, or any advantage that disabling the original Turbo boost may have provided with earlier Intel processor generations.

We have no choice but to accept the way Turbo 2 works. I suggest you don't waste any time trying to find a way around Turbo 2.

Another semi-secret is when the transition to Turbo 2 occurred, as I recall actually with Sandy Bridge processors, the UEFI/BIOS of those mother boards allowed Turbo to be "disabled", but in reality it was never disabled. Otherwise core multiplier over clocking would not work.

The appearance of disabling Turbo was a result of the demand of experienced over clocker's apparently not being able to understand or accept the way Turbo 2 works. When one mother board manufacture began doing that, others had to do the same, or risk being judged wrong by the established over clocking community. "Old habits die hard" applies here, as we can still see today, no offense or sarcasm intended. worriedsmiley.gif

Actually this is an interesting little story that has not quite faded away into the past.
post #6 of 29
Thread Starter 
Okay thanks for the information, but I have tried setting multiplier to 45 with Turbo enabled(as that's the only way to do it) and upon putting load on, it never went beyond roughly 4100Mhz.
I'll give it another go now that I have new information.


Edit: Made minimum power state to 100 and it works, but the issue of it not updating to 4.5Ghz remains. Top speed it goes to is 4.0Ghz. This is exactly the same issue that occurred on the last board.
At this point I WANT to be told I'm doing something wrong but I'm not so sure I am.

Currently, I have my RAM on the provided XMP profile, CPU Vcore at 1.35 and CPU Ratio at 45. I have CPU cache at auto still, not sure if I need to mess with that.
Please let me know if there's something I'm not doing. Overclocking has always been a breeze for me on past chipsets, so maybe Z170 is just more involved and I'm unaware?? I'm not sure what to do next.



I almost don't wanna say it, but could it be possible there's something wrong with my i7 6700k? I have another PC with an i7 6700k in it, on a Gigabyte HD3, I'm curious to see if I can overclock on that. Once I get Windows installed on it, I'll give it a try.
Edited by Enad1 - 10/16/15 at 6:57pm
post #7 of 29
I hate to say it, but it almost sounds like you have an i7-6700 non-K processor. wink.gif Sorry for that, and I doubt your CPU is defective.

Although this would be different than previous ASRock OC Formula boards, I'll mention it anyway. Previous OC Formula boards have a "Slow Mode" switch on the board, apparently for use when extreme over clocking using LN2. From the factory it would be set to the On position. That would switch the CPU to run at 800 MHz. If ASRock changed that switch to run the CPU at a higher speed, I don't know, but it's easy to check if that switch is set to the On position.

Moving on, when you set the core multiplier(s), the UEFI should have an All Cores and Per Core options. With Per Core, you should get four lines, one for each core, that must be set individually to say 45, for a 4.5GHz OC. The All Cores option shows only one line to set the core multipliers with only one entry of 45, for example. That is on the OC Tweaker screen.

Also on the OC Tweaker screen, OR possibly in the Advanced, CPU Configuration screen, you may find a Maximum non-Turbo Speed option, or something like that. There's a similar option to run the processor when in the UEFI at a lower speed. If the first one I mentioned is set to 4.0GHz, that may be why you are stuck there. I know how you don't care for Turbo mode, so you may have set that option. biggrin.gif

Which makes me think it would be a good idea when in the UEFI, to start from scratch by clicking the Load UEFI defaults option. You may first want to save your current settings in a profile, just to remind you of other things you set, like the SATA mode to RAID if you use that, etc. The OC Formula boards have the most options of any ASRock UEFI, and while it may not match the over the top and sometimes unnecessary and confusing (IMO) UEFI options of Asus or Gigabyte, starting from default settings may help.

After that, check how you are setting the core multipliers as I described above, and I'll check the Z170 OC Formula manual for anything unusual. I use an ASRock Z170 Extreme7+ board, whose UEFI is at least partially the same as your board is, and I also have a Z87 OC Formula board, among others, so I'm familiar with ASRock boards.
post #8 of 29
Thread Starter 
Quote:
Originally Posted by parsec View Post

I hate to say it, but it almost sounds like you have an i7-6700 non-K processor. wink.gif Sorry for that, and I doubt your CPU is defective.

Although this would be different than previous ASRock OC Formula boards, I'll mention it anyway. Previous OC Formula boards have a "Slow Mode" switch on the board, apparently for use when extreme over clocking using LN2. From the factory it would be set to the On position. That would switch the CPU to run at 800 MHz. If ASRock changed that switch to run the CPU at a higher speed, I don't know, but it's easy to check if that switch is set to the On position.

Moving on, when you set the core multiplier(s), the UEFI should have an All Cores and Per Core options. With Per Core, you should get four lines, one for each core, that must be set individually to say 45, for a 4.5GHz OC. The All Cores option shows only one line to set the core multipliers with only one entry of 45, for example. That is on the OC Tweaker screen.

Also on the OC Tweaker screen, OR possibly in the Advanced, CPU Configuration screen, you may find a Maximum non-Turbo Speed option, or something like that. There's a similar option to run the processor when in the UEFI at a lower speed. If the first one I mentioned is set to 4.0GHz, that may be why you are stuck there. I know how you don't care for Turbo mode, so you may have set that option. biggrin.gif

Which makes me think it would be a good idea when in the UEFI, to start from scratch by clicking the Load UEFI defaults option. You may first want to save your current settings in a profile, just to remind you of other things you set, like the SATA mode to RAID if you use that, etc. The OC Formula boards have the most options of any ASRock UEFI, and while it may not match the over the top and sometimes unnecessary and confusing (IMO) UEFI options of Asus or Gigabyte, starting from default settings may help.

After that, check how you are setting the core multipliers as I described above, and I'll check the Z170 OC Formula manual for anything unusual. I use an ASRock Z170 Extreme7+ board, whose UEFI is at least partially the same as your board is, and I also have a Z87 OC Formula board, among others, so I'm familiar with ASRock boards.

Alright I have been using 'All Cores' since I thought it would accomplish the same thing, but I will use Per Core. The switches on the board are in the off position, but I'll look again to see if I'm missing anything.

Thanks for the help, I'll head into the BIOS soon with your suggestions and see what I can do. You really don't think it's possible I got a CPU that's just not able to OC?

Edit: Went back into BIOS and used Per Core, set them all to 45 and changed CPU Cache and CPU Cache minimum to 45, still not updating.

I'm still getting x40 as the multiplier when I check in Realtemp, and anywhere else. There's no opinion for Maximum Non-Turbo speed or anything like that.
I've gotta be doing something wrong here because this is getting ridiculous.
Edited by Enad1 - 10/17/15 at 5:02am
post #9 of 29
Is it possible ur chip can't do 45x at 1.35v, and adjusts down to 40x when u boot? If I didn't read the skylake oc statistics thread wrongly, I see 2 submissions for 4.5ghz at above 1.36v.
http://www.overclock.net/t/1570313/skylake-overclocking-guide-with-statistics
post #10 of 29
Um, you can just set PC power options to "High Performance" in the control panel and it should lock on your max multiplier, just don't touch any of the turbo settings type in the multi and try that. It's the same thing I use for many manufacturers.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Overclocking issues on ASRock Z170 OC Formula