post #1 of 1
Thread Starter 
To begin with, my rig:
Asus M5A99X Evo R2.0
AMD FX-8350 (4.3Ghz)
EVGA GTX 750Ti
32GB Corsair Vengeance DDR3-1600
CoolerMaster Nepton AIO cooler
Samsung 850 EVO 250GB SSD

I have Windows 10 installed on the SSD. Clean install. Started with an Insider Preview build. I did something stupid and reinstalled (after deleting UEFI partitions) Win10 build 10240. I have since upgraded to build 10535.
When I install a program, be it a game or anything, from a disc or as a mounted ISO, it seems to take a LOT longer to complete than it does installing the same program in Windows 7 (which I dual boot to on a separate Seagate HDD). By a LOT longer, I mean maybe 5 times longer. It didn't used to, by THAT I mean it was noticeably faster with the FIRST install of Win10(before I did something stupid). Office 2013 took nearly 45 minutes to install.
I have also noticed , when I use Nexus Mod Manager to install a mod in Skyrim, the Mod Manager will often blink or flash, say it's not responding, numerous times (maybe a dozen or so)before settling down. I have tried 3 different versions of Nexus Mod Manager and they all behave the same way.
Firefox 41 also acts similarly, blinking, not responding.
Everything is updated, latest Flash, latest Java, latest .Net, latest Nvidia drivers.
I have tried everything I can think of to correct this to no avail.
Any ideas, tips, suggestions?
Thanks