Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › DTS connect incompatible with Windows 10 (verified by the entire internet)
New Posts  All Forums:Forum Nav:

DTS connect incompatible with Windows 10 (verified by the entire internet)

post #1 of 9
Thread Starter 
I have an odd issue with DTS not working on my PC. I have an Asrock Z97 Extreme4 motherboard with DTS connect, Running Windows 10 Pro, connected to the optical input jack on a Harmon Kardon receiver. I have the latest Realtek driver installed.

In playback devices, the usual features are selected (Realtek Digital Output is enabled and set as the default device. Speakers is disabled)

In the supported formats tab in the Properties windows, I am able to test DTS Audio and Dolby digital just fine on all 5.1 channels.

I have verified that the receiver is correctly set up to receive Dolby digital audio, and the optical cable works.

But.....

Under the Enhancements tab, all sound effects are disabled except DTS Connect

When I go to the Advanced tab and choose any of the 2 channel modes, sound plays through the front left and right speaker. Then when I choose DTS Interactive and click Test, an error window opens up which says "Error! Failed to play test tone"

I have verified that Windows can successfully play through all 5.1 channels under the Supported formats tab even when DTS Interactive is not enabled.

In the Realtek audio manager, when DTS Interactive is enabled, no sound will play at all from the PC. Not system sounds, not youtube videos.

I am at a loss as to what to do. I have uninstalled Realtek audio drivers and ran CCleaner.

Just a FYI the DTS audio worked in Windows 8.1, but I switched to using my analog outputs before doing a clean install of Windows 10.

Specs:

Windows 10 Pro
Asrock Z97 extreme 4
Realtek 1150







Rundown:

Have tested the cable on two separate surround sound recievers
Cable works perfect.
Surround sound plays fine through all 5.1 channels when testing DTS and Dolby in the Supported formats tab when the driver is set to two channel mode
Surround sound test tone fails to play when DTS Interactive is enabled and so sound at all can be heard from the PC.
Have uninstalled, reinstalled the driver multiple times
Ran CCleaner
Have ran sfc /scannow

When driver is set to DTS Interactive, surround soun can be heard when testing in the Supported formats tab, but no test tone plays in the advanced tab when DTS interactive is enabled, and I cannot hear audio when playing youtube videos in either Edge or Chrome.

EDIT: I am considering trying the "unlocked" Realtek drivers tutorial to see if it helps.
Edited by aweir - 10/20/15 at 10:49am
post #2 of 9

You're not alone:

 

Quote:
Originally Posted by Chargeit View Post

My audio is ran over HDMI to the receiver. That uses the Nvidia audio drives instead of my on board. If I were running over optical or analog then I'd have access to a graphics EQ. Analog isn't an option, but, optical is. Issue with that is it only does 5.1 with DTS. Windows 10 also seems to have some issues with DTS over optical since I was not able to get it working correctly. I looked it up and others had the same problem.

I'll look into EQ's. Maybe I can catch a good deal on one around black Friday. Though I'll be honest and say I kind of want to remove complexity from my setup instead of adding to it. Still, I'll check it out.

 

This post is slightly out of context, but the gist is that Windows 10 has problems with DTS over optical and he discovered that he's not the only one.

It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #3 of 9
Thread Starter 
I have scoured the internet for hours and have come to the realization that NO ONE can get DTS connect to work on Windows 10. What a shame, but I suspect there is a reason why that we are not being told.

Looks like I'm going back to Windows 8.1 where everything just worked. Even though Windows 10 is free, it seems you really CAN look a gift horse in the mouth.

For now, I'll stick with my trusty analog outputs. Microsoft hasn't found a way to break that yet but I'm sure they're working on it so they can say "Hey, we fixed that problem that existed for 4 months, aren't we awesome!? Give us a high five."
Edited by aweir - 10/20/15 at 11:28am
post #4 of 9
MS to you:

Edited by Liranan - 10/21/15 at 5:25am
The girlfriend.
(15 items)
 
The Mistress
(13 items)
 
Media Server
(11 items)
 
CPUMotherboardGraphicsRAM
FX8320 @ 4.5 Crosshair V (Third One) 290 Tri-X OC 16GB HyperX 
Hard DriveHard DriveHard DriveCooling
Sandisk SSD Plus 240GB Toshiba 3TB Hitachi 2TB Swiftech H220-X 
OSMonitorKeyboardPower
Win 8.1/Mint Viewsonic VX2457-mhd Fuhlen L411 Slim Super Flower Golden King 650W 
CaseMouseMouse Pad
Enthoo Pro G400 Super Flower 
CPUMotherboardGraphicsRAM
A8-6410 Lenovo Lancer 4B2 K16.3 R5 128 Shaders/M230 Hynix 8GB DDR3 1600 
Hard DriveHard DriveOSMonitor
Samsung 840 120 GB SSD Seagate Momentus 1TB 5400rmp Win 8.1 CMN1487 TN LED 14" 1366*768 
KeyboardPowerMouseMouse Pad
Lenovo AccuType 2900mAh/41Wh Elan Trackpad/Logitech M90 Super Flower 
Audio
AMD Avalon(Connexant) 
  hide details  
Reply
The girlfriend.
(15 items)
 
The Mistress
(13 items)
 
Media Server
(11 items)
 
CPUMotherboardGraphicsRAM
FX8320 @ 4.5 Crosshair V (Third One) 290 Tri-X OC 16GB HyperX 
Hard DriveHard DriveHard DriveCooling
Sandisk SSD Plus 240GB Toshiba 3TB Hitachi 2TB Swiftech H220-X 
OSMonitorKeyboardPower
Win 8.1/Mint Viewsonic VX2457-mhd Fuhlen L411 Slim Super Flower Golden King 650W 
CaseMouseMouse Pad
Enthoo Pro G400 Super Flower 
CPUMotherboardGraphicsRAM
A8-6410 Lenovo Lancer 4B2 K16.3 R5 128 Shaders/M230 Hynix 8GB DDR3 1600 
Hard DriveHard DriveOSMonitor
Samsung 840 120 GB SSD Seagate Momentus 1TB 5400rmp Win 8.1 CMN1487 TN LED 14" 1366*768 
KeyboardPowerMouseMouse Pad
Lenovo AccuType 2900mAh/41Wh Elan Trackpad/Logitech M90 Super Flower 
Audio
AMD Avalon(Connexant) 
  hide details  
Reply
post #5 of 9
This is an odd issue, like 3 drivers have come out since release and not a one works with Windows 10 and DTS Connect over optical. I can use NVIDIA's audio driver and get 7.1 over HDMI but as soon as I use Realtek and optical I'm in the wind. Beat my head against the wall forever but there is no fix. It will be a year before they even try I should guess. I would just use NVIDIA's driver but I like my accessory display and unless the display has inherent 7.1 (which no display ever has) I can't use a pass through, then it automatically forces 2.1 because NVIDIA sucks ass.
post #6 of 9
I get this error when I try to install DTS Connect for my Sound Blaster X-Fi Titanium Champion card.

I hope they resolve this soon if ever. I've also tried using the PAX drivers too.
post #7 of 9
Quote:
Originally Posted by Beavosaur View Post

I get this error when I try to install DTS Connect for my Sound Blaster X-Fi Titanium Champion card.

I hope they resolve this soon if ever. I've also tried using the PAX drivers too.

There is an updated driver that finally works!
post #8 of 9
I just spent 8 hrs scouring this issue, it seems some people can get it to work with beta realtek drivers. I tried to get it to work but it wont work.

My issue stems from having a Creative X7 Limited edition which will not send a 5.1 signal to my bose cinemate 130. Worthless Piece of $500.....

Meanwhile my Asus X99 board should do this but it wont work in windows 10. So I am going to go try it in windows 7.

I cant believe even creative cant get it to work
X99 King Build
(18 items)
 
Da Rig2
(20 items)
 
CPUMotherboardGraphicsRAM
Intel 5930k Asus Rampage V Extreme EVGA 1080 Founders Edition Crucial Ballistix 32GB Sport (4x8GB) 
Hard DriveHard DriveHard DriveHard Drive
2 - Samsung Pro 850 2TB Raid 0 Seagate Barracuda 3TB 7200rpm 3 WD Red 4TB NAS(No array) Samsung Pro 850 1 TB 
Optical DriveCoolingCoolingOS
LITE-ON 12X Blu-ray  ThermalRight SB-IE Custom 10 fans Win 7 X64 
MonitorKeyboardPowerCase
Samsung 55" / 65" Microsoft Sculpt EVGA G2-1300 Lian Li Custom Modded PC_70 
MouseAudio
Razer Deathadder Chroma Creative X7 
CPUMotherboardGraphicsGraphics
Xeon X5660 Gigabyte X58a-ud5 rev2 (Custom Bios mod FF3 10/... EVGA Titan EVGA Titan 
RAMHard DriveHard DriveHard Drive
12GB 3 2GB dimm G Skill PC3 10700 7-8-7-22 (84... Seagate 2 x 1.5GB 3 WD Red 3TB  Samsung Pro 840 
Optical DriveCoolingOSMonitor
LITE-ON 12X Blu-ray  10+fans and Ultra 120 Extreme cooler Win 7 x64 Dell 30" 
MonitorMonitorKeyboardPower
Dell 30" Dell 30" Microsoft 4000 ergonomic keyboard EVGA G2 1300 
CaseMouseMouse PadAudio
Lian Li Custom modded  Razer Copperhead Razer eXact Mat Onboard and Logitech speakers 
  hide details  
Reply
X99 King Build
(18 items)
 
Da Rig2
(20 items)
 
CPUMotherboardGraphicsRAM
Intel 5930k Asus Rampage V Extreme EVGA 1080 Founders Edition Crucial Ballistix 32GB Sport (4x8GB) 
Hard DriveHard DriveHard DriveHard Drive
2 - Samsung Pro 850 2TB Raid 0 Seagate Barracuda 3TB 7200rpm 3 WD Red 4TB NAS(No array) Samsung Pro 850 1 TB 
Optical DriveCoolingCoolingOS
LITE-ON 12X Blu-ray  ThermalRight SB-IE Custom 10 fans Win 7 X64 
MonitorKeyboardPowerCase
Samsung 55" / 65" Microsoft Sculpt EVGA G2-1300 Lian Li Custom Modded PC_70 
MouseAudio
Razer Deathadder Chroma Creative X7 
CPUMotherboardGraphicsGraphics
Xeon X5660 Gigabyte X58a-ud5 rev2 (Custom Bios mod FF3 10/... EVGA Titan EVGA Titan 
RAMHard DriveHard DriveHard Drive
12GB 3 2GB dimm G Skill PC3 10700 7-8-7-22 (84... Seagate 2 x 1.5GB 3 WD Red 3TB  Samsung Pro 840 
Optical DriveCoolingOSMonitor
LITE-ON 12X Blu-ray  10+fans and Ultra 120 Extreme cooler Win 7 x64 Dell 30" 
MonitorMonitorKeyboardPower
Dell 30" Dell 30" Microsoft 4000 ergonomic keyboard EVGA G2 1300 
CaseMouseMouse PadAudio
Lian Li Custom modded  Razer Copperhead Razer eXact Mat Onboard and Logitech speakers 
  hide details  
Reply
post #9 of 9
Anyone got this to work? I bought a 3x as expensive motherboard mainly to get native DTS Connect and get rid of my external (DDL) soundcard, now I'm stumped by this ridiculous incompatability on Windows 10. Nice enough, ASUS celebrates the mobo's Windows 10 compatability...
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › DTS connect incompatible with Windows 10 (verified by the entire internet)