Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA Quadro K5000M – GPU clock capped at 542 MHz – Also GPU-Z and Afterburner reporting different clocks
New Posts  All Forums:Forum Nav:

NVIDIA Quadro K5000M – GPU clock capped at 542 MHz – Also GPU-Z and Afterburner reporting different clocks

post #1 of 2
Thread Starter 
I have a NVIDIA Quadro K5000M in my laptop. This GPU is similar to the GeForce 680M, with some extra Quadro features and slightly reduced core/memory clock speed.

In the past I was able to apply a 20% boost to both the core and memory clock speeds using NVIDIA Inspector in order to match the speeds of the GeForce 680M.

Fast forward a year or so (spent some time away from gaming) and I'm running into a throttling issue with my GPU. Specifically the GPU core speed (memory speed seems fine). The normal max speed for the K5000M is 600 MHz. No matter what I do, it doesn't seem to want to go past 542 MHz. I'd like to bump it to 720 MHz (same speed as GeForce 680M) — but I'm getting this throttle even with no overclocking profile applied.

I've tried the usual suspects. Windows power setting is set to "High performance". NVIDIA control panel power setting is set to "Prefer maximum performance" rather than "Adaptive" or "Let the driver decide." I've tried doing a clean NVIDIA driver install.

It's not a temperature issue. I never get above mid 50's in GPU core temp. And it's not a power issue. I have a 240 W power supply (standard for this laptop), and I have tried multiple power supplies.

I have not tried a brand new Windows install and would rather not do that if I can avoid it.

So, I've been looking for a way to flat out disable throttling and set the speed to what I want while gaming. While playing with different utilities, no matter what I do, the clock caps out at 542 MHz.

I also noticed a discrepancy in the clock speed reported by GPU-Z and MSI Afterburner. Here you see two tools reporting 542 MHz and two tools reporting 900 MHz (yeah I accidentally set it too high). Sometimes while in the P8 idle state, GPU-Z reports 135 MHz and Afterburner reports something around 340. Who do I believe? I suspect Afterburner is just reporting the "max" clock speed for the current power profile, rather than the actual one.



Anyway, I'm interested in any suggestions on how to kick the GPU back up to the speed it's supposed to be at. Thanks.
post #2 of 2
Thread Starter 
Sorry to double post, but I have a resolution to this issue and wanted to post an update in case anyone runs across this while researching a similar issue in the future.

I tried all sorts of things and was unable to get the GPU core clock to go past 542 MHz. I found a tweaked VBIOS here: http://forum.techinferno.com/general-notebook-discussions/1847-nvidia-kepler-vbios-mods-overclocking-editions-modified-clocks-voltage-tweaks.html

After flashing the modified VBIOS, the GPU has no problem clocking up. They must have removed some throttle check in addition to setting the max clock to 758 MHz.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
  • NVIDIA Quadro K5000M – GPU clock capped at 542 MHz – Also GPU-Z and Afterburner reporting different clocks
Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA Quadro K5000M – GPU clock capped at 542 MHz – Also GPU-Z and Afterburner reporting different clocks