Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Drivers crashing to black screen on 7970
New Posts  All Forums:Forum Nav:

Drivers crashing to black screen on 7970

post #1 of 6
Thread Starter 
So basically when I upgraded to Windows 10, I immediately got "display driver recovery" notifications, and it happened every ~5 mins or so. Tried playing some games and it would black screen every couple of minutes, sometimes it recovered, and sometimes I needed a hard reset. I figured it was W10's auto driver installation causing issues, so I uninstalled, ran DDU and installed the 15.7.1 drivers off AMD's site. This fixed the crashing when idle/browsing, and I could play some games (BF4 etc) without crashing, but couldn't play others (League of Legends, Diablo 3) I also tried underclocking the card in CCC/Afterburner, didn't make a difference.

Decided to format and reinstall Windows 7, installed the 15.7.1 drivers again, and I'm still getting the same issues. I seem to be able to run stuff that maintains high load on the GPU like BF4, Furmark/Heaven etc without issue, but thing like PCSX2/Dolphin, League of Legends and Diablo 3 where my GPU is at low load seem to crash and black screen, requiring a hard reset.

This never happened before, I was running 15.7 drivers on W7 before I initially went for the W10 install without any problems. I have upgraded the rest of my system since that time, I was running a s1156 setup before, and now I'm on X99, but can't see how that would make any difference.

Any ideas?
Rig
(9 items)
 
  
CPUMotherboardGraphicsRAM
5820k ga-x99-sli gigabyte 7970 wf 16gb 4x4 lpx 
Hard DriveCoolingPowerCase
samsung 830 128gb ven x/gt ap-15 evga g2 650w corsair 450d 
Audio
jbl lsr305 
  hide details  
Reply
Rig
(9 items)
 
  
CPUMotherboardGraphicsRAM
5820k ga-x99-sli gigabyte 7970 wf 16gb 4x4 lpx 
Hard DriveCoolingPowerCase
samsung 830 128gb ven x/gt ap-15 evga g2 650w corsair 450d 
Audio
jbl lsr305 
  hide details  
Reply
post #2 of 6
If you underclock the GPU by 100-200MHz (memory too) can you see if the issue still happens?
madVR+SVP
(18 items)
 
  
CPUMotherboardGraphicsRAM
Xeon E5 1650 @ 4.8GHz / 1.31v Asus X79 Deluxe EVGA GTX 980 Ti Classified  Kingston HyperX Fury White 16 GB 
Hard DriveHard DriveCoolingOS
Samsung 850 Pro 256 GB Western Digital Green 3 TB Corsair H100i GTX Windows 7 Professional 
MonitorMonitorKeyboardPower
BenQ GW2765 ViewSonic XG2401 Corsair Strafe RGB MX Silent EVGA SuperNOVA G2 750W 
CaseMouseMouse PadAudio
NZXT. H440 Logitech G502 SteelSeries QCK+ Sennheiser HD 598 
AudioOther
FiiO E10K Cablemod Sleeved Cables (Black/White) 
  hide details  
Reply
madVR+SVP
(18 items)
 
  
CPUMotherboardGraphicsRAM
Xeon E5 1650 @ 4.8GHz / 1.31v Asus X79 Deluxe EVGA GTX 980 Ti Classified  Kingston HyperX Fury White 16 GB 
Hard DriveHard DriveCoolingOS
Samsung 850 Pro 256 GB Western Digital Green 3 TB Corsair H100i GTX Windows 7 Professional 
MonitorMonitorKeyboardPower
BenQ GW2765 ViewSonic XG2401 Corsair Strafe RGB MX Silent EVGA SuperNOVA G2 750W 
CaseMouseMouse PadAudio
NZXT. H440 Logitech G502 SteelSeries QCK+ Sennheiser HD 598 
AudioOther
FiiO E10K Cablemod Sleeved Cables (Black/White) 
  hide details  
Reply
post #3 of 6
Did you do the upgrade, or did you do a clean install of Windows 10?
post #4 of 6
Thread Starter 
Quote:
Originally Posted by iinversion View Post

If you underclock the GPU by 100-200MHz (memory too) can you see if the issue still happens?

Already tried that, no change.
Quote:
Originally Posted by blaze2210 View Post

Did you do the upgrade, or did you do a clean install of Windows 10?

It was like this:

> No issues on i7 860 setup with Windows 7 and 15.7 drivers
> Upgraded to 5820k setup with fresh Windows 10 install and crashed while browsing/gaming
> Ran DDU and installed 15.7 drivers, no longer crashed while browsing but still crashed in some games (also tried 15.10 beta, still the same)
> Went back to Windows 7 (full format, not a rollback) and installed 15.7 drivers, still crashing in some games.

Furmark/Heaven and anything that pegs the GPU at 100% load runs fine without crashing, at least so far.
Edited by GameBoy - 10/30/15 at 9:40pm
Rig
(9 items)
 
  
CPUMotherboardGraphicsRAM
5820k ga-x99-sli gigabyte 7970 wf 16gb 4x4 lpx 
Hard DriveCoolingPowerCase
samsung 830 128gb ven x/gt ap-15 evga g2 650w corsair 450d 
Audio
jbl lsr305 
  hide details  
Reply
Rig
(9 items)
 
  
CPUMotherboardGraphicsRAM
5820k ga-x99-sli gigabyte 7970 wf 16gb 4x4 lpx 
Hard DriveCoolingPowerCase
samsung 830 128gb ven x/gt ap-15 evga g2 650w corsair 450d 
Audio
jbl lsr305 
  hide details  
Reply
post #5 of 6
Quote:
Originally Posted by GameBoy View Post

Already tried that, no change.
It was like this:

> No issues on i7 860 setup with Windows 7 and 15.7 drivers
> Upgraded to 5820k setup with fresh Windows 10 install and crashed while browsing/gaming
> Ran DDU and installed 15.7 drivers, no longer crashed while browsing but still crashed in some games (also tried 15.10 beta, still the same)
> Went back to Windows 7 (full format, not a rollback) and installed 15.7 drivers, still crashing in some games.

Furmark/Heaven and anything that pegs the GPU at 100% load runs fine without crashing, at least so far.

what psu are you using?
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 8 / 1600 
Hard DriveCoolingOSMonitor
1000 360/240 7 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 8 / 1600 
Hard DriveCoolingOSMonitor
1000 360/240 7 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
post #6 of 6
Thread Starter 
The problem ended up being the GPU not being seated properly I think, although it looked like it was properly lined up and I did reseat it a couple times... But it has been runningwithout being screwed down to the case for days without a single crash. I think the Motherboard may be too close to the back of the case or something, causing the pci bracket to flex when trying to screw it in.

Still don't really understand why it never crashed at 100% load, though.
Rig
(9 items)
 
  
CPUMotherboardGraphicsRAM
5820k ga-x99-sli gigabyte 7970 wf 16gb 4x4 lpx 
Hard DriveCoolingPowerCase
samsung 830 128gb ven x/gt ap-15 evga g2 650w corsair 450d 
Audio
jbl lsr305 
  hide details  
Reply
Rig
(9 items)
 
  
CPUMotherboardGraphicsRAM
5820k ga-x99-sli gigabyte 7970 wf 16gb 4x4 lpx 
Hard DriveCoolingPowerCase
samsung 830 128gb ven x/gt ap-15 evga g2 650w corsair 450d 
Audio
jbl lsr305 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Drivers crashing to black screen on 7970