Overclock.net › Forums › Components › Monitors and Displays › Asus ROG swift issues
New Posts  All Forums:Forum Nav:

Asus ROG swift issues

post #1 of 2
Thread Starter 
Recently took delivery of an asus ROG swift monitor, hooked it up to my system using the supplied DP cable. Once in windows the mouse movement on screen felt very laggy. Upon checking windows monitor settings the screen was set at native resolution of 2560x1440. But, the refresh rate was locked at 24Hz with no option to select higher. Also the turbo button when pressed didnt allow any changes. Tried a fresh driver install using DDU but still the same problem.

Also hooked the monitor upto my second system, an X58 i7 930 based setup with a gtx 650ti 2gb. No display whatsoever on this setup. So transferred it back to my primary system where again no display at all. Just orange on the monitor display light at bottom right. Thinking that perhaps it was a faulty DP cable, i picked a new one up from amazon but still no change. Spec of primary system is below.

i7 5820k @stock
msi mpower X99s
16gb gskill ripjaw 4 c15
Msi gtx 980ti 6gb gaming edition
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 5820k MSI xX99S Mpower mSI GTX 980TI gaming edition 16gb Gskill ripjaw4 3000mhz c15 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 Samsung F1 1 TB Seagate 750gb LG blu ray 
CoolingOSMonitorKeyboard
Alpenfohn k2 Win 7 home premium 64 Asus ROG swift PG278Q Ozone strike pro 
PowerCaseMouseMouse Pad
Corsair hx 850w Phanteks enthoo primo Logitech G500 Boogie bug xl 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 5820k MSI xX99S Mpower mSI GTX 980TI gaming edition 16gb Gskill ripjaw4 3000mhz c15 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 Samsung F1 1 TB Seagate 750gb LG blu ray 
CoolingOSMonitorKeyboard
Alpenfohn k2 Win 7 home premium 64 Asus ROG swift PG278Q Ozone strike pro 
PowerCaseMouseMouse Pad
Corsair hx 850w Phanteks enthoo primo Logitech G500 Boogie bug xl 
  hide details  
Reply
post #2 of 2
That's odd. Sounds like a driver issue or bad firmware in monitor. Contact Asus right away.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Asus ROG swift issues