Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Windows 10 massive lag on game launch.
New Posts  All Forums:Forum Nav:

Windows 10 massive lag on game launch.

post #1 of 2
Thread Starter 
Windows 10 Pro 64 bit is the version I have running, and every time I launch a game for the first time, the entire system crawls to a dead stop.
I have a Corsair K95 RGB keyboard, which has the LEDs wave in a rainbow pattern, and when I launch a game you can see the lag on the keyboard, it barely is able to even move anymore.
The mouse cursor barely moves anymore, and ends up skipping all over the screen, at varrying speeds.
All input (clicking, keystokes, etc) no longer works until the issue ends, and then all input occurs at once.
Any audio that might have been playing instantly stops playing, and every few seconds I'll hear a little blip from it for a fraction of a second before it stops again.
This could last anywhere from 5 seconds, to a full minute, before finally stopping and launching the game, at which point, it runs flawlessly. Although it does sometimes(rare) occur during loading screens.


If I've run the game, and had this happen to me, it will not happen a second time. However, it will happen on a different game that has not yet been launched, but never twice on the same game.
This also resets when I restart my system.

I've been googling this and going site to site for weeks now, I've not managed to find a single documented report of this occuring, yet it's been incredibly persistent for me, across hardware upgrades, and full reformatting of all SSD/HDDs.
I'm currently just getting online after a full system rebuild and reformatting, with freshly installed drivers (betas) and no extra non-driver software aside from chrome, skype, and steam and the issue has survived and is still present.

My specs are:
CPU: AMD FX-8370E
GPU: 980 Ti
RAM: 32GB 1600 DDR3
MB: ASUS Crosshair V Formula-Z

Any of you guys heard of such a thing? Any suggestions to look into? The almighty google seems to have failed me.
post #2 of 2
I only installed 3 drivers for my mobo as other ones would break W10.
Chipset, Audio, Lan. Then I did my video later... think thats all the drivers I have.

Edit: Other drives would break to os pretty much and had to restore.
Edited by Higgins909 - 11/9/15 at 6:28pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Windows 10 massive lag on game launch.