Overclock.net › Forums › Graphics Cards › AMD/ATI › AMD R9 285 / 380 / 380X Tonga/Tonga XT Owners Discussion Thread
New Posts  All Forums:Forum Nav:

AMD R9 285 / 380 / 380X Tonga/Tonga XT Owners Discussion Thread - Page 41

post #401 of 548
here is my newly arrived 380X.........after going thru a long stupid ridiculous RMA rolleyes.gif

post #402 of 548
my RMA from initial response to finish was ~3 weeks with XFX. I like the card, it's a slight improvement over the 280X... I can play SWTOR at decent FPS on High.
post #403 of 548
Hi there!

Bought this week an Powercolor R9 380, huge improvement over my faithful 5670. But one thing bugs me.

This 380 keeps its core speed at 755MHz idle, and the fans runs enough just to keep 63ºC, usually at 33%. It seems ok, but shouldn't it be at a lower clock when idle?

My comparison is my old gpu, it had 3 performance levels: 157mhz, 400mhz and 775mhz (I get it running stable at 900 for years). My 380 just shows in speccy 2 levels: 755 and 980mhz.

Is something wrong with my card, or it is the way they are supposed to work nowadays? Latter case, is there some software to override the idle clocks and voltages? Afterburner just changes the max clock, afaik.

Tested some drivers (using ddu to uninstall), without change. I'm asking around, but nobody seems to understand that not everybody want a board running OCed 24x7 when isn't needed.


When running games the gpu is doing well, increasing its clock and fans in a very fine way.

Thanks!
post #404 of 548
Quote:
Originally Posted by bakasan View Post

Hi there!

Bought this week an Powercolor R9 380, huge improvement over my faithful 5670. But one thing bugs me.

This 380 keeps its core speed at 755MHz idle, and the fans runs enough just to keep 63ºC, usually at 33%. It seems ok, but shouldn't it be at a lower clock when idle?

My comparison is my old gpu, it had 3 performance levels: 157mhz, 400mhz and 775mhz (I get it running stable at 900 for years). My 380 just shows in speccy 2 levels: 755 and 980mhz.

Is something wrong with my card, or it is the way they are supposed to work nowadays? Latter case, is there some software to override the idle clocks and voltages? Afterburner just changes the max clock, afaik.

Tested some drivers (using ddu to uninstall), without change. I'm asking around, but nobody seems to understand that not everybody want a board running OCed 24x7 when isn't needed.


When running games the gpu is doing well, increasing its clock and fans in a very fine way.

Thanks!

It is weird. If you attach your gpu VBIOS I will see if the problem is caused by the VBIOS. If it is a software problem maybe unistalling driver with Display Driver Unistaller and the installing it again may solve it.
Edited by mynm - 8/15/16 at 11:57am
post #405 of 548
There it is. Meanwhile, I will try to do a clean install in other partition and see the results.
Edited by bakasan - 8/19/16 at 11:18am
post #406 of 548
Quote:
Originally Posted by bakasan View Post

r9_380.zip 100k .zip file

There it is. Meanwhile, I will try to do a clean install in other partition and see the results.

Thanks. Core is blocked by bios to a min of 755mhz, memory is blocked as well to 1475mhz. It is weird.

You may have to talk to Powercolor techsupport to give you a new bios, because I can give you a bios moded to solve the problem, but flashing It will void warranty.

I know a software workaround, but is to large to explain it now, I will tell you it tomorrow.
post #407 of 548
Thanks a lot! smile.gif

I actually have some partitions here, so I used one to try newer OS, installed windows 10 and the latest crimson; and, indeed, the min clock still was 755mhz.

I sent a mail to Powercolor yesterday asking for some help, no responses yet. I would be very grateful if you can explain how this soft workaround is set, and if you have the time, I would not refuse the modded bios too, better have it while I can get it, sooner no one will remember the 300 series.
post #408 of 548
just remember to make a back up of your current BIOS in case you need to put it back in for warranty purposes.
post #409 of 548
Quote:
Originally Posted by bakasan View Post

Thanks a lot! smile.gif

I actually have some partitions here, so I used one to try newer OS, installed windows 10 and the latest crimson; and, indeed, the min clock still was 755mhz.

I sent a mail to Powercolor yesterday asking for some help, no responses yet. I would be very grateful if you can explain how this soft workaround is set, and if you have the time, I would not refuse the modded bios too, better have it while I can get it, sooner no one will remember the 300 series.


You're welcome thumb.gif. Try this to solve the problem:

Go to Afterburner settings, enable extended official overclocking limits. Don't restart pc.

Go to regedit and search PP_PhmSoftPowerPlayTable is at [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000]. Click on modify, go to line 0060, you will see this:

0060 00 00 00 07 02 03 03 00, change it to 0060 00 00 00 07 00 03 00 00.

Restart windows. If cloks persist bloked, go to radeon settings and on preferences click on restore factory defaults.

Hope this can help you. You will have to do this on every new gpu driver instalation.

The only permanet way to solve the problem is flashing gpu. As is a new gpu you will can return it, to avoid problems caused by flashing it.
post #410 of 548
It worked! thumbsupsmiley.png

Just did the register changes and restarted, the clocks now are hovering 300mhz for the core and 150mhz for the memory. I will test it on gaming later, but it seems the patch does the job just fine.

I will keep asking for powercolor support, if they send other bios or suggest rma it, ok; if not, I will just use this card as it is and never buy from them anymore.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › AMD R9 285 / 380 / 380X Tonga/Tonga XT Owners Discussion Thread