Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Screen flickering with Firefox hardware acceleration enabled
New Posts  All Forums:Forum Nav:

Screen flickering with Firefox hardware acceleration enabled

post #1 of 12
Thread Starter 
I noticed when clicking tabs or mousing over certain aspects of webpages a screen flickering issue occurs.
The flickering covers the entire screen, not just the browser window.
Turning off hardware acceleration in firefox options solves this issue.

Is this an issue with the browser, windows, or my ati drivers?

Exact same sort of flickering occurs when I disable Windows desktop window manager (dwm) in Windows 7 and use the classic theme.
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
post #2 of 12
Quote:
Originally Posted by boykisser View Post

I noticed when clicking tabs or mousing over certain aspects of webpages a screen flickering issue occurs.
The flickering covers the entire screen, not just the browser window.
Turning off hardware acceleration in firefox options solves this issue.

Is this an issue with the browser, windows, or my ati drivers?

Exact same sort of flickering occurs when I disable Windows desktop window manager (dwm) in Windows 7 and use the classic theme.

I get a bit of flickering in the same situation, but just my task bar. (also have classic theme on windows7).
r9 280x gfx.
post #3 of 12
Thread Starter 
It's very unfortunate that it is impossible to have classic theme with dwm enabled.
Enabling classic theme automatically disables dwm and causes flickering issues.
I heard that this is resolved in Win 8 and later versions as DWM is more integrated into the kernel remains enabled.

On another hand, I don't think this issue occurs with Nvidia cards, what gives?
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
post #4 of 12
Might have something to do with your GPU clocks kicking up for the acceleration.
POWERFUL
(19 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6800K X99-UD3P-CF AMD Radeon R9 200 Series 16gb G.skill RipjawX 2400mhz DDR4 
Hard DriveHard DriveHard DriveOptical Drive
Samsung spinpoint f3  Western digital Caviar Black Adata SU800 512gb LG Super Multi DVD Burner 
CoolingOSMonitorMonitor
Noctua NH-U14S Windows 10 x64 pro Asus VA32AQ 31.5" 1440p Acer 19" LED 900p 
KeyboardPowerCaseMouse
Logitech G19 OCZ ZX 850w gold Cooler Master HAF XB Logitech G600 
Mouse PadAudioAudio
Custom Artscow Sennheiser 429 Logitech Z313 
  hide details  
Reply
POWERFUL
(19 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6800K X99-UD3P-CF AMD Radeon R9 200 Series 16gb G.skill RipjawX 2400mhz DDR4 
Hard DriveHard DriveHard DriveOptical Drive
Samsung spinpoint f3  Western digital Caviar Black Adata SU800 512gb LG Super Multi DVD Burner 
CoolingOSMonitorMonitor
Noctua NH-U14S Windows 10 x64 pro Asus VA32AQ 31.5" 1440p Acer 19" LED 900p 
KeyboardPowerCaseMouse
Logitech G19 OCZ ZX 850w gold Cooler Master HAF XB Logitech G600 
Mouse PadAudioAudio
Custom Artscow Sennheiser 429 Logitech Z313 
  hide details  
Reply
post #5 of 12
Thread Starter 
Quote:
Originally Posted by heroxoot View Post

Might have something to do with your GPU clocks kicking up for the acceleration.
Yes, I've come to this conclusion as well. t I've yet to find a solution that doesn't involve setting 2D clocks to those of 3D.
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
post #6 of 12
Are you using the latest Fox? I have no flickering on mine with 2 290s and Hotfix. Same with my other rig with a 7950 and my Inspiron laptop with lubuntu.

Although, my Window PCs have not seen an windows update for awhile. Like April last year. I only update MSE.

I did not have to follow the procedure included in this thread but it might help you . . .

http://www.overclock.net/t/1265543/the-amd-how-to-thread

And, yes, my HA is enabled . . .


Edited by rdr09 - 1/28/16 at 10:49pm
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
post #7 of 12
Thread Starter 
Quote:
Originally Posted by rdr09 View Post

Are you using the latest Fox? I have no flickering on mine with 2 290s and Hotfix. Same with my other rig with a 7950 and my Inspiron laptop with lubuntu.

Although, my Window PCs have not seen an windows update for awhile. Like April last year. I only update MSE.

I did not have to follow the procedure included in this thread but it might help you . . .

http://www.overclock.net/t/1265543/the-amd-how-to-thread

And, yes, my HA is enabled . . .

What is this hotfix?
I'm currently using 15.11.1
I tried the catalyst when it came out and I was having some issues with a game and I felt like they removed a lot of the options from control panels.
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
hi
(14 items)
 
  
CPUMotherboardGraphicsRAM
3770k 4.4 @ 1.16v z77 extreme4 290 vaporx 2x8gb 1600 1.35v 
Hard DriveCoolingOSMonitor
850 evo, 830 evo megahalem win10 ltsb qnix 
KeyboardPowerCaseMouse
ducky s3 775w arc midi storm spawn 
Mouse PadAudio
steelseries hd558, yamaha eph-100 
  hide details  
Reply
post #8 of 12
Every other release AMD drivers have problems with hardware acceleration. If it's not Firefox, it's Flash videos, or both or some other browser. I've been hearing about such problems since at least 2008 when I had it myself.

One of the reasons for the flickering seems to be that AMD doesn't handle the GDDR5 upclock and downclock as well in order to avoid such issues. It doesn't happen to everybody, so it's even harder to troubleshoot properly.

The common solutions you already know: either disable hardware acceleration and let the CPU do the work or ramp up the clocks to 3D.
 
Metro 2033 review
Metro 2033
CPUMotherboardGraphicsRAM
Core i7-3820 Asus Sabertooth X79 MSI GTX 750 Ti TF Gaming 16 GB Corsair DDR3 1866 Mhz Dominator 
Hard DriveOptical DriveCoolingOS
Samsung SSD 830 128GB + WD Caviar Black 1TB Sony Optiarc DVD-RW Corsair A70 + Noiseblocker M12-P Windows 7 Home Premium 64-bit 
MonitorKeyboardPowerCase
BenQ RL2455HM Cooler Master Octane Corsair AX750 Professional Modular 80 Plus Gold Cooler Master HAF 912 Plus 
Mouse
Cooler Master Octane 
  hide details  
Reply
 
Metro 2033 review
Metro 2033
CPUMotherboardGraphicsRAM
Core i7-3820 Asus Sabertooth X79 MSI GTX 750 Ti TF Gaming 16 GB Corsair DDR3 1866 Mhz Dominator 
Hard DriveOptical DriveCoolingOS
Samsung SSD 830 128GB + WD Caviar Black 1TB Sony Optiarc DVD-RW Corsair A70 + Noiseblocker M12-P Windows 7 Home Premium 64-bit 
MonitorKeyboardPowerCase
BenQ RL2455HM Cooler Master Octane Corsair AX750 Professional Modular 80 Plus Gold Cooler Master HAF 912 Plus 
Mouse
Cooler Master Octane 
  hide details  
Reply
post #9 of 12
have same issue. With AMD and Nvidia. No fix for this crap. Propobly u need powerfull gpu like gtx970/r9 380x or higher to fix this
post #10 of 12
Quote:
Originally Posted by boykisser View Post

What is this hotfix?
I'm currently using 15.11.1
I tried the catalyst when it came out and I was having some issues with a game and I felt like they removed a lot of the options from control panels.

http://www.overclock.net/t/1586988/amd-crimson-edition-16-1-hotfix-1-6-2016-whql

Contratry to what others may say . . . it happens to nvidia too. i have three rigs with amd gpus and none of them have this flickering issue.headscratch.gif

BTW, i came from 15.4 driver. i have an unconventional way of installing driver. i used 13 driver (still has the uninstall feature) to uninstall 15.4, reboot and installed crimson hotfix. i did not include evolved. normally i just install over the old driver.
Edited by rdr09 - 1/29/16 at 7:34pm
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Screen flickering with Firefox hardware acceleration enabled