post #1 of 1
Thread Starter 
Hey guys.

Lately I've had this issue where every mouse I plug into my PC feels weird and unresponsive, it's like the signal is loose, feels like being on 125hz or lower, when in fact I am on 1000hz. It feels like I have enabled v-sync on, but I don't.

I've tried almost everything to fix it and no luck. I've made sure vsync is off, acceleration is off, I have reinstalled windows twice, and right now reverted back to win7.. and the issue has been there for all of them, so this is clearly hardware related. I've also tried different mice, and they behave the same way. Now here comes the interesting part. I plugged in the mouse in the USB 3.0 port instead of 2.0, and it feels much better, it's not 100% fixed, but this feels lot more controllable..

How can I test to see if this is mobo related, and not any other hardware? currently using a MSI z77a-g43.

Lately when I plugged in a mouse, it also started randomly disconnecting and reconnect, this only happened for a short time though and it fixed itself.. however could also be related.

EDIT: Seem to have fixed it, atleast feels 9000x better than before. I basically went back to the stone age of a BIOS driver... took some 2012 version, one of the most early releases and it seems to have solved it so far.
Edited by Aymanb - 1/30/16 at 10:14am