post #1 of 1
Thread Starter 
Hey

Lately every mouse I plug in feels unresponsive and weird, kinda like a loose signal... however when I plug it into USB 3.0 instead of 2.0, it works much better, not entirely fixed, but much better. Also lately when I plugged a mouse in, it kept disconnecting and reconnecting, until eventually it settled down and started to work properly.

Is this motherboard/usb issues, or could it be that my mobo/usb aren't getting enough power from the PSU? because they do work when I plug them in, they just feel weird, floaty, like I've enabled v-sync or massive amount of input lag... and I've tried every single software related changing/settings, re-formatted windows, tried all the different BIOS settings, nothing helped.

EDIT: Seem to have fixed it, atleast feels 9000x better than before. I basically went back to the stone age of a BIOS driver... took some 2012 version, one of the most early releases and it seems to have solved it so far.
Edited by Aymanb - 1/30/16 at 10:14am