Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Laptop display problems
New Posts  All Forums:Forum Nav:

Laptop display problems

post #1 of 2
Thread Starter 
I have an Asus Q500A laptop that's around 3 years old. It sat for a few weeks, but today when I turned it on the dispay colors look really funky, like someone has turned it to 16 bit color mode. It's out of warranty.

Seems to me like the display connector might be loose, but does anyone have any ideas? Thanks in advance.
Crap build
(13 items)
 
  
CPUMotherboardGraphicsRAM
955 BE ASUS 790x EVO Radeon HD 4670 2x2gb G. Skill RIPJAWS 
Hard DrivePower
640gb WD Black OCZ 600w 
  hide details  
Reply
Crap build
(13 items)
 
  
CPUMotherboardGraphicsRAM
955 BE ASUS 790x EVO Radeon HD 4670 2x2gb G. Skill RIPJAWS 
Hard DrivePower
640gb WD Black OCZ 600w 
  hide details  
Reply
post #2 of 2
Thread Starter 
Guess I partially answered my own question, plugged it into a regular monitor and it works fine.
Crap build
(13 items)
 
  
CPUMotherboardGraphicsRAM
955 BE ASUS 790x EVO Radeon HD 4670 2x2gb G. Skill RIPJAWS 
Hard DrivePower
640gb WD Black OCZ 600w 
  hide details  
Reply
Crap build
(13 items)
 
  
CPUMotherboardGraphicsRAM
955 BE ASUS 790x EVO Radeon HD 4670 2x2gb G. Skill RIPJAWS 
Hard DrivePower
640gb WD Black OCZ 600w 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Laptops and Netbooks
Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Laptop display problems