Overclock.net › Forums › Components › Monitors and Displays › (NEED HELP)QNIX QX2710 Blank after showing Windows 10 Logo
New Posts  All Forums:Forum Nav:

(NEED HELP)QNIX QX2710 Blank after showing Windows 10 Logo

post #1 of 4
Thread Starter 
Hi,

I just bought the new QNIX QX2710 (with only DVI-D connection model). When I try to start the monitor, initially the monitor is working properly (power indicator showing blue light) but then after Windows 10 logo appear, the monitor suddenly become blank and the power indicator is blinking red.mad.gif
I tried to use my other monitor (Dell) and my WIndows can load perfectly. Below is the video of my problem:
https://www.youtube.com/watch?v=6omHObi9WHQ

My graphic card is GTX970 which support dual link DVI.
Anyone has the same experience like me? How to fix this?
Appreciate for the help!thumb.gif
post #2 of 4
do you have another monitor hooked up to the gtx 970? maybe the other monitor is set up as the primary display?
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
post #3 of 4
Thread Starter 
Hi,

Yes I have 3 monitor in total (including this QNIX). I did some experiment:
1. Connect only QNIX and physically disconnect the other 2 monitor. Result: as seen on video, the screen become blank after windows logo appeared.
2. Connect QNIX and 1 Dell monitor (on DisplayPort). Results: The QNIX monitor showed a boot page but after the window logo appear, the screen switch to my Dell monitor (QNIX then start to show red blinking light in its power indicator) and after that Windows run as per normal. I tried to go to NVIDIA control panel, the QNIX is only recognized as 'DVI-D' and I cannot change any resolution or setting from Display manager as well.
3. Connect QNIX and 1 LG monitor (on HDMI). Results: same as no 2.

Is this a cable issue/PCB issue/other issue? Tried to contact the seller but they haven't replied yet.
post #4 of 4
Sounds like driver issue, monitor and signal are fine.

Try uninstalling your graphics card drivers and see if the generic driver will give you a display in windows on the qnix. Then reinstall drivers maybe.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › (NEED HELP)QNIX QX2710 Blank after showing Windows 10 Logo