Overclock.net › Forums › Graphics Cards › AMD/ATI › HD 6950 on latest drivers, won't launch XCOM 2, says DX 10.1 required
New Posts  All Forums:Forum Nav:

HD 6950 on latest drivers, won't launch XCOM 2, says DX 10.1 required

post #1 of 3
Thread Starter 
Any idea why this is happening? It runs Witcher 3, and latest games just fine usually. Also it meets min requirements XCOM 2 has listened... :/
post #2 of 3
Thread Starter 
nm, just had to manually update vc redist manually in the xcom2 folder.
post #3 of 3
I'm curious to hear how it is running on your 6950. Do you recommend buying the game now, or is a GPU upgrade necessary?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HD 6950 on latest drivers, won't launch XCOM 2, says DX 10.1 required