Overclock.net › Forums › Components › Monitors and Displays › Input Lag HELP PLEASE (UGH) Insignia 42" TV
New Posts  All Forums:Forum Nav:

Input Lag HELP PLEASE (UGH) Insignia 42" TV

post #1 of 3
Thread Starter 
So, I just recently moved in with my best friend in accordance with a new job I just got. He had a ~2014 42" 120Hz Insignia LCD TV that he gave me for $100. This is far more modern, and much larger than my extremely dated ~2008 32" Haier TV. But there's a problem.

With the new display, there is a ton of input lag. As I'm typing this, my letters are showing up a few milliseconds after I'm typing them, same with my mouse cursor, in games, everywhere. I've already turned the display to normal colors, and have turned off any and ALL image enhancing features in the settings menu (as instructed by the interwebz). The display is connected via HDMI to my rig which I'll list below, and all settings in Nvidia control panel have been defaulted to try and get it back to normal as possible.

Any help would rock, I'd hate to turn down this much of an upgrade over my old setup.

Build
ASUS ROG Formula V Crosshair
FX6300 4.7GHz
16GB G.Skill DDR3 1600MHz
EVGA GTX680 overclocked
Windows 8.1 Professional
post #2 of 3
does the TV have a game mode?
post #3 of 3
Thread Starter 
Quote:
Originally Posted by thrasherht View Post

does the TV have a game mode?

From the research I've done, it does, but go figure I don't have the remote to turn it on. A remote has been ordered, for now I'm just running dual displays with my older 24" monitor.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Input Lag HELP PLEASE (UGH) Insignia 42" TV