post #1 of 1
Thread Starter 
Hi guys. Recently I'm playing Witcher 3, and after modifications I'm able to barely recieve about 18-23fps. I've made about 25% of the game, but still, it's not any smooth. I wanted to overclock the card, but I can't in any way. I've tried with Afterburner and Sapphire something, clocks stuck at 600/900 everytime. GPU usage 100% all the time, temp. about 50 C, CPU about 10%, temp about 65 C. I'm cooling it very precisely, cleaning it, look after this bastard. Today I've tried to flash the BIOS with 'atiflash' using 7970m BIOS, i found out that the hardware looks pretty much the same, i thought, I'll give it a try. I couldn't read it and save, nor flash it. Am I stuck with the clocks forever? Maybe it's possible to change the clocks in BIOS? What can I possibly do before I change my laptop?


Spec:
Samsung NP350V5C-S05PL with Win 10

Mainboard (from CPU-Z):
Model: NP350V5C-S05PL
Board ver: 00
Chipset: Ivy Bridge Rev. 09
Southbridge: HM76 Rev. 04
BIOS: AMI P10AAL (07/04/2013)
Graphics Interface PCIe x16

i7 3610QM with HD4000

2x4GB PC3-12800(800mhz) Samsung RAM

Radeon 7670M
Sysinfo from Afterburner:

Display device : AMD Radeon HD 7600M Series
BIOS : 013.012.000.045 (GPU-Z does not show BIOS, just "unknown")
GUID : VEN_1002&DEV_6840&SUBSYS_C0D8144D&REV_00&BUS_1&DEV_0&FN_0

extra from GPU-Z:
GPU: Thames
Subvendor: Samsung (144D)
Dev ID:1002-6840
DDR3 - 2GB Samsung
Bus 128 Bit
Driver (custom) 16.201.1151.1007 Beta