Overclock.net › Forums › Components › Monitors and Displays › Need some help fixing a yellow blotch on my screen
New Posts  All Forums:Forum Nav:

Need some help fixing a yellow blotch on my screen

post #1 of 16
Thread Starter 
When coming back to College, the car trip was packed with all my equipment. Unfortunately, my monitor did not come out unscathed. This was about a little more than a month ago.

I had placed my monitor ( Asus PB278Q) leaning on the car seat, so the car seat would act as a cushion from any damage. Unfortunately, my father, who does not realize how much this stuff should cost and thinks my comfort is more important then some $400 monitor), had placed a frozen water bottle ( We do that because the car trips are about 7-8 hours long, and that will keep it cool)

on where the monitor itself was leaning. As I was not in the car at the time, I couldn't stop it, but as soon as I saw it, I removed it.

Now it's damaged frown.gif.

http://i.imgur.com/1IXZyu8.jpg

http://i.imgur.com/YrN2Hbq.jpg

http://i.imgur.com/kYG8HWf.jpg

( It's the 2 yellowish dots in the middle of the screen. The screen is completely fine besides those two dots.)

I used a light source and scanned the surface of the monitors, and there seems to be no damage on the physical screen of the monitor itself, so the damage seems to be purely digital.

I'm also willing to go inside it if it will help.

I also noticed that when I press slightly on the screen where the damage is, the marks seem to get a bit more pronounced. But when I press an area to the right of the monitor, the damage seems to almost completely fade away, and even in some instances go completely away.



Any help? I was going to buy a new monitor in the coming months, but not this soon. Because of it, I've lost most of my motivation for playing on my computer. I also had bought this used, so I'm all out of luck in terms of warranty. I only have the monitor itself.

Thanks for any assistance.
Edited by enesup - 2/14/16 at 12:35pm
post #2 of 16
Can't you do a "degauss" thing like in the early days?

It should be in the menu of the OSD

I have the same monitor, but I can't acces my menu lol... I have other problems with my screen thumb.gif
   
Main Laptop
(13 items)
 
CPUMotherboardGraphicsRAM
i7 2600k 3.4GHz @ 5.2GHz ASUS P8P67 Deluxe (B3) SLi ASUS GTX780Ti DC2OC 16GB (4x 4GB) Vengeance 1866MHz @ 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
C: Crucial MX200 250GB D: Caviar Black 2TB E: Spinpoint 750GB F: Raptor 150GB (Ubuntu 12.04 Dual Boot) 
Optical DriveCoolingOSMonitor
ASUS BD Thermalright Silver Arrow Windows 7 Ultimate 64-bit Asus PB278Q 2560x1440p 
KeyboardPowerCaseMouse
Logitech G11 Corsair 1kW Antec 1200 Logitech G600 
Mouse PadAudio
A4 paper :D Logitech Z-5500 
CPUMotherboardGraphicsRAM
Q9450 (2.6GHz to 3.8GHz) ASUS 780i Striker II Formula ASUS GTX 470 8Gb (4x2Gb) Dominators 1066MHz DDR2 
Hard DriveOptical DriveOSMonitor
C: Crucial M4 256GB D: 1x Raptor 150Gb & E: + F... ASUS DVD + DVD(RW) Windows 7 Ultimate 64-bit ASUS 26" 1080p 
KeyboardPowerCaseMouse
Logitech Corsair 750W Antec 300 Logitech G5 
Mouse PadAudio
A4 paper :D ASUS Cine5 
CPUMotherboardGraphicsRAM
Intel i7 something something ASUS N750JV nVidia 750M 2x 4GB DDR3 1600 Kingston 
Hard DriveOptical DriveOSMonitor
C: Crucial MX200 mSATA 250GB + D: WD 1TB 5k4 E:... DVD-RAM DL C: Windows 7 64-bit, E: Linux Elementary OS Luna 17" 1080p 
Mouse
ASUS Optical USB 
  hide details  
Reply
   
Main Laptop
(13 items)
 
CPUMotherboardGraphicsRAM
i7 2600k 3.4GHz @ 5.2GHz ASUS P8P67 Deluxe (B3) SLi ASUS GTX780Ti DC2OC 16GB (4x 4GB) Vengeance 1866MHz @ 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
C: Crucial MX200 250GB D: Caviar Black 2TB E: Spinpoint 750GB F: Raptor 150GB (Ubuntu 12.04 Dual Boot) 
Optical DriveCoolingOSMonitor
ASUS BD Thermalright Silver Arrow Windows 7 Ultimate 64-bit Asus PB278Q 2560x1440p 
KeyboardPowerCaseMouse
Logitech G11 Corsair 1kW Antec 1200 Logitech G600 
Mouse PadAudio
A4 paper :D Logitech Z-5500 
CPUMotherboardGraphicsRAM
Q9450 (2.6GHz to 3.8GHz) ASUS 780i Striker II Formula ASUS GTX 470 8Gb (4x2Gb) Dominators 1066MHz DDR2 
Hard DriveOptical DriveOSMonitor
C: Crucial M4 256GB D: 1x Raptor 150Gb & E: + F... ASUS DVD + DVD(RW) Windows 7 Ultimate 64-bit ASUS 26" 1080p 
KeyboardPowerCaseMouse
Logitech Corsair 750W Antec 300 Logitech G5 
Mouse PadAudio
A4 paper :D ASUS Cine5 
CPUMotherboardGraphicsRAM
Intel i7 something something ASUS N750JV nVidia 750M 2x 4GB DDR3 1600 Kingston 
Hard DriveOptical DriveOSMonitor
C: Crucial MX200 mSATA 250GB + D: WD 1TB 5k4 E:... DVD-RAM DL C: Windows 7 64-bit, E: Linux Elementary OS Luna 17" 1080p 
Mouse
ASUS Optical USB 
  hide details  
Reply
post #3 of 16
Thread Starter 
I don't know how.
post #4 of 16
I'm sorry, I can't acces my menu so I don't know where the option is... (if it's there anyway...)

Have you tried another HDMI or DVI cable? Or even try VGA just to see if it might be gone if you use another input...
   
Main Laptop
(13 items)
 
CPUMotherboardGraphicsRAM
i7 2600k 3.4GHz @ 5.2GHz ASUS P8P67 Deluxe (B3) SLi ASUS GTX780Ti DC2OC 16GB (4x 4GB) Vengeance 1866MHz @ 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
C: Crucial MX200 250GB D: Caviar Black 2TB E: Spinpoint 750GB F: Raptor 150GB (Ubuntu 12.04 Dual Boot) 
Optical DriveCoolingOSMonitor
ASUS BD Thermalright Silver Arrow Windows 7 Ultimate 64-bit Asus PB278Q 2560x1440p 
KeyboardPowerCaseMouse
Logitech G11 Corsair 1kW Antec 1200 Logitech G600 
Mouse PadAudio
A4 paper :D Logitech Z-5500 
CPUMotherboardGraphicsRAM
Q9450 (2.6GHz to 3.8GHz) ASUS 780i Striker II Formula ASUS GTX 470 8Gb (4x2Gb) Dominators 1066MHz DDR2 
Hard DriveOptical DriveOSMonitor
C: Crucial M4 256GB D: 1x Raptor 150Gb & E: + F... ASUS DVD + DVD(RW) Windows 7 Ultimate 64-bit ASUS 26" 1080p 
KeyboardPowerCaseMouse
Logitech Corsair 750W Antec 300 Logitech G5 
Mouse PadAudio
A4 paper :D ASUS Cine5 
CPUMotherboardGraphicsRAM
Intel i7 something something ASUS N750JV nVidia 750M 2x 4GB DDR3 1600 Kingston 
Hard DriveOptical DriveOSMonitor
C: Crucial MX200 mSATA 250GB + D: WD 1TB 5k4 E:... DVD-RAM DL C: Windows 7 64-bit, E: Linux Elementary OS Luna 17" 1080p 
Mouse
ASUS Optical USB 
  hide details  
Reply
   
Main Laptop
(13 items)
 
CPUMotherboardGraphicsRAM
i7 2600k 3.4GHz @ 5.2GHz ASUS P8P67 Deluxe (B3) SLi ASUS GTX780Ti DC2OC 16GB (4x 4GB) Vengeance 1866MHz @ 2133MHz 
Hard DriveHard DriveHard DriveHard Drive
C: Crucial MX200 250GB D: Caviar Black 2TB E: Spinpoint 750GB F: Raptor 150GB (Ubuntu 12.04 Dual Boot) 
Optical DriveCoolingOSMonitor
ASUS BD Thermalright Silver Arrow Windows 7 Ultimate 64-bit Asus PB278Q 2560x1440p 
KeyboardPowerCaseMouse
Logitech G11 Corsair 1kW Antec 1200 Logitech G600 
Mouse PadAudio
A4 paper :D Logitech Z-5500 
CPUMotherboardGraphicsRAM
Q9450 (2.6GHz to 3.8GHz) ASUS 780i Striker II Formula ASUS GTX 470 8Gb (4x2Gb) Dominators 1066MHz DDR2 
Hard DriveOptical DriveOSMonitor
C: Crucial M4 256GB D: 1x Raptor 150Gb & E: + F... ASUS DVD + DVD(RW) Windows 7 Ultimate 64-bit ASUS 26" 1080p 
KeyboardPowerCaseMouse
Logitech Corsair 750W Antec 300 Logitech G5 
Mouse PadAudio
A4 paper :D ASUS Cine5 
CPUMotherboardGraphicsRAM
Intel i7 something something ASUS N750JV nVidia 750M 2x 4GB DDR3 1600 Kingston 
Hard DriveOptical DriveOSMonitor
C: Crucial MX200 mSATA 250GB + D: WD 1TB 5k4 E:... DVD-RAM DL C: Windows 7 64-bit, E: Linux Elementary OS Luna 17" 1080p 
Mouse
ASUS Optical USB 
  hide details  
Reply
post #5 of 16
Thread Starter 
Quote:
Originally Posted by ASUSfreak View Post

I'm sorry, I can't acces my menu so I don't know where the option is... (if it's there anyway...)

Have you tried another HDMI or DVI cable? Or even try VGA just to see if it might be gone if you use another input...

Haven't tried that, will try a bit later. Thanks for the assistance.
post #6 of 16
It's possible it might be the anti-glare film damaged, you might have to mod it and remove it
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 6700K @4.8Ghz Gigabyte Z170X Gaming 7 Gigabyte 980 ti G1 Corsair DDR4 16GB @3000mhz 
Hard DriveOptical DriveCoolingOS
Crucial M4 256GB SSD Sony DVD/RW Zalman CNPS9900-MAX Windows 8.1 Pro 
MonitorKeyboardPowerCase
Dell 27" S2716DG G-Sync 1440p Saitek Eclipse OCZ ZX 850W Storm Stryker 
Mouse
Logitech M510 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 6700K @4.8Ghz Gigabyte Z170X Gaming 7 Gigabyte 980 ti G1 Corsair DDR4 16GB @3000mhz 
Hard DriveOptical DriveCoolingOS
Crucial M4 256GB SSD Sony DVD/RW Zalman CNPS9900-MAX Windows 8.1 Pro 
MonitorKeyboardPowerCase
Dell 27" S2716DG G-Sync 1440p Saitek Eclipse OCZ ZX 850W Storm Stryker 
Mouse
Logitech M510 
  hide details  
Reply
post #7 of 16
Thread Starter 
Quote:
Originally Posted by Xboxmember1978 View Post

It's possible it might be the anti-glare film damaged, you might have to mod it and remove it

The mark seems to dissapear when I look at it from different angles. Is that what that is?

How would I go about modding it? Could someone with no experience do that easily? Or is it better to just buy a new one?
post #8 of 16
Leave it on for 24 hours with a screen saver slide show, see if it goes away or gets any better.
post #9 of 16
Can you get a good angle on it and see if it looks like small dents in the panel? You get yellow when the LED backlight hits spots like this is why I ask.
post #10 of 16
Thread Starter 
Quote:
Originally Posted by KGPrime View Post

Leave it on for 24 hours with a screen saver slide show, see if it goes away or gets any better.

I tried a Pixel fixer on youtube, the Jscreen tool on for about 8 hours and it didn't work
Edited by enesup - 2/14/16 at 8:04pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Need some help fixing a yellow blotch on my screen