Overclock.net › Forums › Intel › Intel Motherboards › Possibly dead Maximus V Formula? I have no idea
New Posts  All Forums:Forum Nav:

Possibly dead Maximus V Formula? I have no idea

post #1 of 3
Thread Starter 
Hey overclockers

I recently resurrected my MVF i5-3570K system. The watercooling was starting to suffer just around the time where I decided to upgrade to X99 so I hadn't done anything with it for a few months. Now I want to get it back and running for number crunching and maybe a few other secondary tasks.

I got the watercooling back together. The waterblocks and rads needed cleaning and I changed the route a bit cleaning it up with a few well-placed 90 degree fittings, and got most of the air out. I know there's some still in but you know how it is. I used a paperclip to run just the loop and fans overnight.

When I went to boot up the system proper this morning, I got nothing. I mean nothing. The power button on my box AND the start button on the motherboard don't work. The lights on the motherboard are on which means the PSU is supplying some form of power to the motherboard but it doesn't start at all. The fans don't spin or anything.

I had rinsed the motherboard as part of my cleaning process and the CMOS battery was out for a few days. I put the motherboard in my oven at 170F (the lowest it can go) for about a half-hour to help dry (I had to go somewhere so I turned the oven off after 30 minutes and it stayed in for a couple of hours after that). I'm starting to think that may have been a mistake.


What I've tried:

Clearing the CMOS (seems pointless with the battery out for a week) by pressing the BIOS Flashback button above the I/O: The light is solid green, turns off for a few seconds when I press it, and comes back to green.

Flashing the BIOS with the Flashback function: The USB stick is FAT32 and the file is renamed to M5F.CAP and is the only thing on the stick. The stick is in the top left USB slot (the one with the white plastic). Holding down the flashback button for any length of time does nothing. This tells me something is wrong with my BIOS chip. The chip itself looks fine but I can't say what the innards are like.


I have yet to try a different power supply, mainly because it obviously works if the motherboard lights turn on and it can spin the fans and the pump. That's going to be my next step.

I haven't tried mucking around with the RAM in different slots or running without the GPU (i5-3570K has no iGPU btw) because those suggestions are always for people whose systems TURN ON but don't post.

A google search suggested looking for shorts somewhere but I honestly can't think of anywhere that might be shorted. While I'm testing with another PSU I'll unplug as many things as I can think of (GPU, SSD, etc) to try to eliminate that as a problem, but I really just don't see it.


TL; DR: All the conventional ways to turn a PC on are not working; power button, MoBo start button, manually shorting the pins. The system shows no signs of life at all, except for the lights on the board (ROG logo etc) when the PSU is plugged in and turned on.


Any help would be greatly appreciated!


Andrew
post #2 of 3
So you poured water on your motherboard, and then baked it in the oven? Was it dirty or anything like water cooling spilled on it that made you need to clean the entire motherboard? I mean I've heard of people baking their GPUs at 170C but not a full motherboard.. And it seems you might have destroyed the motherboard, you should have baked it for 10 minutes only, not 30 minutes, and you left it in for another half an hour.. Although the oven might be off, a lot of heat was still left inside so your motherboard was still considered baking.. The motherboard might be bricked at this point, although it still recieves power.
post #3 of 3
Thread Starter 
Yeah. I was as careful as I could be when taking the loop apart but a bit of coolant (contaminated with hella algae) spilled onto the board so between that, and the dust too stuck on to vacuum, I rinsed it thoroughly in the sink, shook most of the water out, and set it in the oven.

I just don't understand why a GPU at 170C is safe but not a motherboard at 170F (yes, Farenheit, i.e. 77C).

Like, most heat-generating components can reach that temperature on their own, and they weren't even running.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Possibly dead Maximus V Formula? I have no idea