Overclock.net › Forums › Components › Monitors and Displays › Dell Ultrasharp U2312HM not displaying anything
New Posts  All Forums:Forum Nav:

Dell Ultrasharp U2312HM not displaying anything

post #1 of 2
Thread Starter 
Menu buttons still shows up so I'm thinking if it could be a problem with my DVI cable -- but have no way of checking that since I don't have any other cables.

I read online that there could be a problem with the power supply; not giving enough power to the monitor. But I was using the same setup for awhile now and there wasn't any problem until recently. The monitor started showing signs of malfunction (not displaying anything and going into sleep mode instead) about a month ago. I'm hardly ever on my desktop since I'm always working on my laptop.

I sure hope it isn't a problem with the graphics card.

Could someone help me troubleshoot or share some thoughts on this issue before I make a trip down to get a new cable?

So summary right now:
- could be the lack of power from the power supply?
- DVI cable problem?
- monitor problem

What other checks/tests can I do before moving on to changing parts to isolate the problem?
post #2 of 2
Thread Starter 
So here's an update:

1. Took out my GPU and RAM to clean the connections with an eraser and reconnected -- failed.

2. Changed my connection from DVI to HDMI -- failed.

3. Refreshed the CMOS -- failed.

4. Identified leakage from my Antec Kuhler 920 CPU cooler:






My gut tells me its the GPU that is busted. My wallet hopes its the RAM.

Anyway its about time for an upgrade. But dang this came quite suddenly.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Dell Ultrasharp U2312HM not displaying anything