Overclock.net › Forums › Components › Monitors and Displays › Installed brand new Dell S2716DG and don't have 144hz or HDCP working.
New Posts  All Forums:Forum Nav:

Installed brand new Dell S2716DG and don't have 144hz or HDCP working. - Page 2

post #11 of 16
Quote:
Originally Posted by Warrior1986 View Post

UPDATE

Bad news. Got the replacement monitor in and it has the EXACT same October 2015 manufacture date stamp on it along with the same revision number on it. I'm not even going to bother opening it up, just going to call Newegg and tell them I want to RMA the monitor and to send me a monitor that has a date stamp on it within the past few months. It's way too much of a coincidence that we are at the end of June almost and Newegg just got a new shipment of these monitors 2-3 weeks per the rep and yet I'm getting a monitor from the same batch from 9 months back even after ordering a replacement over a month later.
lol- just try it on before returning- maybe it'll work perfect. jeez.
post #12 of 16
Wait, are you trying to run it at 144Hz with a GTX 670 ? If yes, then that's your problem. You need minimum a GTX 780 for that refresh rate. I'm surprised you even RMA'd it for that.

Edit: NVM you RMA'd it for HDCP issue.
Edited by Romin - 6/27/16 at 10:21pm
post #13 of 16
You got the older A01 version that does not support HDCP. Twice? Man how unlucky. The newer A02 revision fixes that and allows HDCP support again. Along with lighter screen coating. I have one on order myself from Best Buy. I get it this week and if it shows A01 on the box. Version number is after the serial number on the box. I am not even opening it and its going straight back.
post #14 of 16
Quote:
Originally Posted by FattysGoneWild View Post

You got the older A01 version that does not support HDCP. Twice? Man how unlucky. The newer A02 revision fixes that and allows HDCP support again. Along with lighter screen coating. I have one on order myself from Best Buy. I get it this week and if it shows A01 on the box. Version number is after the serial number on the box. I am not even opening it and its going straight back.

Do you have any proof or a source of the coating being lighter??
post #15 of 16
Read about it on different forums. Cant remember where. I asked on Dell forums about it as well today.
post #16 of 16
Quote:
Originally Posted by FattysGoneWild View Post

You got the older A01 version that does not support HDCP. Twice? Man how unlucky. The newer A02 revision fixes that and allows HDCP support again. Along with lighter screen coating. I have one on order myself from Best Buy. I get it this week and if it shows A01 on the box. Version number is after the serial number on the box. I am not even opening it and its going straight back.
Have A01 and HDCP works over DP, not sure about HDMI tho.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Installed brand new Dell S2716DG and don't have 144hz or HDCP working.