Overclock.net › Forums › Graphics Cards › NVIDIA › Does a GTX 670 not support 1440p@144hz or HDCP over Displayport?
New Posts  All Forums:Forum Nav:

Does a GTX 670 not support 1440p@144hz or HDCP over Displayport?

post #1 of 31
Thread Starter 
I just upgraded my monitor from a BenQ XL2420TX to a Dell S2716DG with zero other changes. The BenQ was connected via Dual-DVI to my Gigabyte GTX 670, and Nvidia control panel showed that HDCP status was green. The Dell is connected via the included Displayport cable to the same card, and control panel is telling me the display does NOT support HDCP.

Also, it doesn't even give me the option of selecting 144hz at any resolution, regardless of G-Sync being on or not.

I tried updating the monitor driver from Dell's site, and also updated via clean DDU install to the latest Nvidia drivers. Neither made any difference. I can't test Dual-DVI because strangely this Dell doesn't have a port for it.

I paid for a 144hz, not 120hz monitor, and I need to be able to watch BluRays and other protected content on this screen. I'm afraid I'm at a loss as I have had no issue with this GTX 670 and the old BenQ. What is the problem and how do I resolve it?
Gaming Machine
(13 items)
 
Secondary Rig
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Athlon64 X2 4400+ OC'ed (2.94 GHz) Asus A8N-SLI Deluxe eVGA Geforce GTX 260 Core 216 (896-P3-1267-AR) 4x Corsair CMX512-3200XLPRO at 2-2-2-5 
Hard DriveOptical DriveOSMonitor
2x Western Digital 74GB Raptors in RAID 0 Plextor PX-716A Windows XP Pro SP3 Samsung SyncMaster 915N 
KeyboardPowerCaseMouse
Logitech G15 Gaming Keyboard PC Power and Cooling Turbo-Cool 510 ATX Custom Lian-Li PC-61 Logitech MX1000 
Mouse Pad
None 
CPUMotherboardGraphicsRAM
AMD Athlon XP 2200+ Throughbred A Asus A7V333 Visiontek GeForce 4 Ti 4600 Patriot 512MB PC-2700 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 120GB TDK CDRW5200B / TOSHIBA DVD-ROM SD-M1612 Windows XP Home SP2 Samsung SyncMaster 700NF (BEST CRT FTW!) 
KeyboardPowerCaseMouse
Microsoft Internet Keyboard Antec Truepower 430W Antec SX1040BII Microsoft Intellimouse Explorer 3.0 
  hide details  
Reply
Gaming Machine
(13 items)
 
Secondary Rig
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Athlon64 X2 4400+ OC'ed (2.94 GHz) Asus A8N-SLI Deluxe eVGA Geforce GTX 260 Core 216 (896-P3-1267-AR) 4x Corsair CMX512-3200XLPRO at 2-2-2-5 
Hard DriveOptical DriveOSMonitor
2x Western Digital 74GB Raptors in RAID 0 Plextor PX-716A Windows XP Pro SP3 Samsung SyncMaster 915N 
KeyboardPowerCaseMouse
Logitech G15 Gaming Keyboard PC Power and Cooling Turbo-Cool 510 ATX Custom Lian-Li PC-61 Logitech MX1000 
Mouse Pad
None 
CPUMotherboardGraphicsRAM
AMD Athlon XP 2200+ Throughbred A Asus A7V333 Visiontek GeForce 4 Ti 4600 Patriot 512MB PC-2700 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 120GB TDK CDRW5200B / TOSHIBA DVD-ROM SD-M1612 Windows XP Home SP2 Samsung SyncMaster 700NF (BEST CRT FTW!) 
KeyboardPowerCaseMouse
Microsoft Internet Keyboard Antec Truepower 430W Antec SX1040BII Microsoft Intellimouse Explorer 3.0 
  hide details  
Reply
post #2 of 31
Quote:
Originally Posted by Warrior1986 View Post

I just upgraded my monitor from a BenQ XL2420TX to a Dell S2716DG with zero other changes. The BenQ was connected via Dual-DVI to my Gigabyte GTX 670, and Nvidia control panel showed that HDCP status was green. The Dell is connected via the included Displayport cable to the same card, and control panel is telling me the display does NOT support HDCP.

Also, it doesn't even give me the option of selecting 144hz at any resolution, regardless of G-Sync being on or not.

I tried updating the monitor driver from Dell's site, and also updated via clean DDU install to the latest Nvidia drivers. Neither made any difference. I can't test Dual-DVI because strangely this Dell doesn't have a port for it.

I paid for a 144hz, not 120hz monitor, and I need to be able to watch BluRays and other protected content on this screen. I'm afraid I'm at a loss as I have had no issue with this GTX 670 and the old BenQ. What is the problem and how do I resolve it?

Windows 10? I had some issues with windows 10 where i'd have to un-seat, and reseat the cable for the display to work properly. Worked fine with 7-8-8.1 though.
 
Spare Gaming Rig
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7 7700k @ 4903 Mhz @1.312v 24/7 Asrock Z270 Taichi eVGA GTX 1080 ACX 3.0 G.Skill Flare X 16GB 3200CL14 
Hard DriveHard DriveCoolingMonitor
256GB Samsung 850 Pro 1TB Samsung 850 Evo NZXT Kraken X52 Dell S2417DG 165Hz 1440p G-Sync 
KeyboardPowerCaseMouse
Razer Blackwidow X Chroma - Mercury Edition Corsair 750 RM Phanteks Evolv ATX Razer Lancehead Tournament Edition Mercury Edition 
Mouse PadAudio
Razer Firefly - Cloth Razer Kraken 7.1 V2 Mercury Edition 
CPUMotherboardGraphicsRAM
i7 4790k @ 4.6Ghz Asus MAXIMUS VII GENE GTX 980 Ti @ 1400 Mhz 4 x 4GB (16GB) Corsair LPX DDR3 
Hard DriveHard DriveCoolingOS
240GB Seagate 1TB RAID HDD Cosair H240 Windows 10 
MonitorKeyboardPower
Asus P278Q Razer BlackWidow Corsair 650W 
  hide details  
Reply
 
Spare Gaming Rig
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7 7700k @ 4903 Mhz @1.312v 24/7 Asrock Z270 Taichi eVGA GTX 1080 ACX 3.0 G.Skill Flare X 16GB 3200CL14 
Hard DriveHard DriveCoolingMonitor
256GB Samsung 850 Pro 1TB Samsung 850 Evo NZXT Kraken X52 Dell S2417DG 165Hz 1440p G-Sync 
KeyboardPowerCaseMouse
Razer Blackwidow X Chroma - Mercury Edition Corsair 750 RM Phanteks Evolv ATX Razer Lancehead Tournament Edition Mercury Edition 
Mouse PadAudio
Razer Firefly - Cloth Razer Kraken 7.1 V2 Mercury Edition 
CPUMotherboardGraphicsRAM
i7 4790k @ 4.6Ghz Asus MAXIMUS VII GENE GTX 980 Ti @ 1400 Mhz 4 x 4GB (16GB) Corsair LPX DDR3 
Hard DriveHard DriveCoolingOS
240GB Seagate 1TB RAID HDD Cosair H240 Windows 10 
MonitorKeyboardPower
Asus P278Q Razer BlackWidow Corsair 650W 
  hide details  
Reply
post #3 of 31
Quote:
Originally Posted by Warrior1986 View Post

I just upgraded my monitor from a BenQ XL2420TX to a Dell S2716DG with zero other changes. The BenQ was connected via Dual-DVI to my Gigabyte GTX 670, and Nvidia control panel showed that HDCP status was green. The Dell is connected via the included Displayport cable to the same card, and control panel is telling me the display does NOT support HDCP.

Also, it doesn't even give me the option of selecting 144hz at any resolution, regardless of G-Sync being on or not.

I tried updating the monitor driver from Dell's site, and also updated via clean DDU install to the latest Nvidia drivers. Neither made any difference. I can't test Dual-DVI because strangely this Dell doesn't have a port for it.

I paid for a 144hz, not 120hz monitor, and I need to be able to watch BluRays and other protected content on this screen. I'm afraid I'm at a loss as I have had no issue with this GTX 670 and the old BenQ. What is the problem and how do I resolve it?

Trying connecting ONLY the Dell and disconnect the BenQ - and see if the Dell works by itself at 144Hz?
post #4 of 31
Thread Starter 
Quote:
Originally Posted by Shiftstealth View Post

Windows 10? I had some issues with windows 10 where i'd have to un-seat, and reseat the cable for the display to work properly. Worked fine with 7-8-8.1 though.

Nope, still on Win7 here.
Quote:
Originally Posted by speedyeggtart View Post

Trying connecting ONLY the Dell and disconnect the BenQ - and see if the Dell works by itself at 144Hz?

The BenQ has been totally connected and removed from the system.
Gaming Machine
(13 items)
 
Secondary Rig
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Athlon64 X2 4400+ OC'ed (2.94 GHz) Asus A8N-SLI Deluxe eVGA Geforce GTX 260 Core 216 (896-P3-1267-AR) 4x Corsair CMX512-3200XLPRO at 2-2-2-5 
Hard DriveOptical DriveOSMonitor
2x Western Digital 74GB Raptors in RAID 0 Plextor PX-716A Windows XP Pro SP3 Samsung SyncMaster 915N 
KeyboardPowerCaseMouse
Logitech G15 Gaming Keyboard PC Power and Cooling Turbo-Cool 510 ATX Custom Lian-Li PC-61 Logitech MX1000 
Mouse Pad
None 
CPUMotherboardGraphicsRAM
AMD Athlon XP 2200+ Throughbred A Asus A7V333 Visiontek GeForce 4 Ti 4600 Patriot 512MB PC-2700 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 120GB TDK CDRW5200B / TOSHIBA DVD-ROM SD-M1612 Windows XP Home SP2 Samsung SyncMaster 700NF (BEST CRT FTW!) 
KeyboardPowerCaseMouse
Microsoft Internet Keyboard Antec Truepower 430W Antec SX1040BII Microsoft Intellimouse Explorer 3.0 
  hide details  
Reply
Gaming Machine
(13 items)
 
Secondary Rig
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Athlon64 X2 4400+ OC'ed (2.94 GHz) Asus A8N-SLI Deluxe eVGA Geforce GTX 260 Core 216 (896-P3-1267-AR) 4x Corsair CMX512-3200XLPRO at 2-2-2-5 
Hard DriveOptical DriveOSMonitor
2x Western Digital 74GB Raptors in RAID 0 Plextor PX-716A Windows XP Pro SP3 Samsung SyncMaster 915N 
KeyboardPowerCaseMouse
Logitech G15 Gaming Keyboard PC Power and Cooling Turbo-Cool 510 ATX Custom Lian-Li PC-61 Logitech MX1000 
Mouse Pad
None 
CPUMotherboardGraphicsRAM
AMD Athlon XP 2200+ Throughbred A Asus A7V333 Visiontek GeForce 4 Ti 4600 Patriot 512MB PC-2700 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 120GB TDK CDRW5200B / TOSHIBA DVD-ROM SD-M1612 Windows XP Home SP2 Samsung SyncMaster 700NF (BEST CRT FTW!) 
KeyboardPowerCaseMouse
Microsoft Internet Keyboard Antec Truepower 430W Antec SX1040BII Microsoft Intellimouse Explorer 3.0 
  hide details  
Reply
post #5 of 31
Quote:
Originally Posted by Warrior1986 View Post

Nope, still on Win7 here.
The BenQ has been totally connected and removed from the system.

I could still try suggesting an older driver. Maybe one from the 670's release. Might be worth a shot. redface.gif
 
Spare Gaming Rig
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7 7700k @ 4903 Mhz @1.312v 24/7 Asrock Z270 Taichi eVGA GTX 1080 ACX 3.0 G.Skill Flare X 16GB 3200CL14 
Hard DriveHard DriveCoolingMonitor
256GB Samsung 850 Pro 1TB Samsung 850 Evo NZXT Kraken X52 Dell S2417DG 165Hz 1440p G-Sync 
KeyboardPowerCaseMouse
Razer Blackwidow X Chroma - Mercury Edition Corsair 750 RM Phanteks Evolv ATX Razer Lancehead Tournament Edition Mercury Edition 
Mouse PadAudio
Razer Firefly - Cloth Razer Kraken 7.1 V2 Mercury Edition 
CPUMotherboardGraphicsRAM
i7 4790k @ 4.6Ghz Asus MAXIMUS VII GENE GTX 980 Ti @ 1400 Mhz 4 x 4GB (16GB) Corsair LPX DDR3 
Hard DriveHard DriveCoolingOS
240GB Seagate 1TB RAID HDD Cosair H240 Windows 10 
MonitorKeyboardPower
Asus P278Q Razer BlackWidow Corsair 650W 
  hide details  
Reply
 
Spare Gaming Rig
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7 7700k @ 4903 Mhz @1.312v 24/7 Asrock Z270 Taichi eVGA GTX 1080 ACX 3.0 G.Skill Flare X 16GB 3200CL14 
Hard DriveHard DriveCoolingMonitor
256GB Samsung 850 Pro 1TB Samsung 850 Evo NZXT Kraken X52 Dell S2417DG 165Hz 1440p G-Sync 
KeyboardPowerCaseMouse
Razer Blackwidow X Chroma - Mercury Edition Corsair 750 RM Phanteks Evolv ATX Razer Lancehead Tournament Edition Mercury Edition 
Mouse PadAudio
Razer Firefly - Cloth Razer Kraken 7.1 V2 Mercury Edition 
CPUMotherboardGraphicsRAM
i7 4790k @ 4.6Ghz Asus MAXIMUS VII GENE GTX 980 Ti @ 1400 Mhz 4 x 4GB (16GB) Corsair LPX DDR3 
Hard DriveHard DriveCoolingOS
240GB Seagate 1TB RAID HDD Cosair H240 Windows 10 
MonitorKeyboardPower
Asus P278Q Razer BlackWidow Corsair 650W 
  hide details  
Reply
post #6 of 31
Quote:
Originally Posted by Warrior1986 View Post

Nope, still on Win7 here.
The BenQ has been totally connected and removed from the system.

Did you used the included DisplayPort cable that came with the Dell? If not, what brand and how long is the DisplayPort cable you are using?
post #7 of 31
Thread Starter 
Quote:
Originally Posted by Shiftstealth View Post

I could still try suggesting an older driver. Maybe one from the 670's release. Might be worth a shot. redface.gif

Hadn't considered that as it would be pretty strange if it worked, but at this point I'm willing to try it out.
Quote:
Originally Posted by speedyeggtart View Post

Did you used the included DisplayPort cable that came with the Dell? If not, what brand and how long is the DisplayPort cable you are using?

Yes I sure did.
Gaming Machine
(13 items)
 
Secondary Rig
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Athlon64 X2 4400+ OC'ed (2.94 GHz) Asus A8N-SLI Deluxe eVGA Geforce GTX 260 Core 216 (896-P3-1267-AR) 4x Corsair CMX512-3200XLPRO at 2-2-2-5 
Hard DriveOptical DriveOSMonitor
2x Western Digital 74GB Raptors in RAID 0 Plextor PX-716A Windows XP Pro SP3 Samsung SyncMaster 915N 
KeyboardPowerCaseMouse
Logitech G15 Gaming Keyboard PC Power and Cooling Turbo-Cool 510 ATX Custom Lian-Li PC-61 Logitech MX1000 
Mouse Pad
None 
CPUMotherboardGraphicsRAM
AMD Athlon XP 2200+ Throughbred A Asus A7V333 Visiontek GeForce 4 Ti 4600 Patriot 512MB PC-2700 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 120GB TDK CDRW5200B / TOSHIBA DVD-ROM SD-M1612 Windows XP Home SP2 Samsung SyncMaster 700NF (BEST CRT FTW!) 
KeyboardPowerCaseMouse
Microsoft Internet Keyboard Antec Truepower 430W Antec SX1040BII Microsoft Intellimouse Explorer 3.0 
  hide details  
Reply
Gaming Machine
(13 items)
 
Secondary Rig
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Athlon64 X2 4400+ OC'ed (2.94 GHz) Asus A8N-SLI Deluxe eVGA Geforce GTX 260 Core 216 (896-P3-1267-AR) 4x Corsair CMX512-3200XLPRO at 2-2-2-5 
Hard DriveOptical DriveOSMonitor
2x Western Digital 74GB Raptors in RAID 0 Plextor PX-716A Windows XP Pro SP3 Samsung SyncMaster 915N 
KeyboardPowerCaseMouse
Logitech G15 Gaming Keyboard PC Power and Cooling Turbo-Cool 510 ATX Custom Lian-Li PC-61 Logitech MX1000 
Mouse Pad
None 
CPUMotherboardGraphicsRAM
AMD Athlon XP 2200+ Throughbred A Asus A7V333 Visiontek GeForce 4 Ti 4600 Patriot 512MB PC-2700 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 120GB TDK CDRW5200B / TOSHIBA DVD-ROM SD-M1612 Windows XP Home SP2 Samsung SyncMaster 700NF (BEST CRT FTW!) 
KeyboardPowerCaseMouse
Microsoft Internet Keyboard Antec Truepower 430W Antec SX1040BII Microsoft Intellimouse Explorer 3.0 
  hide details  
Reply
post #8 of 31
Your GTX 670 simply doesn't support 1440p 144Hz. It can only do 1440 120Hz.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k MSI Z97 Gaming 5 GTX 1070 Gaming X HyperX Fury 16GB 
Hard DriveCoolingOSMonitor
Samsung 850 EVO 250GB + X25-M 80GB Noctua NH-D15 Windows 10 MG279Q 1440p 144hz 
KeyboardPowerMouseAudio
QuickFire TK Cooler Master V750 Logitech G402 HD 558 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k MSI Z97 Gaming 5 GTX 1070 Gaming X HyperX Fury 16GB 
Hard DriveCoolingOSMonitor
Samsung 850 EVO 250GB + X25-M 80GB Noctua NH-D15 Windows 10 MG279Q 1440p 144hz 
KeyboardPowerMouseAudio
QuickFire TK Cooler Master V750 Logitech G402 HD 558 
  hide details  
Reply
post #9 of 31
Quote:
Originally Posted by Blackcurrent View Post

Your GTX 670 simply doesn't support 1440p 144Hz. It can only do 1440 120Hz.

Are you sure I have a friend with this exact issue using a GTX980.
XForma
(5 items)
 
  
KeyboardCaseMouseMouse Pad
K-Type  XForma FM Classic Ergo 2 White QCK Heavy 
  hide details  
Reply
XForma
(5 items)
 
  
KeyboardCaseMouseMouse Pad
K-Type  XForma FM Classic Ergo 2 White QCK Heavy 
  hide details  
Reply
post #10 of 31
Quote:
Originally Posted by invena View Post

Are you sure I have a friend with this exact issue using a GTX980.

I had a 970 and worked just fine at 2560x1440 144hz. Previously I had a GTX 670 and had this problem so I did a bit of research and confirmed I wasn't the only one with the issue. Only seems to happen to older generations. Perhaps its because it uses an older DisplayPort version thus not supporting the amount of bandwidth required for 1440p 144Hz.
Edited by Blackcurrent - 6/16/16 at 1:00am
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k MSI Z97 Gaming 5 GTX 1070 Gaming X HyperX Fury 16GB 
Hard DriveCoolingOSMonitor
Samsung 850 EVO 250GB + X25-M 80GB Noctua NH-D15 Windows 10 MG279Q 1440p 144hz 
KeyboardPowerMouseAudio
QuickFire TK Cooler Master V750 Logitech G402 HD 558 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k MSI Z97 Gaming 5 GTX 1070 Gaming X HyperX Fury 16GB 
Hard DriveCoolingOSMonitor
Samsung 850 EVO 250GB + X25-M 80GB Noctua NH-D15 Windows 10 MG279Q 1440p 144hz 
KeyboardPowerMouseAudio
QuickFire TK Cooler Master V750 Logitech G402 HD 558 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Does a GTX 670 not support 1440p@144hz or HDCP over Displayport?