Overclock.net › Forums › Cooling › Water Cooling › Corsair Hydro Series H100i GTX Question
New Posts  All Forums:Forum Nav:

Corsair Hydro Series H100i GTX Question - Page 2

post #11 of 14
Thread Starter 
LOL. Let me explain again.

I had a DIFFERENT Corsair cooler on my 4930k. When I got my H100i I didn't install anything from the package except the new cooler. When I attached it to my x79 deluxe there was already a back plate on it from the previous Corsair cooler. Does that make sense?

Therefore I didn't use any of the parts from the bag in the box except the screws. Then when I tried to find the box today I couldn't and here we are.

So once again I ask..... do I need to worry about the cooler not fitting on my 6700k since I don't have a back plate for it? If the cooler doesn't actually HAVE a back plate can I still attach it to my new board? I got an ASUS ATX DDR4 2667 LGA 1151 SABERTOOTH Z170 S Motherboard.
post #12 of 14
Ohhh makes sense now... Im affraid your probably SOL because the mounting holes on you new mobo are ever so slightly inward not allowing the same backplate or whatever you want to call it to be used unless its designed to be compatible. The corsair mounting backplate for intel has moveable rubber screw holes that slide inward enough to switch between the two different sockets. So unless your previous cooler was also 115x compatable and has the same system then when you try to line the mounting plate up it wont work... See in this image how the screw holes are like plastic pieces that can slide outward? unless your backplate can adjust like that then you might need to buy the right parts. I dont think they are expensive, you can probably get it for less than $20 but im not sure...
post #13 of 14
Open your case and take a peek at the mounting plate and see if the screw holes can be adjusted... If soo then i dont see why you cant just use it again
post #14 of 14
Quote:
Originally Posted by Dissolution187 View Post

LOL. Let me explain again.

I had a DIFFERENT Corsair cooler on my 4930k. When I got my H100i I didn't install anything from the package except the new cooler. When I attached it to my x79 deluxe there was already a back plate on it from the previous Corsair cooler. Does that make sense?

Therefore I didn't use any of the parts from the bag in the box except the screws. Then when I tried to find the box today I couldn't and here we are.

So once again I ask..... do I need to worry about the cooler not fitting on my 6700k since I don't have a back plate for it? If the cooler doesn't actually HAVE a back plate can I still attach it to my new board? I got an ASUS ATX DDR4 2667 LGA 1151 SABERTOOTH Z170 S Motherboard.

No, it doesn't make sense.....because LGA 2011 does not use a backplate for Corsair coolers. In addition, it uses different standoffs than LGA 1151.

Long and short of it - you need to order a mounting kit - http://www.corsair.com/se-fi/h80i-gt-h100i-gtx-h110i-gtx-mounting-hardware-kit

You will need to contact Corsair to get it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Corsair Hydro Series H100i GTX Question