Overclock.net › Forums › Components › Sound Cards and Computer Audio › Trouble with XFi drivers
New Posts  All Forums:Forum Nav:

Trouble with XFi drivers

post #1 of 3
Thread Starter 
So I just installed the P2 PSU yesterday (overkill I know, but been meaning to upgrade and was a good price) and all has been well. I was playing a bit of CSGO this morning and things were fine, then it exited to desktop (as it has been doing on and off for some time now anyways) and my sound was gone. Okay, I figured I just need to reinstall the XFi drivers as I've done before. I have the most recent Windows 10 drivers from Creative's site. I get the infamous "Setup is unable to detect a supported product on your system" message when trying to install.

I know this has been discussed before but I didn't see anything too recent. I've uninstalled old drivers and onboard has always been disabled. Device manager had no missing drivers and only "High Definition Audio Device," which I believe is referring to my monitor, but I did try and update those as well just in case. Nothing. I just now reseated the card in its slot and now I have a "Multimedia Audio Controller" unknown in device manager. Okay, figured that would at least let me install the drivers now, but nope, same problem. I right clicked that in device manager to try and update and it didn't find anything.

Anyone have any thoughts on this? I don't really see how it could be due to the PSU but that's the only hardware that has been changed recently, and the sound was working fine yesterday and this morning. Is it just time to ditch the card maybe? It's done me well for probably 6 or 7 years now so that wouldn't really bother me to be honest.

Thanks in advance for any help!
Boats 'N Hoes
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570k @ 4.4 ASUS P8Z77-V Pro MSI GTX 1060 Gaming X Samsung 8gb @ 2133 CL9 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 500gb WD1001FALS WD10EZEX WD5000AAKS 
Optical DriveCoolingOSMonitor
LG DVDRW Hyper 212+ Windows 10 x64 Dell U2715H 
KeyboardPowerCaseMouse
Ducky Shine II MX Reds, White LED EVGA SuperNOVA P2 650w Antec P180 Roccat Kone XTD Optical 
AudioOther
SB XFi XtremeMusic Klipsch ProMedia 2.1 
  hide details  
Reply
Boats 'N Hoes
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570k @ 4.4 ASUS P8Z77-V Pro MSI GTX 1060 Gaming X Samsung 8gb @ 2133 CL9 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 500gb WD1001FALS WD10EZEX WD5000AAKS 
Optical DriveCoolingOSMonitor
LG DVDRW Hyper 212+ Windows 10 x64 Dell U2715H 
KeyboardPowerCaseMouse
Ducky Shine II MX Reds, White LED EVGA SuperNOVA P2 650w Antec P180 Roccat Kone XTD Optical 
AudioOther
SB XFi XtremeMusic Klipsch ProMedia 2.1 
  hide details  
Reply
post #2 of 3
Are you sure about getting the Xtreme Music driver, and did you use admin privilege?
High Definition Audio Device might be your 680, so you should be able to disable it.
Did you select your sound card as the default device?
post #3 of 3
Thread Starter 
Thanks for the response. Yes I'm sure about the driver, and no I didn't use admin, but the same thing happened. I didn't think about the HD audio device being my 680, but the whole thing about selecting my sound card as the default device can't be done if you can't even install the drivers. That's the problem.'
Boats 'N Hoes
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570k @ 4.4 ASUS P8Z77-V Pro MSI GTX 1060 Gaming X Samsung 8gb @ 2133 CL9 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 500gb WD1001FALS WD10EZEX WD5000AAKS 
Optical DriveCoolingOSMonitor
LG DVDRW Hyper 212+ Windows 10 x64 Dell U2715H 
KeyboardPowerCaseMouse
Ducky Shine II MX Reds, White LED EVGA SuperNOVA P2 650w Antec P180 Roccat Kone XTD Optical 
AudioOther
SB XFi XtremeMusic Klipsch ProMedia 2.1 
  hide details  
Reply
Boats 'N Hoes
(18 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570k @ 4.4 ASUS P8Z77-V Pro MSI GTX 1060 Gaming X Samsung 8gb @ 2133 CL9 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 500gb WD1001FALS WD10EZEX WD5000AAKS 
Optical DriveCoolingOSMonitor
LG DVDRW Hyper 212+ Windows 10 x64 Dell U2715H 
KeyboardPowerCaseMouse
Ducky Shine II MX Reds, White LED EVGA SuperNOVA P2 650w Antec P180 Roccat Kone XTD Optical 
AudioOther
SB XFi XtremeMusic Klipsch ProMedia 2.1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Trouble with XFi drivers