Overclock.net › Forums › Volt Mods › General Volt Mods › Graphics Cards Volt Mods › Zotac GTX 970 AMP! Omega voltage issues.
New Posts  All Forums:Forum Nav:

Zotac GTX 970 AMP! Omega voltage issues.

post #1 of 7
Thread Starter 
Hello everyone, I got my hands on a GTX 970 AMP! Omega from Zotac and im pretty pleased with it's build quality, allthough, as the title says, it has some weird voltage issues. You can use OC+ combined with the Firestorm utility to set a voltage of 1.26 Stock, but because I'm on watercooling I've modified the BIOS to max. 1.312 Volts, my question now is, why 1) doesn't it go any higher than 1.234 Volt without any manual adjustmenst 2) when I force the 1.312 Volt through with Firestorm the max stable clock decreases 20 Mhz ,meaning '1.234Volts == 1530 Mhz' and
'1.312 Volt == 1500Mhz' , why does it do that, and can I hard or even soft? mod it in any way to prevent this kind of acting? I've searched through google for hours and I can't find a soloution why this card does that. Also using heaven benchmark, the card uses about 170 watts at 37C°, using furmark it goes up to 270 watts at 46C° and at both benchmarks the same thing happens with the voltage-clock issue. I'd really appreciate anyone giving this a shot and helping lots of other "desperate" Zotac owners, because this is pcb "viewed" a very good card, until you look at it's BIOS , etc...
Well hope someone can help me! tongue.gif
post #2 of 7

needs BIOS edit to open up current range

post #3 of 7
Thread Starter 
I already did a BIOS mod on it and increased the power on everything... what do I have to edit to "open up current range" ? I have to use Maxwell BIOS editor??
post #4 of 7

you have to raise the TDP limits in the BIOS for your 3D states (P0 and what every boost state your card uses by default.

 

*post a copy of your bios and I will edit it for you to compare.

post #5 of 7
Thread Starter 
Hey man, thanks for attenpting to help me, unfortunate thing i just changed CPU so i cant sent you mine ATM, also ive found out thru gpuz that my perfcap reason is "vrel" reliability, if thats any useful. You can search for my BIOS in the Internet a good one would be "Joe dirt's zotac 970 AMP omega(or extreme idk, both are same)" vor just search for "Zotac 970 AMP Omega BIos" you will find it if you're willing to help me. Would highly appreciate it!
Quote:
Originally Posted by CL3P20 View Post

you have to raise the TDP limits in the BIOS for your 3D states (P0 and what every boost state your card uses by default.

*post a copy of your bios and I will edit it for you to compare.
Quote:
Originally Posted by CL3P20 View Post

you have to raise the TDP limits in the BIOS for your 3D states (P0 and what every boost state your card uses by default.

*post a copy of your bios and I will edit it for you to compare.
post #6 of 7
Thread Starter 
This would be my stock BIOS: I got it in my hands anyways. http://www10.zippyshare.com/v/LmSXg21o/file.html
post #7 of 7
Thread Starter 
BIOS: http://www10.zippyshare.com/v/LmSXg21o/file.html
Quote:
Originally Posted by CL3P20 View Post

you have to raise the TDP limits in the BIOS for your 3D states (P0 and what every boost state your card uses by default.

*post a copy of your bios and I will edit it for you to compare.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards Volt Mods
Overclock.net › Forums › Volt Mods › General Volt Mods › Graphics Cards Volt Mods › Zotac GTX 970 AMP! Omega voltage issues.