Overclock.net › Forums › Graphics Cards › AMD/ATI › Polaris Bios Editing ( RX5xx / RX4xx )
New Posts  All Forums:Forum Nav:

Polaris Bios Editing ( RX5xx / RX4xx ) - Page 227

post #2261 of 3354
Quote:
Originally Posted by Xcat2008 View Post

@robnitro Now i got more free time, give +20 Power Limit on Wattman and works now xD No crash nothing xD Thank you AMD, for this Free card by Download lol


Edit:

WoW my Vram goes hot changing the Power Limit while benchmarking xD Before 72 Degrees xD


Man, vrm is not vram. You shouldn't worry until you're under 100c, anyway.
post #2262 of 3354
Quote:
Originally Posted by SSBrain View Post

I tried that too in the past as I have one too. It cannot be flashed to 8GB (even though the memory can be easily clocked over 2000 MHz), and no matter if you modify bios value to make it think it has 8GB.
Eventually, I removed the cooler and realized that the memory chips themselves (8 of them) are 512 MByte chips, i.e. 4 gigabit. Their code begins with K4G4.

Well that is a shame, when i put the 8gb bios and the gpu showed the 8gb i got all hyped....bad luck i guess, still this memorys are good.
post #2263 of 3354
My results have been crazy good https://youtu.be/YnuRcx_xRlM
Double Dragon
(16 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX-8370 970 PRO GAMING/AURA Radeon (TM) RX 480 Graphics Radeon (TM) RX 480 Graphics 
RAMRAMRAMRAM
Crucial Technology  Crucial Technology  Crucial Technology  Crucial Technology  
CoolingOSMonitorKeyboard
Corsair H110i Windows 10 X64 HP 27es Corsair K55 RGB 
PowerCaseMouseMouse Pad
Rosewill Hive 1000 Watt Bronze Certified Phateks P400 Tempered Glass Red/Black Corsair Harpoon RGB Corsair MM800 RGB 
  hide details  
Reply
Double Dragon
(16 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX-8370 970 PRO GAMING/AURA Radeon (TM) RX 480 Graphics Radeon (TM) RX 480 Graphics 
RAMRAMRAMRAM
Crucial Technology  Crucial Technology  Crucial Technology  Crucial Technology  
CoolingOSMonitorKeyboard
Corsair H110i Windows 10 X64 HP 27es Corsair K55 RGB 
PowerCaseMouseMouse Pad
Rosewill Hive 1000 Watt Bronze Certified Phateks P400 Tempered Glass Red/Black Corsair Harpoon RGB Corsair MM800 RGB 
  hide details  
Reply
post #2264 of 3354
Anyone know which data table is responsible for configuring the display outputs? It looks the asus strix rx470 is one of the only cards that has a dual dvi setup. The sapphire rx570 bios works well, but at the cost of one of the dvi ports.

These are the data tables for the sapphire rx570 bios:
Code:
Data Tables:
  0000:   -                          (UtilityPipeLine)
  0001:   -                          (MultimediaCapabilityInfo)
  0002:   -                          (MultimediaConfigInfo)
  0003:   9854  Len 00e4  Rev 01:02  (StandardVESA_Timing)    (struct size 01c4)
  0004:   9938  Len 006c  Rev 02:02  (FirmwareInfo)    (struct size 006c)
  0005:   99a4  Len 0034  Rev 02:01  (DAC_Info)    (struct size 0008)
  0006:   99d8  Len 004e  Rev 01:03  (LVDS_Info)    (struct size 0034)
  0007:   -                          (TMDS_Info)
  0008:   acf8  Len 0038  Rev 02:01  (AnalogTV_Info)    (struct size 0048)
  0009:   -                          (SupportedDevicesInfo)
  000a:   9a26  Len 00dc  Rev 01:01  (GPIO_I2C_Info)
  000b:   9b02  Len 000c  Rev 01:05  (VRAM_UsageByFirmware)    (struct size 000c)
  000c:   9b0e  Len 0020  Rev 01:01  (GPIO_Pin_LUT)
  000d:   9b2e  Len 0074  Rev 01:01  (VESA_ToInternalModeLUT)
  000e:   9ba2  Len 0018  Rev 02:03  (ComponentVideoInfo)
  000f:   9bba  Len 0341  Rev 07:01  (PowerPlayInfo)
  0010:   -                          (CompassionateData)
  0011:   ace0  Len 0018  Rev 02:01  (SaveRestoreInfo/DispDevicePriorityInfo)
  0012:   -                          (PPLL_SS_Info/SS_Info)
  0013:   9efc  Len 0005  Rev 01:01  (OemInfo)    (struct size 0005)
  0014:   -                          (XTMDS_Info)
  0015:   -                          (MclkSS_Info)
  0016:   9f02  Len 015e  Rev 01:03  (Object_Info/Object_Header)    (struct size 0010)
  0017:   a334  Len 007d  Rev 01:01  (IndirectIOAccess)
  0018:   a060  Len 02d4  Rev 02:01  (MC_InitParameter/AdjustARB_SEQ)
  0019:   -                          (ASIC_VDDC_Info)
  001a:   ac54  Len 0028  Rev 03:01  (ASIC_InternalSS_Info/ASIC_MVDDC_Info)    (struct size 0034)
  001b:   ac7c  Len 0064  Rev 02:03  (TV_VideoMode/DispOutInfo)
  001c:   a3b2  Len 0753  Rev 02:02  (VRAM_Info)    (struct size 0354)
  001d:   -                          (MemoryTrainingInfo/ASIC_MVDDQ_Info)
  001e:   -                          (IntegratedSystemInfo)
  001f:   ab06  Len 010c  Rev 03:06  (ASIC_ProfilingInfo/ASIC_VDDCI_Info)    (struct size 0022)
  0020:   ac12  Len 0042  Rev 03:01  (VoltageObjectInfo/VRAM_GPIO_DetectionInfo)
  0021:   -                          (PowerSourceInfo)

I'd like to try swapping in the table from my original bios (Lard's table calculator).

DispOutInfo seems like a likely candidate.
post #2265 of 3354
I have HIS rx 470 İcooler 4gb ( overclocked 1335-1850) can I flash it to rx 570 ?

What should I do if I can smile.gif ?
4790K BEAST
(14 items)
 
  
Reply
4790K BEAST
(14 items)
 
  
Reply
post #2266 of 3354
Quote:
Originally Posted by daevy3k View Post

Man, vrm is not vram. You shouldn't worry until you're under 100c, anyway.

I know, misstype my friend smile.gif Alredy edited. 100c or a little more not much, 150c from the datasheet will just burn/blow.
post #2267 of 3354
If anyone thinks they are bricked yet still starting up and unable to get into windows then maybe you can dos flash it? Here's an ISO I made it works.. it has ATIFlash.exe on there.... download UltraISO and drag your ellesmere.rom in the root and save... then burn to cd .. boot to cd and type e:\ i think then dir /w .. make sure ellesmere is in there... It might be d:\ .. try different letters until you find the cd directory... start up with CD Support... then...

atiflash -p -f 0 ellesmere.rom ....

Done
thumb.gif

WIN98SE_AMD.zip 1706k .zip file
post #2268 of 3354
Flashed MSI rx470 gaming to MSI rx570 gaming from TPU but had far too many artifacts even at the desktop so flashed back. Like other had to do it via command line due to subsystem I'd mismatch.

Sent from my SM-N920P using Tapatalk
post #2269 of 3354
Has anybody tried some Multimonitor-Setup? Over at TPU it's said, that some cards loose one Displayport when modified.

€dit: I did a backup of my XFX RX 480 BIOS and that's 512K in size. All downloaded BIOSes have 256k. Is that ok?
post #2270 of 3354
Thread Starter 
Quote:
Originally Posted by Y0shi View Post

Has anybody tried some Multimonitor-Setup? Over at TPU it's said, that some cards loose one Displayport when modified.

€dit: I did a backup of my XFX RX 480 BIOS and that's 512K in size. All downloaded BIOSes have 256k. Is that ok?
Yes polaris is 256k of code and 256k empty. So no problem flashing a 256k bios.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Polaris Bios Editing ( RX5xx / RX4xx )