Overclock.net › Forums › Graphics Cards › AMD/ATI › Polaris Bios Editing ( RX5xx / RX4xx )
New Posts  All Forums:Forum Nav:

Polaris Bios Editing ( RX5xx / RX4xx ) - Page 8

post #71 of 4829
Yes, i accidentally flashed the 128kb rom file rolleyes.gif
The 512kb files just include some code at Offset 0x38000 with length 0x7EE4, seems identical on the 4GB and 8GB version so we probably just need to replace the first 128kb on the 512kb files.
Edited by PCIEgate - 7/5/16 at 3:34pm
post #72 of 4829
Thread Starter 
only use 512KB rom files
post #73 of 4829
Quote:
Originally Posted by PCIEgate View Post

BIOS flash is available now: techpowerup

Tested the 8GB BIOS on my 4GB card and started this vram testing tool two times:

Another test with the 4GB BIOS and direct3dtest.exe four times opened:

post #74 of 4829
as vrm controller is same as on hawaii it will be maybe interesting to include vrm reading as its implemented in hawaii bios reader wink.gif
FX
(7 items)
 
  
CPUMotherboardGraphicsRAM
FX-8320@4.4Ghz M5A99FX PRO R2.0 AMD Radeon R9 290X Patriot Memory  
Hard DriveCoolingMonitor
Samsung 840 Raijintek Ereboss iiyama X4071UHSU (4K) 
  hide details  
Reply
FX
(7 items)
 
  
CPUMotherboardGraphicsRAM
FX-8320@4.4Ghz M5A99FX PRO R2.0 AMD Radeon R9 290X Patriot Memory  
Hard DriveCoolingMonitor
Samsung 840 Raijintek Ereboss iiyama X4071UHSU (4K) 
  hide details  
Reply
post #75 of 4829
Quote:
Originally Posted by Sp3cialUs3r View Post

Ok i will try the AMD Bios from Techpowerup. I flashed before my own safed Bios. Maybe its corrupted:thumb: But i must fix first my windows.

GPU-Z is making Crazy **** by Exporting the Bios, its only 128 KB big. The Original Bios has a 512 KB Size:mad:

I found out the hard way that the GPU-Z saved bios was incorrect. Had to unbrick my card by using the TPU ref bios. Lesson learned, I should have used atiflash to save the bios instead. tongue.gif
post #76 of 4829
So Card Works again fine. Perfect. Now make a little Voltage Mod.thumb.gif

Ok no modding... After Bios Modding Card gots an Error 43 Message... only changed one Voltage rolleyes.gif

Thanks for help thumb.gifthumb.gifthumb.gif
Edited by Sp3cialUs3r - 7/5/16 at 4:49pm
post #77 of 4829
Quote:
Originally Posted by Sp3cialUs3r View Post

So Card Works again fine. Perfect. Now make a little Voltage Mod.thumb.gif

Ok no modding... After Bios Modding Card gots an Error 43 Message... only changed one Voltage rolleyes.gif

Thanks for help thumb.gifthumb.gifthumb.gif

You can't just edit one voltage. You have to change all of them from auto to manual override.

Try the voltage I have under GPU voltage. For voltages not listed use 1050mV.

Power Bac G5
(6 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7 6950X EVGA GTX 1080 Ti GSkill 32GB 4133Mhz Samsung 960 Pro 1TB 
CoolingMonitor
Corsair H110i ASUS PG278Q 
  hide details  
Reply
Power Bac G5
(6 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7 6950X EVGA GTX 1080 Ti GSkill 32GB 4133Mhz Samsung 960 Pro 1TB 
CoolingMonitor
Corsair H110i ASUS PG278Q 
  hide details  
Reply
post #78 of 4829
Well thats good news people making some Progress....

I still cant open my Bios from The XFX RX 480 OC EDITION @ 1288mhz with Polaris Bios editor even though i did make a copy with atiflash tool
i think id would be intressting to take a look at the XFX bios because its allready slighty overclocked from Manufacture.
so here is the Right Bios if some one can do something with it

XFX-RX480-OC-EDITION1288mhz-8GB-RAM.zip 109k .zip file
post #79 of 4829
Quote:
Originally Posted by TheLAWNOOB View Post

You can't just edit one voltage. You have to change all of them from auto to manual override.

Try the voltage I have under GPU voltage. For voltages not listed use 1050mV.






Thank you, this i didnt know. Now the Fun beginns!
post #80 of 4829
The last two States i configured 1200 for 1,2v. I want so see how much i can Clock. @ 1,15v i got 1360 MHz Stable at 71 degrees. (Artic Accelero Extreme IV).

EDIT:

I edited now every Voltage State, but got still the ERROR 43 Message. With Stock Bios everything is ok. The Driver dont recognize the Card just fine after a Bios Mod.
Edited by Sp3cialUs3r - 7/5/16 at 5:07pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Polaris Bios Editing ( RX5xx / RX4xx )