Overclock.net › Forums › Graphics Cards › AMD/ATI › Polaris Bios Editing ( RX5xx / RX4xx )
New Posts  All Forums:Forum Nav:

Polaris Bios Editing ( RX5xx / RX4xx ) - Page 9

post #81 of 3353
I changed all the voltages/clocks to the values I use in Wattman as well as the fan profile and after I flashed it the gpu was no longer recognized by the amd driver and just used the MS basic display adapter while my 2nd gpu I use for more monitors was working fine
post #82 of 3353
Quote:
Originally Posted by Yukikaze View Post

I changed all the voltages/clocks to the values I use in Wattman as well as the fan profile and after I flashed it the gpu was no longer recognized by the amd driver and just used the MS basic display adapter while my 2nd gpu I use for more monitors was working fine

So we have nearly the same problem.

Does anyone have a Solution? redface.gif

Thanks
post #83 of 3353
Quote:
Originally Posted by Ginmarr View Post

Ellesmere.zip 95k .zip file

I checked your BIOS, you have the same VRAM chips as the RX 480 8GB. If you flash a RX 480 8GB BIOS you would unlock an extra 4GB of VRAM. thumb.gif

Thanks for sharing that, it's helped the development of https://github.com/caa82437/PolarisBiosEditor
Quote:
Originally Posted by Sp3cialUs3r View Post

So we have nearly the same problem.

Does anyone have a Solution? redface.gif

Thanks

A small change I made may fix the problem?

v1.4
https://github.com/caa82437/PolarisBiosEditor
post #84 of 3353
Quote:
Originally Posted by Sp3cialUs3r View Post

So we have nearly the same problem.

Does anyone have a Solution? redface.gif

Thanks

A small change I made may fix the problem?

v1.4
https://github.com/caa82437/PolarisBiosEditor
post #85 of 3353
Some funny and unfunny thinks here:

First, i flash a XFX RX 480 4 GB with the ATi Stock 8 GB Bios. The Card runs perfekt and the upgrade from 4 GB to 8 GB work well =)
For this flash i have to Chance the Supvendor id and the sup id, otherwise ATIFlash stop with SUB ID error.

I found out that some Cards ( like my Sapphire RX 480 8 GB too ) use the Standart ATI Bios that you can found on the reviewers cards. XFX use a diffrent Bios ( ohne the SUP ID ) so you have to change that if you want to flash.

Then there are some unhappy thinks with the Polaris Bios editor.
At fist i save the Bios of my Sapphire Card and then load it to the Bios editor.

After changing the Memory speed to 2100 Mhz and the P7 Chip Speed to 1288 Mhz, and flash the Bios, i got some troubble.

At Boot my Gigabyte Z77X-UDH3 use CMS settings without UEFi Boot. After loading Window 10 the Radeon was disable in the Hardware Manager and i cant Start the Radeon settings. So the Card is unuseble.

Then i try to flash the stock Bios annythink goes fine. No Problems annyware.

Should i do annythink wrong? I have to disable wattman bevor flash? Or reinstall the drivers?

Have a nice day =)
post #86 of 3353
Are you guys using 512 byte roms? If so then could be an issue with the checksum in the bios editor ( or amd has gone to extreme lengths and disabled GPUs that have non stock roms?)
post #87 of 3353
Quote:
Originally Posted by caa82437 View Post

A small change I made may fix the problem?

v1.4
https://github.com/caa82437/PolarisBiosEditor

Whoo that was fast. I try it now =)

Edit:

Sorry dude, nothink has change =(

I'm wondering about the think that after i reboot the UEFI ob my Motherboard can't found an Video Card with UEFI Boot support and activate CSM Boot Option. So somethink goes wrong with the flash?
Edited by Cross-Flow - 7/5/16 at 6:08pm
post #88 of 3353
Quote:
Originally Posted by paromi View Post

Well thats good news people making some Progress....

I still cant open my Bios from The XFX RX 480 OC EDITION @ 1288mhz with Polaris Bios editor even though i did make a copy with atiflash tool
i think id would be intressting to take a look at the XFX bios because its allready slighty overclocked from Manufacture.
so here is the Right Bios if some one can do something with it

XFX-RX480-OC-EDITION1288mhz-8GB-RAM.zip 109k .zip file


WOOHOO! THanks! used this on my 4gb XFX RX 480 and it worked XD

post #89 of 3353
Quote:
Originally Posted by paromi View Post

Hello

I downloaded ATIFLASH , POLARIS BIOS EDITOR, and GPUZ

with GPUZ i made a copy of the Bios ( XFX RX 480 OC @ 1288mhz)

XFXRX4808GBOC1288mhz.zip 95k .zip file

But POLARIS BIOS EDITOR don´t open it



Thanks

Quote:
Originally Posted by PCIEgate View Post

Yeah, i just bricked and un-bricked my card too. The 8GB flash worked correctly but re-flash to my 4GB backup just corrupted the card somehow, seems either a corrupt backup or a problem with ATIFlash.
I used a CH341A programmer and a soic test clip.

Might be useful:
BIOS chip is a Gigadevice GD25Q41B -> Datasheet

It's located on the back:

Quote:
Originally Posted by Yukikaze View Post

Quote:
Originally Posted by Sp3cialUs3r View Post

Ok i will try the AMD Bios from Techpowerup. I flashed before my own safed Bios. Maybe its corrupted:thumb: But i must fix first my windows.

GPU-Z is making Crazy **** by Exporting the Bios, its only 128 KB big. The Original Bios has a 512 KB Size:mad:

I found out the hard way that the GPU-Z saved bios was incorrect. Had to unbrick my card by using the TPU ref bios. Lesson learned, I should have used atiflash to save the bios instead. tongue.gif
This is based on the paromi's ROM. After analyzing both ROM from paromi I found some parts after the headers (specifically the PCI DATA STRUCTURE), somehow they shifted. There are two 00s between ATOM ROM HEADER & PCI DATA STRUCTURE. However, the offset for the PCI DATA STRUCTURE is correctly defined in the VBIOS ROM HEADER. So everything look ok nonetheless. So I'm not sure whether the two 00s I'm talking about here leads to corrupted ROM. jackalopeater don't have problem using the 2nd paromi's ROM file though (edit: ok the 2nd ROM is 512KB).

It's worth to mention that @Ginmarr's (here) & @The Stilt's ROMs (in the temporary fix thread) don't have this problem though.
Edited by kizwan - 7/5/16 at 9:32pm
Superhero Effect
(26 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7-3820 @4.7GHz Asus P9X79 PRO 2 x Sapphire R9 290 4GB GDDR5 Corsair Vengeance CMZ16GX3M4X1600C9 (16GB) 
Hard DriveHard DriveOptical DriveCooling
WD WD6400AAVS 640GB 8MB SATA-II Caviar Green 2 x Plextor PX-M5S 128GB (RAID0) Liteon 12x Blu-ray Drive COMBO 2 x (EK-FC R9-290X - Acetal, EK-FC R9-290X Back... 
CoolingCoolingCoolingCooling
Koolance Ball Valve VLV-BL1X2 XSPC D5 Dual Bay Reservoir/Pump Combo Hardware Labs Black Ice GT Stealth 360mm Hardware Labs Black Ice SR-1 120 
CoolingCoolingCoolingCooling
XSPC EX240 2x120mm radiator 5 x Corsair SP120 High Performance 2 x Corsair SP120 PWM High Performance XSPC Raystorm 
CoolingCoolingOSMonitor
NZXT Sentry 2 fan controller PrimoFlex Advanced LRT 10ft Tubing - 7/16in. ID... Windows 10 Home 64-bit Samsung SyncMaster B2330H 23" 
MonitorKeyboardPowerCase
Philips 236G3DHSB 3D LCD LED 23" Razer BlackWidow Ultimate Seasonic X-1050 1050W Corsair Vengeance C70 Mid-Tower Gaming Case Gun... 
MouseAudio
Razer Imperator 2012 Realtek ALC898 8-Channel High Definition Audio ... 
CPUMotherboardGraphicsRAM
Intel Core i7 720QM Dell Studio 1557 Intel PM55 ATI Mobility Radeon HD 4500/5100 Series Samsung 2GB DDR3-1333 
RAMHard DriveOptical DriveCooling
Samsung 2GB DDR3-1333 Seagate ST9320325AS HL-DT-ST_DVD+-RW_GA11N Fan + Copper + Aluminum + Shin-Etsu G751 
OSMonitorKeyboardPower
Windows 7 Home Premium 64-bit 15.6" LCD (WXGA) InnoLux BT156GW01 Dell Studio 1557 Keyboard Dell 90W AC Adapter 
Audio
IDT High Definition Audio CODEC 
  hide details  
Reply
Superhero Effect
(26 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7-3820 @4.7GHz Asus P9X79 PRO 2 x Sapphire R9 290 4GB GDDR5 Corsair Vengeance CMZ16GX3M4X1600C9 (16GB) 
Hard DriveHard DriveOptical DriveCooling
WD WD6400AAVS 640GB 8MB SATA-II Caviar Green 2 x Plextor PX-M5S 128GB (RAID0) Liteon 12x Blu-ray Drive COMBO 2 x (EK-FC R9-290X - Acetal, EK-FC R9-290X Back... 
CoolingCoolingCoolingCooling
Koolance Ball Valve VLV-BL1X2 XSPC D5 Dual Bay Reservoir/Pump Combo Hardware Labs Black Ice GT Stealth 360mm Hardware Labs Black Ice SR-1 120 
CoolingCoolingCoolingCooling
XSPC EX240 2x120mm radiator 5 x Corsair SP120 High Performance 2 x Corsair SP120 PWM High Performance XSPC Raystorm 
CoolingCoolingOSMonitor
NZXT Sentry 2 fan controller PrimoFlex Advanced LRT 10ft Tubing - 7/16in. ID... Windows 10 Home 64-bit Samsung SyncMaster B2330H 23" 
MonitorKeyboardPowerCase
Philips 236G3DHSB 3D LCD LED 23" Razer BlackWidow Ultimate Seasonic X-1050 1050W Corsair Vengeance C70 Mid-Tower Gaming Case Gun... 
MouseAudio
Razer Imperator 2012 Realtek ALC898 8-Channel High Definition Audio ... 
CPUMotherboardGraphicsRAM
Intel Core i7 720QM Dell Studio 1557 Intel PM55 ATI Mobility Radeon HD 4500/5100 Series Samsung 2GB DDR3-1333 
RAMHard DriveOptical DriveCooling
Samsung 2GB DDR3-1333 Seagate ST9320325AS HL-DT-ST_DVD+-RW_GA11N Fan + Copper + Aluminum + Shin-Etsu G751 
OSMonitorKeyboardPower
Windows 7 Home Premium 64-bit 15.6" LCD (WXGA) InnoLux BT156GW01 Dell Studio 1557 Keyboard Dell 90W AC Adapter 
Audio
IDT High Definition Audio CODEC 
  hide details  
Reply
post #90 of 3353
Quote:
Originally Posted by Sp3cialUs3r View Post

So we have nearly the same problem.

Does anyone have a Solution? redface.gif

Thanks
seems we have the exact same problem Error code 43 and the driver doesn't recognize my 480
Quote:
Originally Posted by caa82437 View Post

A small change I made may fix the problem?

v1.4
https://github.com/caa82437/PolarisBiosEditor
Still the same Error code 43 with v1.4
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Polaris Bios Editing ( RX5xx / RX4xx )