Overclock.net › Forums › Components › Monitors and Displays › Input lag got fixed by weird ways, any help is appreciated a lot!
New Posts  All Forums:Forum Nav:

Input lag got fixed by weird ways, any help is appreciated a lot!

post #1 of 11
Thread Starter 
Hey guys.

I have had terrible, horrible input lag, like having vsync on the past 3 months, completely unnatural mouse behavior. I have almost replaced everything in my PC that I suspected could cause it, but nothing helped.

Today I kinda rage went into the nvidia controlpanel and I started spamming the scaling options, changing back and forth between scalings and somehow it snapped and started acting normal again.. now I feel the most normal mouse behavior that I have for the past 3 months.

What could have caused this? is my monitor acting up? graphics card? I have tried several graphics cards, both had the same problem.. has to be the monitor right?
post #2 of 11
Are you using multiple monitors?
post #3 of 11
Thread Starter 
Quote:
Originally Posted by Drake87 View Post

Are you using multiple monitors?

Only one. Benq XL2411T.

I have used lightboost, custom resolutions etc. in the past.
Edited by Aymanb - 7/2/16 at 5:02am
post #4 of 11
Probably has to do with the drivers. One of the latest drivers has been causing issues with youtube videos and crashing when playing video in full screen. For me, firefox has been running like crap with the newest driver. Are you by chance using a steel series mouse?
post #5 of 11
Thread Starter 
Quote:
Originally Posted by Drake87 View Post

Probably has to do with the drivers. One of the latest drivers has been causing issues with youtube videos and crashing when playing video in full screen. For me, firefox has been running like crap with the newest driver. Are you by chance using a steel series mouse?

As I said, this has been going on in a period of 3 months. I've been through everything. New parts, fresh installations, different drivers. I could even feel this in windows installation menus and so on, not just the desktop.

Also I tried the CPU graphics card, same issue.
post #6 of 11
Some motherboards have "optimized" usb ports for the mouse. I've never seen anything different about them, but they're usually at the far left side of the ports. Post the specs of the PC and the mouse you're using.
post #7 of 11
Probably GPU driver issue from what you've described. You always want to run native resolution and no scaling, no VSR/DSR, no FRTC or other frame limiting in driver, no sort of sync of any type, ...
post #8 of 11
Quote:
Originally Posted by JackCY View Post

Probably GPU driver issue from what you've described. You always want to run native resolution and no scaling, no VSR/DSR, no FRTC or other frame limiting in driver, no sort of sync of any type, ...
He's seeing it with the intel video as well. Even in the windows install menu. I'm thinking his motherboard or mouse. Doubt it's his monitor.
post #9 of 11
Thread Starter 
Been through 3 motherboards (2x 1155, 1x 1151) and I have about 7 different mice, same issue.

No modified gaming USB.
post #10 of 11
Thread Starter 
Same issue happens with two different graphics cards and nvidia drivers. Gtx 660 Ti, gtx 960.

I don't remember my Intel graphics experience that much because they were always weak in terms of performance/fps so it was very hard to compare but bottom line is it just never felt good.

Monitor is the only thing that I have not replaced/tried another one. It's a 4 yr old benq xl2411t
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Input lag got fixed by weird ways, any help is appreciated a lot!