Overclock.net › Forums › Graphics Cards › NVIDIA › [TIP] NVFlash with Newest 980 Ti Hybrid (Different Firmware Issue)
New Posts  All Forums:Forum Nav:

[TIP] NVFlash with Newest 980 Ti Hybrid (Different Firmware Issue)

post #1 of 2
Thread Starter 
Hi all. I just wanted to make this post so that others don't make the same mistake as me. So here's what happened and how I fixed it..

I recently sold my 980Ti Hybrid to a buddy in anticipation of the new GTX 1080. After a few weeks of waiting and watching the prices of the 980Ti continue to plummet and plummet, I jumped on another 980 Ti Hybrid for $450 shipped (Jet) and received it just yesterday.

The first thing I always do with a new graphics card is test its limits with MSI Afterburner. Core clock first, then Memory clock, then both. Once I found my max stable OC (1520/4104), I decided it was time to flash one of the bios' on the 980 Ti Forums. I chose Sheyster's "980Ti-SC-425.zip" which is based off the 980Ti SC. It was the one I settled on for my previous 980Ti Hybrid and I loved it.

I started NVFlash and did the usual "NVFlash --list", "NVFlash -6 bios.rom" and was greeted with a warning I hadn't seen on my previous 980Ti Hybrid:

C:\NVFlash>nvflash --list

NVIDIA Firmware Update Utility (Version 5.227)
Modified Version by Joe Dirt

NVIDIA display adapters present in system:
<0> GeForce GTX 980 Ti (10DE,17C8,3842,1996) H:--:NRM S:00,B:01,PCI,D:00,F:00

C:\NVFlash>nvflash -6 980Ti-SC-425.rom

NVIDIA Firmware Update Utility (Version 5.227)
Modified Version by Joe Dirt

Checking for matches between display adapter(s) and image(s)...

Adapter: GeForce GTX 980 Ti (10DE,17C8,3842,1996) H:--:NRM S:00,B:01,PCI,D:00,
F:00

WARNING: Firmware image PCI Subsystem ID (3842.4992)
does not match adapter PCI Subsystem ID (3842.1996).

Please press 'y' to confirm override of PCI Subsystem ID's:


I noticed right away that I had never had to press Y more than once and began examining the text. Then I saw where it said my Firmware image was 3842.4992 and the Sheyster image was 3842.1996.

I decided to do some Googling and, from what I was finding online, decided it was safe to proceed. BIG MISTAKE. It said it went through just fine and I needed to do a restart. So I restarted and was greeted with a black screen. I knew this was bad. I turned the power off and turned it back on.. greeted with another black screen. By now, I was worried. I just received this card and it actually OCs above 1500MHz (I NEVER have this kind of luck).

I told myself to stay calm, grab the iPad and see about fixing it. I found a pretty good thread somewhere that said to plug another GPU into the slot the 980Ti was in and place the 980Ti in a lower slot. Well... that's kind of a problem when I'm using an MSI Z170I mini ITX motherboard with just one PCI slot. Then it came to me.. *Check to see if I can use integrated graphics with this mobo!* And sure enough, there was even a DisplayPort that I could use to plug my monitor in. I then cleared the CMOS on the mobo, pulled the 980Ti out of the PCI slot, started up and went into BIOS to set the main display adapter to Integrated Graphics. I then shut the computer back down, plugged the 980Ti back into the PCI slot and started the computer. It loaded up to windows and I quickly went to NVFlash..

Once I got into NVFlash, I thought to myself *thank God I made a back up of my card's ROM just minutes before I flashed* (with GPU-Z). I ran the NVFlash --list cmd and it showed my card. I then ran NVFlash -6 Stock.rom and as it began to flash, it failed. ****. I thought that it was all over from here. I decided to Google one more time to see if there was some magical fix and found a thread talking about certain versions of NVFlash having this problem of ERRORing out when trying to flash. One post had attached version 250 saying that it worked for him. I decided to see if it would work for me.

Sure enough, as soon as I traded out my newer NVFlash with version 250 and ran the same commands, it flashed back to stock and I had my 980 Ti working again.


I apologize for the very long post. I just didn't want anyone to make the same mistake I did. If you have any questions or even future advice for myself and others who encounter this issue, feel free to post below. Thanks.
Edited by Kold - 7/3/16 at 3:05pm
post #2 of 2
So was the issue because of the BIOS rom or the newer flash tool?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › [TIP] NVFlash with Newest 980 Ti Hybrid (Different Firmware Issue)