Overclock.net › Forums › Graphics Cards › NVIDIA › 1070 blank windows 10 screen
New Posts  All Forums:Forum Nav:

1070 blank windows 10 screen

post #1 of 3
Thread Starter 
Hello I just recieved my new 1070 gpu however upon boot sometimes it will do a normal boot up, show the bios, windows logo then as soon as it goes to the login screen the monitor turns off? Happens on dp,hdmi, tried several cables, only really way is to restart the pc and hope it displays the login screen. Is there a way to fix this or anyone have this issue as well?
post #2 of 3
Did you do a clean install of new drivers? That's mandatory after installing a video card.

Use ddu to remove old drivers.
http://www.guru3d.com/files-details/display-driver-uninstaller-download.html


I installed this driver it is working fine.

http://www.overclock.net/t/1605065/nvidia-official-368-69-game-ready-whql-display-driver
MyCleanPC
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770k ASUS MAXIMUS VI EVGA master blaster Corsair Vengence  
Hard DriveOptical DriveOSMonitor
OCZ SSD raid0 samsung Win 7 Samsung 
PowerCase
Enermax rev 1050 Stacker 832 
  hide details  
Reply
MyCleanPC
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770k ASUS MAXIMUS VI EVGA master blaster Corsair Vengence  
Hard DriveOptical DriveOSMonitor
OCZ SSD raid0 samsung Win 7 Samsung 
PowerCase
Enermax rev 1050 Stacker 832 
  hide details  
Reply
post #3 of 3
Thread Starter 
It was a brand new pc setup built from a pc shop, all hardware software pre installed from them. I did do a ddu and re install of new gpu drivers and still has the same problem every now and then. Maybe its the intel onboard gpu trying to work instead of the 1070?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › 1070 blank windows 10 screen