Overclock.net › Forums › Components › Monitors and Displays › Qnix QX2710 flickering
New Posts  All Forums:Forum Nav:

Qnix QX2710 flickering

post #1 of 5
Thread Starter 
Two nights ago I finally got around to replacing my old 750TI with the brand new RX480, and due to the QX2710 only having a DVI-D port I purchased an active Displayport to DVI on amazon that was recommended.



Since installing the new card and turning it on it's been flickering/tearing non-stop. I was hoping it was a driver issue so I reformatted since I was planning to, to upgrade to WIN10, but sadly that was not the issue.

I am currently using the DVI cable that was provided with the monitor, because I was able to overclock on my 750Ti to 96hz and that was acceptable to me.
I do have on order from Walmart a new cable that I will be picking up Friday. DVI-D cable

Hopefully that fixes the problems, I would like some advice or if I should just cut my losses and sell the monitor and get a new one.
post #2 of 5
Does the active display port adapter cause the same flickering on the 750ti?
post #3 of 5
Thread Starter 
I just checked since I can't sleep and yes it does.
post #4 of 5
Almost certainly the adapter then. Does flickering happen at 60Hz?
post #5 of 5
Thread Starter 
Yeah, I figured as much. Do you have any recommendations on displayport to dvi adapters?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Qnix QX2710 flickering