Overclock.net › Forums › Graphics Cards › Graphics Cards - General › Really need help
New Posts  All Forums:Forum Nav:

Really need help

post #1 of 38
Thread Starter 
I just installed my new PSU a seasonic S12 620W threw out my hd5450 and put in my rx 480 and nothing shows up on screen it's just rebooting after like 30 seconds for one time every time I start it manually
post #2 of 38
Please post all your specs - motherboard, CPU, cables you used to connect PSU to GPU, etc.
What have you tried so far to solve the issue?
Have you tried reseating the card?
Have you tried the card with another PSU and the PSU with another card?
My Rig
(14 items)
 
Ex-wife's Rig
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 4460 AsRock H81M-DG4 Sapphire Rx470 Platinum KVR 1600 16Gb 
Hard DriveHard DriveCoolingOS
2x Seagate 3Tb Samsung 850 EVO 120 Scythe Ninja 3 Rev.B Windows 10 Pro 
MonitorKeyboardPowerCase
Fujitsu Siemens A17-2A Logitech K280e SuperFlower SF-550K12XP Thermaltake Versa H25 
MouseAudio
Logitech G402 Sony MDR XD150 
CPUMotherboardGraphicsRAM
Athlon 750K 4.0Ghz AsRock FM2A75 Pro4+ Sapphire R9 270X Dual-X Kingston 2x4Gb 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 EVO 120  Western Digital 320Gb LiteON DVD-RW CoolerMaster Hyper Z600 
OSMonitorKeyboardPower
Windows 7 Pro x64 Toshiba 32" FullHD TV Logitech FSP Hexa 550 
CaseMouse
DeLUX Logitech 
  hide details  
Reply
My Rig
(14 items)
 
Ex-wife's Rig
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 4460 AsRock H81M-DG4 Sapphire Rx470 Platinum KVR 1600 16Gb 
Hard DriveHard DriveCoolingOS
2x Seagate 3Tb Samsung 850 EVO 120 Scythe Ninja 3 Rev.B Windows 10 Pro 
MonitorKeyboardPowerCase
Fujitsu Siemens A17-2A Logitech K280e SuperFlower SF-550K12XP Thermaltake Versa H25 
MouseAudio
Logitech G402 Sony MDR XD150 
CPUMotherboardGraphicsRAM
Athlon 750K 4.0Ghz AsRock FM2A75 Pro4+ Sapphire R9 270X Dual-X Kingston 2x4Gb 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 EVO 120  Western Digital 320Gb LiteON DVD-RW CoolerMaster Hyper Z600 
OSMonitorKeyboardPower
Windows 7 Pro x64 Toshiba 32" FullHD TV Logitech FSP Hexa 550 
CaseMouse
DeLUX Logitech 
  hide details  
Reply
post #3 of 38
Thread Starter 
My specs:
I3 2100
Foxconn H61MX
Seasonic S12 II 620W
I tried my old gpu which is working just fine
I reset the CMOS.
post #4 of 38
Is the 6pin pcie power on the 480 plugged in?
Guts (4k HTPC)
(12 items)
 
   
CPUMotherboardGraphicsRAM
Xeon X3450 @ 3.5GHz Gigabyte GA P55M UD2 EVGA GTX 1050Ti SC 4GB GDDR5 12GB DDR3 1600Mhz Assorted Kits 
Hard DriveHard DriveOSMonitor
Kingston 120GB SSD 8TB Seagate Surveillance 5400RPM Win 10 LG OLED55C6P 
KeyboardPowerCaseAudio
Logitech K400+ Corsair HX850 80+ Gold Phanteks Evolv mATX Fluance Tower Speakers + JBL Center + Fluance R... 
CPUMotherboardGraphicsRAM
AMD 1800X @ Stock Gigabyte Aorus GA-AX370-Gaming K7 Gigabyte GTX 980 TI Gaming OC 16GB EVGA DDR4 3000MHz CL15 
Hard DriveHard DriveHard DriveHard Drive
256GB Crucial M4 SSD 256GB Crucial M4 SSD 512GB Crucial M4 SSD 512GB Crucial MX100 SSD 
Hard DriveHard DriveHard DriveOptical Drive
Seagate 1.5TB Samsung 1.5TB  Seagate 3TB LG BD Reader 
CoolingOSMonitorMonitor
Scythe Fuma Windows 10 Pro 60" Samsung PN60E530 Acer GN246HL w/ Lightboost 
MonitorKeyboardPowerCase
HP ZR22w ThermalTake Mech w/ Cherry MX Blacks NZXT Hale90 750W ThermalTake Core X31 
MouseMouse PadAudioAudio
Logitech G900 SteelSeries 9HD Fluance Bookshelf Speakers + Micca MB42 + Onkyo... O2 AMP + Audioengine D1 Dac + SHP9500s w/ V-Mo... 
  hide details  
Reply
Guts (4k HTPC)
(12 items)
 
   
CPUMotherboardGraphicsRAM
Xeon X3450 @ 3.5GHz Gigabyte GA P55M UD2 EVGA GTX 1050Ti SC 4GB GDDR5 12GB DDR3 1600Mhz Assorted Kits 
Hard DriveHard DriveOSMonitor
Kingston 120GB SSD 8TB Seagate Surveillance 5400RPM Win 10 LG OLED55C6P 
KeyboardPowerCaseAudio
Logitech K400+ Corsair HX850 80+ Gold Phanteks Evolv mATX Fluance Tower Speakers + JBL Center + Fluance R... 
CPUMotherboardGraphicsRAM
AMD 1800X @ Stock Gigabyte Aorus GA-AX370-Gaming K7 Gigabyte GTX 980 TI Gaming OC 16GB EVGA DDR4 3000MHz CL15 
Hard DriveHard DriveHard DriveHard Drive
256GB Crucial M4 SSD 256GB Crucial M4 SSD 512GB Crucial M4 SSD 512GB Crucial MX100 SSD 
Hard DriveHard DriveHard DriveOptical Drive
Seagate 1.5TB Samsung 1.5TB  Seagate 3TB LG BD Reader 
CoolingOSMonitorMonitor
Scythe Fuma Windows 10 Pro 60" Samsung PN60E530 Acer GN246HL w/ Lightboost 
MonitorKeyboardPowerCase
HP ZR22w ThermalTake Mech w/ Cherry MX Blacks NZXT Hale90 750W ThermalTake Core X31 
MouseMouse PadAudioAudio
Logitech G900 SteelSeries 9HD Fluance Bookshelf Speakers + Micca MB42 + Onkyo... O2 AMP + Audioengine D1 Dac + SHP9500s w/ V-Mo... 
  hide details  
Reply
post #5 of 38
Thread Starter 
Yes everything is plugged in and the fan is spinning
post #6 of 38
Quote:
Originally Posted by Dragonsoul View Post

Yes everything is plugged in and the fan is spinning

Have you tried booting in safe mode? If it works, remove the old driver with DDU (display driver uninstaller), boot normally into Windows afterwards and install the last one...
HWF-X 2014
(26 items)
 
  
CPUMotherboardGraphicsGraphics
4930k RAMPAGE IV BLACK EDITION XFX DD Radeon R9 290X XFX DD Radeon R9 290X 
GraphicsRAMHard DriveHard Drive
290x Kingston Hyper-X Western Digital Caviar Black 4TB Crucial M500 
Optical DriveOptical DriveCoolingCooling
Pioneer Blu-Ray Recorder Pioneer Blu-Ray Recorder Alphacool xp3 Mo-ra 3 
CoolingCoolingCoolingCooling
EK 290x EK 290x Alphacool dual Laing reservoir Tygon Silver 
OSMonitorMonitorMonitor
Windows 10 Dell U2713HM Dell U2713HM Dell U2713HM 
KeyboardPowerCaseMouse
Logitech G710+ EVGA Supernova G2 1600W Silverstone TJ-11 Logitech G700s 
Mouse PadAudio
Razer Goliathus Onkyo 
  hide details  
Reply
HWF-X 2014
(26 items)
 
  
CPUMotherboardGraphicsGraphics
4930k RAMPAGE IV BLACK EDITION XFX DD Radeon R9 290X XFX DD Radeon R9 290X 
GraphicsRAMHard DriveHard Drive
290x Kingston Hyper-X Western Digital Caviar Black 4TB Crucial M500 
Optical DriveOptical DriveCoolingCooling
Pioneer Blu-Ray Recorder Pioneer Blu-Ray Recorder Alphacool xp3 Mo-ra 3 
CoolingCoolingCoolingCooling
EK 290x EK 290x Alphacool dual Laing reservoir Tygon Silver 
OSMonitorMonitorMonitor
Windows 10 Dell U2713HM Dell U2713HM Dell U2713HM 
KeyboardPowerCaseMouse
Logitech G710+ EVGA Supernova G2 1600W Silverstone TJ-11 Logitech G700s 
Mouse PadAudio
Razer Goliathus Onkyo 
  hide details  
Reply
post #7 of 38
Thread Starter 
I remived the card and used the IO of the mobo uninstalled tge driver with DDU in safe mode. still no signal when i am booting
post #8 of 38
Thread Starter 
Even my mouse and keyboard don't work it seems that it doesnt straight up boot.
I will try the card at my friend's pc but if it's not the card what is it then
Edited by Dragonsoul - 7/12/16 at 8:12am
post #9 of 38
Quote:
Originally Posted by Dragonsoul View Post

Even my mouse and keyboard don't work it seems that it doesnt straight up boot.
I will try the card at my friend's pc but if it's not the card what is it then

The card could be a dud, or possibly it's something with the card not falling back to BIOS mode? Just a hunch, had a couple of these problems with an old P67 board...

(Edit: extra T in hunch)
Edited by amra88 - 7/12/16 at 2:50pm
HWF-X 2014
(26 items)
 
  
CPUMotherboardGraphicsGraphics
4930k RAMPAGE IV BLACK EDITION XFX DD Radeon R9 290X XFX DD Radeon R9 290X 
GraphicsRAMHard DriveHard Drive
290x Kingston Hyper-X Western Digital Caviar Black 4TB Crucial M500 
Optical DriveOptical DriveCoolingCooling
Pioneer Blu-Ray Recorder Pioneer Blu-Ray Recorder Alphacool xp3 Mo-ra 3 
CoolingCoolingCoolingCooling
EK 290x EK 290x Alphacool dual Laing reservoir Tygon Silver 
OSMonitorMonitorMonitor
Windows 10 Dell U2713HM Dell U2713HM Dell U2713HM 
KeyboardPowerCaseMouse
Logitech G710+ EVGA Supernova G2 1600W Silverstone TJ-11 Logitech G700s 
Mouse PadAudio
Razer Goliathus Onkyo 
  hide details  
Reply
HWF-X 2014
(26 items)
 
  
CPUMotherboardGraphicsGraphics
4930k RAMPAGE IV BLACK EDITION XFX DD Radeon R9 290X XFX DD Radeon R9 290X 
GraphicsRAMHard DriveHard Drive
290x Kingston Hyper-X Western Digital Caviar Black 4TB Crucial M500 
Optical DriveOptical DriveCoolingCooling
Pioneer Blu-Ray Recorder Pioneer Blu-Ray Recorder Alphacool xp3 Mo-ra 3 
CoolingCoolingCoolingCooling
EK 290x EK 290x Alphacool dual Laing reservoir Tygon Silver 
OSMonitorMonitorMonitor
Windows 10 Dell U2713HM Dell U2713HM Dell U2713HM 
KeyboardPowerCaseMouse
Logitech G710+ EVGA Supernova G2 1600W Silverstone TJ-11 Logitech G700s 
Mouse PadAudio
Razer Goliathus Onkyo 
  hide details  
Reply
post #10 of 38
Thread Starter 
So there shouldn't be compatibility issues between the rx 480 and this really old mobo?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards - General
Overclock.net › Forums › Graphics Cards › Graphics Cards - General › Really need help