Overclock.net › Forums › Graphics Cards › AMD/ATI › [Official] Polaris Owners Club
New Posts  All Forums:Forum Nav:

[Official] Polaris Owners Club - Page 108

post #1071 of 4340
Quote:
Originally Posted by dlee7283 View Post

im done with AMD this gen. I literally replaced my 480 with a 470 to see if it would work correctly but of course it has to black screen again.

I play killing floor, change the resolution to 1080p and the computer freezes and wont boot into windows again. i magically insert a 950 and guess what, windows boots!.
its only using the WIndows driver and it still is smart enough to know to default back to the resolution before you changed it in-game...


I am going to wait until the 1060 comes down in price and get that, im sick of dealing with bugs all in the name of saving a few bucks.

Have you tried the latest driver? 16.8.3.
Quote:
Fixed Issues

A random blank or colored screen may be experienced intermittently on some Radeon RX 400 series products while gaming.
3770K
(14 items)
 
R7 1700
(8 items)
 
 
CPUMotherboardGraphicsRAM
RYZEN 1700 ASROCK AB350 GAMING K4 ZOTAC 1080TI REFERENCE MODEL G SKILL 8 GIG (2X) 
Hard DriveOSPowerCase
WESTERN DIGITAL 250 M.2 2280 WINDOWS 10 64 CORSAIR SF600 LIAN LI PC-O10 
  hide details  
Reply
3770K
(14 items)
 
R7 1700
(8 items)
 
 
CPUMotherboardGraphicsRAM
RYZEN 1700 ASROCK AB350 GAMING K4 ZOTAC 1080TI REFERENCE MODEL G SKILL 8 GIG (2X) 
Hard DriveOSPowerCase
WESTERN DIGITAL 250 M.2 2280 WINDOWS 10 64 CORSAIR SF600 LIAN LI PC-O10 
  hide details  
Reply
post #1072 of 4340
Quote:
Originally Posted by JackCY View Post

@Shatun-Bear:
I'm trying to justify getting a Nitro 480 as it is the only I can get in my country beside couple shops having overpriced XFXs.
I've done all I can today with one shop to get a hold of them and a reply on the availability, no luck. If I can't get a hold of them on Monday then I'm not even inclined to place an order with them at all for any price as that just means trouble when shop doesn't answer emails nor picks up phones.
The places that offer any decent prices on 480s are close to none and ordering from Germany is not good price wise either as they've raised prices too at least the shop that would ship at a reasonable cost to me.
And I can't get a hold of KFA2 GTX 1070 EX either, the cheapest 1070 in Europe.

I've paid about $186 for my 280x and gotten that back while spending 3.5 months and $15 on RMA shipping. So kind of half of 1060/480 gets paid by previous card. 1060s also come with game code that can be sold. 480s come with nothing, not even newest Doom or Deus Ex, none, nil. Instead AMD is promoting CPUs with those kind of games and prebuilt crap systems, pretty much the stuff no one wants to buy anymore.

I got the 1060 ordered for $260. The 480s are nearly impossible to find at that price in any shop. $270+ for the lowest binned version. The 1060s aren't binned and OC well in general. 4xx it's a hit or miss with OC especially when they bin the chips and reserve better ones for the more expensive versions.

Ok fair enough. I just couldn't justify getting a 1060. It was a 480 or 1070. I had an EVGA 980 SC so getting a 1060 would have been a slight downgrade. A 480 may be the same but it has a bit of an X-factor in DX12/Vulkan and I wanted to put the finger up to Nvidia price increases so here I am with a Nitro on the way.
post #1073 of 4340
Hey Guys,
I'm planning to buy a Sapphire RX 460 2GB to replace my dead 7770
But I wonder if it'll work with my motherboard since it's still have legacy BIOS with no UEFI (MSI 880GM-E41)

waht do you think guys? will it work on my "ancient" motherboard?
post #1074 of 4340
Quote:
Originally Posted by Steinkovich View Post

Hey Guys,
I'm planning to buy a Sapphire RX 460 2GB to replace my dead 7770
But I wonder if it'll work with my motherboard since it's still have legacy BIOS with no UEFI (MSI 880GM-E41)

waht do you think guys? will it work on my "ancient" motherboard?

That MSI board has PCI-Ex16, which is compatible with PCI-Express 3.0 on the 460.
3770K
(14 items)
 
R7 1700
(8 items)
 
 
CPUMotherboardGraphicsRAM
RYZEN 1700 ASROCK AB350 GAMING K4 ZOTAC 1080TI REFERENCE MODEL G SKILL 8 GIG (2X) 
Hard DriveOSPowerCase
WESTERN DIGITAL 250 M.2 2280 WINDOWS 10 64 CORSAIR SF600 LIAN LI PC-O10 
  hide details  
Reply
3770K
(14 items)
 
R7 1700
(8 items)
 
 
CPUMotherboardGraphicsRAM
RYZEN 1700 ASROCK AB350 GAMING K4 ZOTAC 1080TI REFERENCE MODEL G SKILL 8 GIG (2X) 
Hard DriveOSPowerCase
WESTERN DIGITAL 250 M.2 2280 WINDOWS 10 64 CORSAIR SF600 LIAN LI PC-O10 
  hide details  
Reply
post #1075 of 4340
Quote:
Originally Posted by Shatun-Bear View Post

Ok fair enough. I just couldn't justify getting a 1060. It was a 480 or 1070. I had an EVGA 980 SC so getting a 1060 would have been a slight downgrade. A 480 may be the same but it has a bit of an X-factor in DX12/Vulkan and I wanted to put the finger up to Nvidia price increases so here I am with a Nitro on the way.

980 > 1060 kind of, 480 usually < 1060 at the moment because of lack of proper DX12 and Vulkan use.
I'm fine with either 1060 or 480, what ever I can get at decent price and works without issues, I'm even tempted by 4GB 480 but the VRAM is kind of on the limit even for 1920x1200px.
NV raised the prices for sure but then AMD follows them frown.gif

Second hand there seems to be nothing, most 980, 980Ti are overpriced to almost new price of competing products and sellers are mad what $ they ask for.
post #1076 of 4340
Quote:
Originally Posted by keikei View Post

Have you tried the latest driver? 16.8.3.

yes already tried that

AMD obviously doesnt like my 4K TV or my motherboard while Nvidia does so I gotta stick with what works. I really liked the 480
    
CPUMotherboardGraphicsRAM
Intel i7 6700 MSI B150 Mortar Artic Zotac GTX 1060 3GB Crucial 8 GB DDR4-2400 
Hard DriveOptical DriveOSMonitor
256 Mushkin Triactor Pioneer BR-RW Windows 10 LTSB x64 Seiki 4K 60HZ 42 inch 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7 6700 MSI B150 Mortar Artic Zotac GTX 1060 3GB Crucial 8 GB DDR4-2400 
Hard DriveOptical DriveOSMonitor
256 Mushkin Triactor Pioneer BR-RW Windows 10 LTSB x64 Seiki 4K 60HZ 42 inch 
  hide details  
Reply
post #1077 of 4340
Quote:
Originally Posted by dlee7283 View Post

yes already tried that

AMD obviously doesnt like my 4K TV or my motherboard while Nvidia does so I gotta stick with what works. I really liked the 480

So the issue has nothing to do with not being able to recovering from sleep right? https://www.reddit.com/r/AMDHelp/comments/4xhtla/monitors_wont_wake_from_sleep_after_rx_470/
3770K
(14 items)
 
R7 1700
(8 items)
 
 
CPUMotherboardGraphicsRAM
RYZEN 1700 ASROCK AB350 GAMING K4 ZOTAC 1080TI REFERENCE MODEL G SKILL 8 GIG (2X) 
Hard DriveOSPowerCase
WESTERN DIGITAL 250 M.2 2280 WINDOWS 10 64 CORSAIR SF600 LIAN LI PC-O10 
  hide details  
Reply
3770K
(14 items)
 
R7 1700
(8 items)
 
 
CPUMotherboardGraphicsRAM
RYZEN 1700 ASROCK AB350 GAMING K4 ZOTAC 1080TI REFERENCE MODEL G SKILL 8 GIG (2X) 
Hard DriveOSPowerCase
WESTERN DIGITAL 250 M.2 2280 WINDOWS 10 64 CORSAIR SF600 LIAN LI PC-O10 
  hide details  
Reply
post #1078 of 4340
Usually that black screen and problems are the hybrid sleep in Energy options of Windows, it's a long term problem Its more noticiable in Crossfire GPU's but in single too - Usually y recommend disable it - I have it disable too.-
post #1079 of 4340
Hmm. driver initialization from sleep and power on doesn't seem clean. I got a pink screen flash starting the driver right before the login and right before games. I get a green line shutting down. Now on the 16.8.3 driver I get a yellow screen flash for power on and starting games. So they changed something with how the driver initializes. Just not sure they've gotten it right yet. I don't sleep...I mean my computer doesn't sleep... but the driver has to initialize coming back from that too. . Sounds like a driver that isn't initializing the card cleanly yet. Since they changed something in 16.8.3 with how the card initializes, I'd say it would be worth a try for your blanking issues Also, since they specifically say they fixed an issue with the screen going blank. It would be worth a try.. We'll have to wait until they finally get this all the way right. Unless of course I'm the only one with the pink/yellow flash issue and it's just my messed up card.. I don't get unrecoverable black screens though I think its something AMD has had trouble with in the past.
post #1080 of 4340
Quote:
Originally Posted by keikei View Post

That MSI board has PCI-Ex16, which is compatible with PCI-Express 3.0 on the 460.

but will the card be compatible with non-UEFI/ legacy bios that my motherboard has?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › [Official] Polaris Owners Club