Overclock.net › Forums › Components › Mice › Nixeus REVEL [It's here!]
New Posts  All Forums:Forum Nav:

Nixeus REVEL [It's here!] - Page 92

post #911 of 2432
Haven't has that on any of my start ups. Aside from the flickering thing I don't have any noticable bugs.
post #912 of 2432
Cannot even order this mouse biggrin.gif
Ordered plenty of things from Amazon.co.UK to Sweden, but Nixeus does not ship to Sweden on Amazon.CO.UK for some reason biggrin.gif
post #913 of 2432
Yep, Nixeus really needs to get its shipping in order.

Mate of mine in Belgium wants one but can't because co.uk won't ship to Belgium either. Our only option in Europe (aside from UK) is to order it from the US and pay massive customs fees.
Desktop (Main)
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K ASUS X99-A/USB 3.1  ASUS ROG Strix GeForce GTX 1080 Kingston HyperX 16GB 3Ghz  
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Pro Seagate Barracuda 1.5 TB Seagate Barracuda 2.0 TB Seagate Barracuda 4TB 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda 4TB Le random dvd writer Corsair Hydro Series™ H100i Windows 10 Professional 64 bit 
MonitorKeyboardPowerCase
iiyama ProLite G2773HS Corsair K70 Super Flower 1200W (Platinum) Corsair 600T Black 
MouseMouse PadAudioAudio
Nixeus Revel Allsop Raindrop XL ASUS Xonar Essence STXII Sennheiser HD650 
Audio
Musical Fidelity X-Can v3 
  hide details  
Reply
Desktop (Main)
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K ASUS X99-A/USB 3.1  ASUS ROG Strix GeForce GTX 1080 Kingston HyperX 16GB 3Ghz  
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Pro Seagate Barracuda 1.5 TB Seagate Barracuda 2.0 TB Seagate Barracuda 4TB 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda 4TB Le random dvd writer Corsair Hydro Series™ H100i Windows 10 Professional 64 bit 
MonitorKeyboardPowerCase
iiyama ProLite G2773HS Corsair K70 Super Flower 1200W (Platinum) Corsair 600T Black 
MouseMouse PadAudioAudio
Nixeus Revel Allsop Raindrop XL ASUS Xonar Essence STXII Sennheiser HD650 
Audio
Musical Fidelity X-Can v3 
  hide details  
Reply
post #914 of 2432
Yeah, it bugs me a bit that mouse is sold in Europe yet only few ( like Germany and U.K? ) can only purchase one... It doesn't make any sense! Only way you can purchase in Europe is do something as stupid as drop shipping, or buy directly from Amazon.com which has crazy custom fees + shipping fees. Massdrop is decent but takes huge amount of time before shipping, like 2 weeks or more + custom wait time + domestic shipping. I hope they address this soon!
post #915 of 2432
Blame Brexit
post #916 of 2432
Sooo i think i bricked my revel for good now...
Replaced M1 and M2 with d2f-01f's, plugged in the stock cable and made sure the switches are working (worked).

Then i switched the cable to a paracord one i used in my WMO before, put the 4 cables in the right color order before and tested the mouse again.

LMB and RMB stopped working! Like i said they were working just before switching the cable.

I switched to the old cable = same problem.

Tested it on another pc, flashed back old firmware. Re-soldered the switches several times, new and working switches aswell. Nothing worked.

TL;DR:

So i basically have a mouse with everything besides LMB and RMB working because of switching the cable once (without the 5th shielding inner cable, which seemed to be the only difference). frown.gif

Ordered two new revels from amazon now.

But can anybody tell me what could have happened? Did the cable without shielding destroyed LMB and RMB without anything else? (which seems totally strange). Sensor, mwheel M3, M4, M5 and cpi button works.
Edited by turnschuh - 10/2/16 at 11:21am
post #917 of 2432
Quote:
Originally Posted by turnschuh View Post

Sooo i think i bricked my revel for good now...
Replaced M1 and M2 with d2f-01f's, plugged in the stock cable and made sure the switches are working (worked).

Then i switched the cable to a paracord one i used in my WMO before, put the 4 cables in the right color order before and tested the mouse again.

LMB and RMB stopped working! Like i said they were working just before switching the cable.

I switched to the old cable = same problem.

Tested it on another pc, flashed back old firmware. Re-soldered the switches several times, new and working switches aswell. Nothing worked.

TL;DR:

So i basically have a mouse with everything besides LMB and RMB working because of switching the cable once (without the 5th shielding inner cable, which seemed to be the only difference). frown.gif

Ordered two new revels from amazon now.

But can anybody tell me what could have happened? Did the cable without shielding destroyed LMB and RMB without anything else? (which seems totally strange). Sensor, mwheel M3, M4, M5 and cpi button works.


Its really hard to brick like that, even if you change the color on the connector and plugin wrong, windows should tell that does not recognize the device.
post #918 of 2432
Yea thats what i thought too, but good to know that i was thinking right.
So i dont know what happened. It is really strange. :S
post #919 of 2432
Quote:
Originally Posted by Nivity View Post

Cannot even order this mouse biggrin.gif
Ordered plenty of things from Amazon.co.UK to Sweden, but Nixeus does not ship to Sweden on Amazon.CO.UK for some reason biggrin.gif
That's outrageous! I demand to spend my money right now.
SmellyVRMs
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 970@not stable Gigabyte GA-990FXA-UD3 R9 270 Kingston HyperX 8Gb 
Hard DriveCoolingMonitorKeyboard
Seagate Barracuda CoolerMaster Hyper TX3 BenQ XL2411Z KC60 w/ Kailh Speed Silver 
PowerCaseMouse PadAudio
Zalman 600W Thermaltake Versa H25 Zowie G-SR Boarseman CX98S 
Audio
Steelseries Siberia V2 
  hide details  
Reply
SmellyVRMs
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 970@not stable Gigabyte GA-990FXA-UD3 R9 270 Kingston HyperX 8Gb 
Hard DriveCoolingMonitorKeyboard
Seagate Barracuda CoolerMaster Hyper TX3 BenQ XL2411Z KC60 w/ Kailh Speed Silver 
PowerCaseMouse PadAudio
Zalman 600W Thermaltake Versa H25 Zowie G-SR Boarseman CX98S 
Audio
Steelseries Siberia V2 
  hide details  
Reply
post #920 of 2432
Quote:
Originally Posted by turnschuh View Post

Yea thats what i thought too, but good to know that i was thinking right.
So i dont know what happened. It is really strange. :S

The guy in CeeSa's thread bricked his friend's Kinzu by wrong pinout. I however didn't brick g303 when i'd put pins in wrong order. My guess is there should be particular mistake in pinout for mouse to break (like putting 2 power pins in 2 data pins slot). Anyway it's better to consult people here who are experienced with PCB tinkering, they should know better.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Nixeus REVEL [It's here!]