Overclock.net › Forums › Graphics Cards › NVIDIA › 970 NO PICTURE ON THE SCREEN
New Posts  All Forums:Forum Nav:

970 NO PICTURE ON THE SCREEN

post #1 of 5
Thread Starter 
Hi guyshabe yesterday i bought a 970 g1 for my 1080p setup
My pc
Intel 2600k stock
Corsair 12gb 1333mhz ram
1TB HDD
128GB SSD
Z68A-GD65 G3
970 G1
Arctic Fusion 550RF 500W
By the first instalation i got a b2 error code on my screen,i exchanged my card an updated my motherboard bios.970 back in no picture on the monitor,no beep sounds but the fans are spinning.
Cleared CMOS,checked the 6 and 8 pin adapters but nothing,is there help?
Edited by yeezygod - 7/18/16 at 2:13am
post #2 of 5
Check the pci-e slot for dust and what not. Use a tooth brush to clean out the slot if it's dirty.

Check the teeth or the card too. Then make sure your card is properly inserted in the pci-e slot, evenly and firmly.
    
CPUMotherboardGraphicsRAM
8700k @5.1GHz Apex X TITAN X (Pascal)  Trident Z 4400MHz 
Hard DriveCoolingCoolingOS
750 NVMe 1.2TB EK HF/rx360/rx120 EK FC/GTs/mcp655 Windows 10 Pro  
MonitorPowerCaseAudio
BL3200PT 1600 T2 800d Pro Audio 2.1 + DragonFly Red 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
8700k @5.1GHz Apex X TITAN X (Pascal)  Trident Z 4400MHz 
Hard DriveCoolingCoolingOS
750 NVMe 1.2TB EK HF/rx360/rx120 EK FC/GTs/mcp655 Windows 10 Pro  
MonitorPowerCaseAudio
BL3200PT 1600 T2 800d Pro Audio 2.1 + DragonFly Red 
  hide details  
Reply
post #3 of 5
Check your motherboard BIOS and see if the default display adapter isn't set to Integrated Graphics mode. If that is the case, change it to PCI-E.
Crimson Dawn
(17 items)
 
  
CPUMotherboardGraphicsRAM
Inter Core i5 4440 @ 3.1 Ghz Asus B85M-GAMER Zotac Nvidia GeForce GTX 950 2GB Amp Edition! G.Skill RipjawsX 16GB (4x4GB) @ 1600 Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 750 EVO 120 GB SSD Seagate 500GB Seagate 250GB  LG DVD Burner 
CoolingOSMonitorKeyboard
Intel Stock Cooler Windows 10 Home 64 Bit AOC 16" (1366x768) Microsoft 800 
PowerCaseMouseMouse Pad
Seasonic S12II 620W Corsair Carbide SPEC - 03 Logitech G300s Red Gear MP35 Control Type Gaming Mousepad 
Audio
HyperX Cloud Drone 
  hide details  
Reply
Crimson Dawn
(17 items)
 
  
CPUMotherboardGraphicsRAM
Inter Core i5 4440 @ 3.1 Ghz Asus B85M-GAMER Zotac Nvidia GeForce GTX 950 2GB Amp Edition! G.Skill RipjawsX 16GB (4x4GB) @ 1600 Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 750 EVO 120 GB SSD Seagate 500GB Seagate 250GB  LG DVD Burner 
CoolingOSMonitorKeyboard
Intel Stock Cooler Windows 10 Home 64 Bit AOC 16" (1366x768) Microsoft 800 
PowerCaseMouseMouse Pad
Seasonic S12II 620W Corsair Carbide SPEC - 03 Logitech G300s Red Gear MP35 Control Type Gaming Mousepad 
Audio
HyperX Cloud Drone 
  hide details  
Reply
post #4 of 5
The card new or used?

Sounds almost like a short somewhere if you've got a motherboard making a beep noise... but its strange since my GTX970 that died would let my PC boot, obviously on integrated graphics but the card never spun its fans or nothin...
I'd inspect the card with and without the cooler really really well....make sure nothing is damaged or broken on it. Especially if its used.
post #5 of 5
Thread Starter 
Quote:
Originally Posted by MrTOOSHORT View Post

Check the pci-e slot for dust and what not. Use a tooth brush to clean out the slot if it's dirty.

Check the teeth or the card too. Then make sure your card is properly inserted in the pci-e slot, evenly and firmly.
you was right,the pci was just dirty i love you guuuuuuuuuuuuuys <3
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › 970 NO PICTURE ON THE SCREEN