Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › something weired with my MSI Ge60 2pe
New Posts  All Forums:Forum Nav:

something weired with my MSI Ge60 2pe

post #1 of 2
Thread Starter 

I bought this laptop from a friend and its been great until last night. If I shut down the laptop then go to press the power button to turn it on it will display the MSI logo and BAM shut right down BUT if I press the power button and hold it for 2-3 seconds it boots up perfectly fine. This laptop has windows 10. Im not sure whats going on.

 

I havent tried updating bios because im not sure how. This laptop does not have an automatic BIOS update you have to put the file some where and go into the bios and install it

 

I tried 

 

Removing my SSD

Removing my HDD

Removing each 8gb of ram

tried resetting BIOS

tried removing the battery

tried removing the power supply

tried removing my external cooling fan

Intel
(17 items)
 
  
CPUMotherboardGraphicsRAM
2500K (4.2ghz) GIGABYTE GA-Z68AP-D3 Gigabyte 1060 3GB Adata XPG DDR3 1600 8GB 
Hard DriveHard DriveOptical DriveCooling
500GB Seagate PNY 128GB SSD LG M-Disc DEEPCOOL GAMMAXX S40 
OSMonitorKeyboardPower
Windows 10 Home LG 25um56 2560x1080 Ultrawide (IPS) Logitech k360 Seasonic S12II 520w (Bronze) 
CaseMouseMouse PadAudio
Rosewill Nautilus  Havit Magic Eagle Steel series (world of warcraft) GX Gaming 2.1 (Onboard Audio) 
  hide details  
Reply
Intel
(17 items)
 
  
CPUMotherboardGraphicsRAM
2500K (4.2ghz) GIGABYTE GA-Z68AP-D3 Gigabyte 1060 3GB Adata XPG DDR3 1600 8GB 
Hard DriveHard DriveOptical DriveCooling
500GB Seagate PNY 128GB SSD LG M-Disc DEEPCOOL GAMMAXX S40 
OSMonitorKeyboardPower
Windows 10 Home LG 25um56 2560x1080 Ultrawide (IPS) Logitech k360 Seasonic S12II 520w (Bronze) 
CaseMouseMouse PadAudio
Rosewill Nautilus  Havit Magic Eagle Steel series (world of warcraft) GX Gaming 2.1 (Onboard Audio) 
  hide details  
Reply
post #2 of 2
Thread Starter 

i ended up figuring it out. I took the entire laptop apart and reseated and firmly screwed down the power button and put it all back together and now it works. i also went ahead and Re-enforced the touch pad and made it more stable. seems better then it did. 

Intel
(17 items)
 
  
CPUMotherboardGraphicsRAM
2500K (4.2ghz) GIGABYTE GA-Z68AP-D3 Gigabyte 1060 3GB Adata XPG DDR3 1600 8GB 
Hard DriveHard DriveOptical DriveCooling
500GB Seagate PNY 128GB SSD LG M-Disc DEEPCOOL GAMMAXX S40 
OSMonitorKeyboardPower
Windows 10 Home LG 25um56 2560x1080 Ultrawide (IPS) Logitech k360 Seasonic S12II 520w (Bronze) 
CaseMouseMouse PadAudio
Rosewill Nautilus  Havit Magic Eagle Steel series (world of warcraft) GX Gaming 2.1 (Onboard Audio) 
  hide details  
Reply
Intel
(17 items)
 
  
CPUMotherboardGraphicsRAM
2500K (4.2ghz) GIGABYTE GA-Z68AP-D3 Gigabyte 1060 3GB Adata XPG DDR3 1600 8GB 
Hard DriveHard DriveOptical DriveCooling
500GB Seagate PNY 128GB SSD LG M-Disc DEEPCOOL GAMMAXX S40 
OSMonitorKeyboardPower
Windows 10 Home LG 25um56 2560x1080 Ultrawide (IPS) Logitech k360 Seasonic S12II 520w (Bronze) 
CaseMouseMouse PadAudio
Rosewill Nautilus  Havit Magic Eagle Steel series (world of warcraft) GX Gaming 2.1 (Onboard Audio) 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Laptops and Netbooks
Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › something weired with my MSI Ge60 2pe