Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5770 screw up sometimes after upgrade to Windows 10
New Posts  All Forums:Forum Nav:

HD5770 screw up sometimes after upgrade to Windows 10

post #1 of 13
Thread Starter 
I don't remember I have this problem when I was with Windows 7. After upgrade to Windows 10, while I play CSGO or watching youtube video in Chrome with hardware acceleration, sometimes around 1 time out of 5 days the screen just go blank then the computer restart itself. The monitor would be off even Windows runs after restarts. I have to press power button to let Windows 10 shut down in login screen (while I cannot see it through monitor since it is blank), then start the computer again and everything would be fine again. Anyway to check the log or do anything to help this? I did totally uninstall the driver and let Windows 10 install the graphic card driver.
post #2 of 13
Thread Starter 
same problem happens again
post #3 of 13
Tell us more about your rig. Tell us everything. Is it one 5770? 2?

Off hand I would re-install direct X
Let the AMD software install itself not windows.
Clear the drivers with driver sweeper or something then reinstall it.
    
CPUMotherboardGraphicsRAM
Core i7 980X 3.33ghz (4.5ghz) Rampage 3 Extreme 2x Powercolor 7990 (1 devil 1 stock) 24 gigs GSKILL DDR3-2133 
Hard DriveOptical DriveCoolingCooling
Corsair 240 gb SSD / 500gb Seagate none :( XSPC RASA Ultimate -Performance-PCs Über 655 Fu... 1 Aquacomputer Airplex Modularity Rad System 240mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 3x Acer G245HBMID 24" G15 (old school)  Lian Li 750-850 watts , OCZ 1250 ZXseries 
CaseMouseMouse PadAudio
Lian Li PC-70 Midtower Logitech G700 Teflon coated :D onboard soundmax Creative 7.1 
OtherOther
6x Delta Fans!!!! WHOOOOOOOOSH Hailea HC-250A 110V (1/6HP=295Watt cooling capa... 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 980X 3.33ghz (4.5ghz) Rampage 3 Extreme 2x Powercolor 7990 (1 devil 1 stock) 24 gigs GSKILL DDR3-2133 
Hard DriveOptical DriveCoolingCooling
Corsair 240 gb SSD / 500gb Seagate none :( XSPC RASA Ultimate -Performance-PCs Über 655 Fu... 1 Aquacomputer Airplex Modularity Rad System 240mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 3x Acer G245HBMID 24" G15 (old school)  Lian Li 750-850 watts , OCZ 1250 ZXseries 
CaseMouseMouse PadAudio
Lian Li PC-70 Midtower Logitech G700 Teflon coated :D onboard soundmax Creative 7.1 
OtherOther
6x Delta Fans!!!! WHOOOOOOOOSH Hailea HC-250A 110V (1/6HP=295Watt cooling capa... 
  hide details  
Reply
post #4 of 13
Thread Starter 
Quote:
Originally Posted by Maximus Thalos View Post

Tell us more about your rig. Tell us everything. Is it one 5770? 2?

Off hand I would re-install direct X
Let the AMD software install itself not windows.
Clear the drivers with driver sweeper or something then reinstall it.

just one hd5770, gigabyte
updated from window 7 professional 64bits to windows 10 pro
cpu pentium e6500
motherboard intel dg41ty
2gb ram x 2 total 4gb ram
24“ samsung monitor connect with dvi port
550w power supply FSP HEXA+ 550 less than 1 year ago.

I need to find a way to solve the blank screen problem first. It is totally blank after I turn on the computer but I can hear windows 10 runs as normal and I can press power button once to let windows 10 normally shut down(not holding power button to force electronic shut down)
Edited by espn - 8/11/16 at 10:08pm
post #5 of 13
Thread Starter 
This casee sounds like almost exactly same as mine:
https://www.techpowerup.com/forums/threads/constant-black-screen-crashing-is-it-the-psu.220989/
and look like the conculsion is power supply.
Anyway for me to check it?
post #6 of 13
Next best guess would be the power supply. You dont have a tester put in a larger one. If its stable it's most likely the problem. Otherwise your card is shorting out or the power pins are loose. Check the cables for burned markings too. Tou never know.
    
CPUMotherboardGraphicsRAM
Core i7 980X 3.33ghz (4.5ghz) Rampage 3 Extreme 2x Powercolor 7990 (1 devil 1 stock) 24 gigs GSKILL DDR3-2133 
Hard DriveOptical DriveCoolingCooling
Corsair 240 gb SSD / 500gb Seagate none :( XSPC RASA Ultimate -Performance-PCs Über 655 Fu... 1 Aquacomputer Airplex Modularity Rad System 240mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 3x Acer G245HBMID 24" G15 (old school)  Lian Li 750-850 watts , OCZ 1250 ZXseries 
CaseMouseMouse PadAudio
Lian Li PC-70 Midtower Logitech G700 Teflon coated :D onboard soundmax Creative 7.1 
OtherOther
6x Delta Fans!!!! WHOOOOOOOOSH Hailea HC-250A 110V (1/6HP=295Watt cooling capa... 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 980X 3.33ghz (4.5ghz) Rampage 3 Extreme 2x Powercolor 7990 (1 devil 1 stock) 24 gigs GSKILL DDR3-2133 
Hard DriveOptical DriveCoolingCooling
Corsair 240 gb SSD / 500gb Seagate none :( XSPC RASA Ultimate -Performance-PCs Über 655 Fu... 1 Aquacomputer Airplex Modularity Rad System 240mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 3x Acer G245HBMID 24" G15 (old school)  Lian Li 750-850 watts , OCZ 1250 ZXseries 
CaseMouseMouse PadAudio
Lian Li PC-70 Midtower Logitech G700 Teflon coated :D onboard soundmax Creative 7.1 
OtherOther
6x Delta Fans!!!! WHOOOOOOOOSH Hailea HC-250A 110V (1/6HP=295Watt cooling capa... 
  hide details  
Reply
post #7 of 13
Thread Starter 
Quote:
Originally Posted by Maximus Thalos View Post

Next best guess would be the power supply. You dont have a tester put in a larger one. If its stable it's most likely the problem. Otherwise your card is shorting out or the power pins are loose. Check the cables for burned markings too. Tou never know.

thanks. I have a new power supply at my parent home so I can bring it back and try it.

There is new problem today: 1 ram slot cannot detect ram. I am having 2 gb each ram in 2 slot. I was trying to unplug one ram to see if rhe graphic card can work, but then I test both ram works in 1 slot but 1 slot cannot detect either ram.

There is another old and still exist problem, few months ago the power button would not let me power on computer sometimes. I need to hold the power button like 1 to 2 seconds then have around 85% chance to turn it on, same problem still exists.
post #8 of 13
Thread Starter 
i just tested with a new power supply and it is interesting that:
1. graphic card still black screen
2. onboard display works fine now, before with old power supply it just let me boot to windows 10 logo for few seconds then black screen but the sound shows windows 10 still works and can use power button to turn off normally.
3. still just 1 ram slot works.

I think the motherboard has serious problem. I will go to buy a new motherboard, cpu, and ram today. I don't have a choice ha ha.
post #9 of 13
Bummer but at least we tried. I would think your CPU is just fine tho. They are pretty hardy. ram and mobo tho might need to be replaced.
    
CPUMotherboardGraphicsRAM
Core i7 980X 3.33ghz (4.5ghz) Rampage 3 Extreme 2x Powercolor 7990 (1 devil 1 stock) 24 gigs GSKILL DDR3-2133 
Hard DriveOptical DriveCoolingCooling
Corsair 240 gb SSD / 500gb Seagate none :( XSPC RASA Ultimate -Performance-PCs Über 655 Fu... 1 Aquacomputer Airplex Modularity Rad System 240mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 3x Acer G245HBMID 24" G15 (old school)  Lian Li 750-850 watts , OCZ 1250 ZXseries 
CaseMouseMouse PadAudio
Lian Li PC-70 Midtower Logitech G700 Teflon coated :D onboard soundmax Creative 7.1 
OtherOther
6x Delta Fans!!!! WHOOOOOOOOSH Hailea HC-250A 110V (1/6HP=295Watt cooling capa... 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 980X 3.33ghz (4.5ghz) Rampage 3 Extreme 2x Powercolor 7990 (1 devil 1 stock) 24 gigs GSKILL DDR3-2133 
Hard DriveOptical DriveCoolingCooling
Corsair 240 gb SSD / 500gb Seagate none :( XSPC RASA Ultimate -Performance-PCs Über 655 Fu... 1 Aquacomputer Airplex Modularity Rad System 240mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 3x Acer G245HBMID 24" G15 (old school)  Lian Li 750-850 watts , OCZ 1250 ZXseries 
CaseMouseMouse PadAudio
Lian Li PC-70 Midtower Logitech G700 Teflon coated :D onboard soundmax Creative 7.1 
OtherOther
6x Delta Fans!!!! WHOOOOOOOOSH Hailea HC-250A 110V (1/6HP=295Watt cooling capa... 
  hide details  
Reply
post #10 of 13
Thread Starter 
Quote:
Originally Posted by Maximus Thalos View Post

Bummer but at least we tried. I would think your CPU is just fine tho. They are pretty hardy. ram and mobo tho might need to be replaced.

I will donate this motherboard. I am not sure if it is hd5770 or the motherboard graphic card slot has problem. I will buy new cpu, ram, motherboard and try to use with existing hd5770.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5770 screw up sometimes after upgrade to Windows 10