Overclock.net › Forums › Graphics Cards › AMD/ATI › Bios modification request
New Posts  All Forums:Forum Nav:

Bios modification request - Page 2

post #11 of 14
Thread Starter 
I'm still doing preliminary testing but so far it looks like I can get the same performance I was aiming for with stock clocks of 1030 core, 1600 mhz ram, and stock voltage with just the power target pushed to +50%.

So, so far.. this is quite a big (nice) improvement.
post #12 of 14
Thread Starter 
Still trying to figure out how to get this flashing to work right and experimenting with it.......

After some more testing.. I can't get the core clock to lift off of sapphire's default 1030 mhz with this ram timings shifted bios no matter how much power or voltage I throw at it. It just won't do it. So sure I can get ram faster.. but in 3dmark and games it's not as fast as core boost + ram boost together.

And almost everything I try writing in hawaii bios booster either doesn't work, doesn't have desired outcome when flashed.. or makes it black screen from simple changes like ram clock with stock voltage.. which works in trixx, but not with a bios write and flashing.. so I dunno. I appreciate your help but I think I'm nearly going to give up and just go back to stock bios and the overclock I had. For what ever reason.. I seem doomed to never have anything work right.

I've spent almost all day and all night flashing and trying to clock this thing and not made much progress towards anything better than what I had before. Even this shifted bios for ram timings with ram at 1630 mhz and nothing else.. in games is kind of "meh" after a bit.

At this point I think I'm almost going to give up.. I want to be playing games and enjoying my new card and I've spent more time trying to bios flash and tune it than actually enjoying any games on it.

Thanks for your help though.
Edited by kithylin - 8/15/16 at 12:45am
post #13 of 14
Forget the ROM I linked in post 9.

I will do you some ROMs that you can compare in HawaiiReader showing what I'd be doing if had your card.

First step I'd make GPU Clock 2 and GPU Freq Table (DPM 2) match, I'd make RAM Clock 2 and RAM Freq Table (DPM 1 & 2) all 1250MHz. This helped me keep lower voltage in DPM 1 & 2 and also aided with black screen when GPU VID was too low but RAM clock to high (ie >1250MHz). This will be file VX290X_8GB_V1.rom in zip.

Second step I'd manually set DPM 1 - 7 as the EVV calculated VID per DPM manually. This will be file VX290X_8GB_V2.rom in zip.

Third step I'd make DPM 0 0.968V (ie 986mV) and DPM 1 1.075V. Reason being why is 290X DPM 0 stock AMD is 0.968V but seen a few cards where they increase it but may not be required. DPM 1 oddly on your card is calculated higher than DPM 2, The Stilt advised in Hawaii bios mod just to lower it as it's just an anomaly (short version, see thread for info). I have also modified another section in PowerPlay to match new DPM 0 VID, you will not see this in HawaiiReader as it does not show this section in ROM. This will be file VX290X_8GB_V3.rom in zip.


kithylin_VX290X_8GB_Mods.zip 124k .zip file


Note: Offsets have not been zero'd in via above ROMs which exist on your card, as highlighted in earlier post. I'll zero those later as it's a lot of manual modding.

Don't give up now, I have spent days on "stuff" related to bios mod wink.gif . I would try ROM VX290X_8GB_V3 first, see if you achieve the same OC as stock ROM using SW in OS. None of the ROMs have tighter RAM straps or 390/X MC in it, so there is no performance gain over stock on that front. I'm just setting up base mod ROM in a way. I have double checked these ROMs are correctly modified by manually comparing them in hex editor, just like I would if flashing my own card.

Prior to a flash I usually delete a file that MSI AB saves, it records some settings it detects from ROM, this file is located in install dir /profiles and begins with VEN. I have never used TriXX so can not highlight what it may save and what to delete, perhaps just uninstall it and make sure install dir is empty. If you uninstall any of these programs do not keep any saved profiles / settings.

After a flash I usually switch PC fully off and on to reinitialize card. Then when I enter OS I reset driver to "factory defaults".

HTH you.
Edited by gupsterg - 8/15/16 at 4:01am
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
post #14 of 14
Thread Starter 
With my nvidia card.. I just posted what overclock I had stable and some nice guy on the forums came back with a bios, flashed it and it worked for 8 months daily and there was never a single issue, and I was even able to make a few tweaks myself and it worked fine.

But with this AMD card.. my dreams of having my 100% stable daily-driver overclock written permanently to the bios of the card without having to use software is just that.. a dream. It will never work and I'm not trying anymore.

I'm tired of trips to safe mode every 5 minutes to remove it and re-flashing something again and again and again and nothing -NOTHING- works for AMD cards from that bios editor. I make tiny minute changes and it just runs black screen, distorted display and crashes everywhere.

I don't want to be rude but I really didn't want to dig in that deep and learn bios editing myself and especially down to the hex editing level. That's just too much and my brain hurts trying to figure it out.

So, sorry you already spent effort on me.. and I'm just trying to tell you, don't spend any further effort on me.

I'm abandoning this and just going as I am forever.

Maybe some day AMD can fix Crimson drivers so we can use software overclocks with it and this bios mess won't be needed.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Bios modification request