Overclock.net › Forums › General Hardware › General Processor Discussions › concerned about over all temps in my setup
New Posts  All Forums:Forum Nav:

concerned about over all temps in my setup

post #1 of 3
Thread Starter 
Hey all i got a few conserining issues. when playing games like witcher 3 im getting random fps drops and i dont think i should be getting any kind of fps drop at all considering my setup.though please correct me if im wrong. using afterburner to monitor ingame im getting temps in the 70 + on my gpus and cpu. i am only on 4.1ghz using latest bios drivers on my motherbord.. is this normal?
post #2 of 3
You're just on air I'm guessing? Seems OK, could be better. Unless you're noticing the fps drop with some spike in fan activity or something indicating the temps are jumping up, could be just Wither3 and it's bad optimization.

Could try a better CPU cooler and better thermal paste, the GPU seems OK at that temp if it's working hard (which it would be on Witcher3, I'm guessing you have the graphics settings turned up nice n high smile.gif )
Ol'Faithful
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon x5660 P6X58D-E XFX AMD Radeon R9 280X Corsair Vengeance 24 GB Triple Chanel 6x4GB 
Optical DriveCoolingOSMonitor
Lite-On DVD-RW Noctua DH-14 CPU Cooler Windows 7 Pro x64 Samsung 24" LED 1080p 5ms DVI (S23A300B) 
PowerMouseAudio
Thermaltake Toughpower 750W Gold Corsair M95 Onboard :S 
  hide details  
Reply
Ol'Faithful
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon x5660 P6X58D-E XFX AMD Radeon R9 280X Corsair Vengeance 24 GB Triple Chanel 6x4GB 
Optical DriveCoolingOSMonitor
Lite-On DVD-RW Noctua DH-14 CPU Cooler Windows 7 Pro x64 Samsung 24" LED 1080p 5ms DVI (S23A300B) 
PowerMouseAudio
Thermaltake Toughpower 750W Gold Corsair M95 Onboard :S 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by spinFX View Post

You're just on air I'm guessing? Seems OK, could be better. Unless you're noticing the fps drop with some spike in fan activity or something indicating the temps are jumping up, could be just Wither3 and it's bad optimization.

Could try a better CPU cooler and better thermal paste, the GPU seems OK at that temp if it's working hard (which it would be on Witcher3, I'm guessing you have the graphics settings turned up nice n high smile.gif )

no im not on an aircooler if you read my hardware you would see im using a watercooler for my cpu. i run the game at 1440p with everything max but foliage distance. if its higher then high. i get fps drops more. i orignaly build this thinking it would handel 4k gaming at 60fps..it dosent. and this seems wrong. even in doom at 4k i dont get 60fps at ultra and im consernd somthing is wrong in my rig.but not sure what. thanks
Edited by morta - 8/17/16 at 7:02pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Processor Discussions
Overclock.net › Forums › General Hardware › General Processor Discussions › concerned about over all temps in my setup