Overclock.net › Forums › Components › Power Supplies › PSU only runs for 3 seconds. Help needed.
New Posts  All Forums:Forum Nav:

PSU only runs for 3 seconds. Help needed.

post #1 of 6
Thread Starter 
I have an old Cooler Master RS-460-PCAR-A3 PSU that only runs for approx 3 seconds, then shuts down.
The PSU came pre-installed in the Elite 334 casing, which I had many years ago for my basic type-writing-rig.

I removed the PSU from the case and did a simple troubleshooting. Jumpered the green pin to the ground and started it, but only for a few seconds, and it went dead again. Tried cycling the mechanical switch again but to no avail. It just remains dead. As it is no longer running, I can't even measure the 3.3v / 5v / 12v rails.
The only way to start it again is after a very long wait (probably waiting for all the charges inside to dissipate).

I don't think I've missed anything. Does that Pin8 PWR OK grey wire has any effect on this (duration of PSU running)?

Anything else that I can measure?
post #2 of 6
What you have is there is just terrible so throw it into the nearest dumpster and get a decent PSU instead
Why you should not buy a Cooler Master Extreme Power Plus / Tomahawk

Its not worth wasting any time on as its pretty much junk and as it says in that thread above it cant do anywhere near its rated wattage.
Seravee
(27 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming EVGA GTX 1080 FTW2 Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD60EZRX  WD Red WD80EFZX 8TB  Seagate Ironwolf Pro 10 TB 
Optical DriveCoolingCoolingOS
LG CH12NS30 x5 Noctua NF-A14 FLX Noctua NH-D15S Windows 7 64 Bit 
MonitorMonitorKeyboardPower
Asus PG279Q LG 49UH750V 4K LED TV Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone EMP Roccat Sense Metor Sennheiser HD 598 
AudioAudioAudioAudio
Onkyo TX NR646  Dali Opticon Vokal x2 Dali Opticon 2 x2 Dali Opticon 1 
AudioOtherOther
Dali E12 F Subwoofer CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
Seravee
(27 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming EVGA GTX 1080 FTW2 Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD60EZRX  WD Red WD80EFZX 8TB  Seagate Ironwolf Pro 10 TB 
Optical DriveCoolingCoolingOS
LG CH12NS30 x5 Noctua NF-A14 FLX Noctua NH-D15S Windows 7 64 Bit 
MonitorMonitorKeyboardPower
Asus PG279Q LG 49UH750V 4K LED TV Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone EMP Roccat Sense Metor Sennheiser HD 598 
AudioAudioAudioAudio
Onkyo TX NR646  Dali Opticon Vokal x2 Dali Opticon 2 x2 Dali Opticon 1 
AudioOtherOther
Dali E12 F Subwoofer CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
post #3 of 6
Thread Starter 
Quote:
Originally Posted by shilka View Post

What you have is there is just terrible so throw it into the nearest dumpster and get a decent PSU instead
Why you should not buy a Cooler Master Extreme Power Plus / Tomahawk

Its not worth wasting any time on as its pretty much junk and as it says in that thread above it cant do anywhere near its rated wattage.
I know it's junk but it had served for 6 years before it died. It powered a Pentium E5200, Biostar G31 mobo, 2x1GB RAM, 1 optical drive and 2 HDDs.
I've disassembled the PSU, found 2 blown caps (10v 1000uF).
post #4 of 6
Would you mind taking some pictures and posting them in that thead?
Would like to see those blown caps

If you have not thrown it out already?
Thanks.
Seravee
(27 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming EVGA GTX 1080 FTW2 Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD60EZRX  WD Red WD80EFZX 8TB  Seagate Ironwolf Pro 10 TB 
Optical DriveCoolingCoolingOS
LG CH12NS30 x5 Noctua NF-A14 FLX Noctua NH-D15S Windows 7 64 Bit 
MonitorMonitorKeyboardPower
Asus PG279Q LG 49UH750V 4K LED TV Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone EMP Roccat Sense Metor Sennheiser HD 598 
AudioAudioAudioAudio
Onkyo TX NR646  Dali Opticon Vokal x2 Dali Opticon 2 x2 Dali Opticon 1 
AudioOtherOther
Dali E12 F Subwoofer CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
Seravee
(27 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming EVGA GTX 1080 FTW2 Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD60EZRX  WD Red WD80EFZX 8TB  Seagate Ironwolf Pro 10 TB 
Optical DriveCoolingCoolingOS
LG CH12NS30 x5 Noctua NF-A14 FLX Noctua NH-D15S Windows 7 64 Bit 
MonitorMonitorKeyboardPower
Asus PG279Q LG 49UH750V 4K LED TV Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt 
CaseMouseMouse PadAudio
Phanteks Enthoo Luxe Roccat Kone EMP Roccat Sense Metor Sennheiser HD 598 
AudioAudioAudioAudio
Onkyo TX NR646  Dali Opticon Vokal x2 Dali Opticon 2 x2 Dali Opticon 1 
AudioOtherOther
Dali E12 F Subwoofer CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
post #5 of 6
Thread Starter 

post #6 of 6
Quote:
Originally Posted by poinguan View Post

I know it's junk but it had served for 6 years before it died. It powered a Pentium E5200, Biostar G31 mobo, 2x1GB RAM, 1 optical drive and 2 HDDs.
I've disassembled the PSU, found 2 blown caps (10v 1000uF).

Surprised it didn't damage any of those components over the years.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › PSU only runs for 3 seconds. Help needed.