Overclock.net › Forums › Components › Hard Drives & Storage › Seagate 1TB bricked firmware
New Posts  All Forums:Forum Nav:

Seagate 1TB bricked firmware

post #1 of 8
Thread Starter 
I checked the bricked firmware thread already, stumped and got no replies so I'm starting a new post.

Had a Seagate usb GoFlex 1TB drive suddenly become unrecognizable. Drive is ST1000LM010. Disappeared from drive management.
Sent it for free diags, they said unrepairable - firmware is corrupt, so I'm trying to use the tutorial to rebuild the firmware. I have a USB/TTL converter wired up with gnd/TX/RX to the drive, and cable plugged in for power (paper insulating the data connector).
I plugged the drive in til it stopped powering up (I dont have any weird drive sounds). Plugged in the USB (installed drivers ok), then ran hyperterminal.

At hyperterminal it doesn't bring up F3 T>, just a blinking cursor. I swapped TX and RX thinking I got them crossed, still no effect.

Can someone confirm the proper pinouts for Freeplay ST1000LM010 at least? I don't know why I'm not getting a response from Hyperterm, does that mean it's truly unrepairable?
post #2 of 8
do you have " Must have " data on it? like pictures, videos, music and such?

My best and successful 90% of the time is, if your drive becomes unreadable, the next , best step is to get on ebay, look up theres PCB boards / model #s you'll have to find that matches the exact board on your HDD.

I've done this so many times for customers for my version of data recovery without using software, if they become unrecognizable , anyways.

Could you supply a picture on the board on your HDD so I can help you find a board?

Looks something like this is what we're looking for.


Edited by Cloudforever - 9/10/16 at 6:49am
post #3 of 8
Thread Starter 


That's the board, 100609264 rev B. I've looked into this, how can you match the firmware? Isn't it unique to the drive? or do I have to reprogram the firmware when I get it?
post #4 of 8
basically when you search for that board, its going to match exactly what was on the other PCB, throw it on and voila, most the time it works.

If its not been dropped or physically damaged inside. sometimes when you do an update to your firmware like that, in my expierence, sometimes it'll cause your issue. buy anybody quote me if i'm wrong.

No, it is not unique to the drive. Its basically just on the PCB. Thats where your co processor is and all that jazz. on the board itself.

I just did a search for your board on ebay.

http://www.ebay.com/sch/i.html?_from=R40&_sacat=0&_nkw=100609264+rev+B&_sop=7

Here is for the hard drive, and you'd have to send a message asking if that # would be identical to your hard drive's PCB

http://www.ebay.com/sch/i.html?_odkw=100609264+rev+B&_sop=7&_osacat=0&_from=R40&_trksid=p2045573.m570.l1313.TR3.TRC2.A0.H0.XST1000LM010.TRS0&_nkw=ST1000LM010&_sacat=0
post #5 of 8
Thread Starter 
Probably my only hope, I'll order one and give it a shot. I'll update here after all said and done.
post #6 of 8
Yeaaa, I mean besides when they're physically damaged and extremely hard to get data off without having to send it out, i used software.

Hardware wise when they do that, thats really the only suggestion I can give you without having to send it out =\

We use those types of HDDs at my data center. they're great drives.

Hope it works no problem for you!
post #7 of 8
Thread Starter 
I got the pcb in today - pretty fast for china shipping. Swapped it out.
The only progress is now the light on the cable for the usb interface blinks like an error. Before it didn't do a thing. But it still doesntt show up in disk management. I'll try to hook up the wires to this board and see if I can see it in hyperterminal now.
post #8 of 8
Thread Starter 
Okay... are you still around? I got the board installed and finally got around to rewiring the TX/RX. Just putting the board in didn't help at all, I didn't expect it would, but I do get a blue light on the usb now which is an improvement. Is there a link to a walkthrough to get me through the hyperterminal stuff to see if I can read it?

I still get no prompt in hyperterminal.
Edited by kmesse - 10/9/16 at 5:23pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › Seagate 1TB bricked firmware