Overclock.net › Forums › Software, Programming and Coding › Networking & Security › What elements provide a snappy browser experience?
New Posts  All Forums:Forum Nav:

What elements provide a snappy browser experience?

post #1 of 21
Thread Starter 
So I asked this here.

http://www.overclock.net/t/1611901/m4600-w-slow-broswer-interactions

Seems people have no idea, so I'll ask the networking group for any ideas.

Basically my laptop is only slow on loading pages but after is fine, what can I do to promote browser performance? I don't have this issue on my sig rig, so it has to be the laptop, and I need the laptop to act as my primary going forward.

Thanks for any help, I need this laptop for school so I need it to work for me.
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
post #2 of 21
You could test your DNS servers. I'm not sure what there is to do that now, but you could try to find a free project that I think was called namebench (that's what I used in the past), and if your DNS servers are slow, you could change them to faster ones.

Unless I'm misunderstanding what you mean when you say loading?

Is the web browser you're using up to date? In the other thread you said it was firefox, are you still using that?

When you say other than page loading it is fine, does that mean you can load a 1080p video on youtube, and watch it with no issue (such as buffering or stuttering?).
Deepthought
(15 items)
 
Baldr
(14 items)
 
Terminal Dogma
(6 items)
 
CPUMotherboardGraphicsRAM
AMD A10-7850K MSI A88XM-GAMING Integrated Crucial Ballistix Sport  
Hard DriveCoolingCoolingCooling
Samsung 850 EVO  Prolimatech Genesis Black 2x Phanteks PH-F140HP 3x Noctua NF-P14S 
OSMonitorKeyboardCase
Debian 8 Samsung UN55H6350AFXZA Dell Generic Nanoxia Deep Silence 5 
MouseOther
Logitech G402 HP NC364T 
CPUGraphicsRAMHard Drive
Intel Core I3 M370 Intel HD Toshiba Samsung 850 EVO 
OSOS
Windows 7 Ultimate Fedora 21 
  hide details  
Reply
Deepthought
(15 items)
 
Baldr
(14 items)
 
Terminal Dogma
(6 items)
 
CPUMotherboardGraphicsRAM
AMD A10-7850K MSI A88XM-GAMING Integrated Crucial Ballistix Sport  
Hard DriveCoolingCoolingCooling
Samsung 850 EVO  Prolimatech Genesis Black 2x Phanteks PH-F140HP 3x Noctua NF-P14S 
OSMonitorKeyboardCase
Debian 8 Samsung UN55H6350AFXZA Dell Generic Nanoxia Deep Silence 5 
MouseOther
Logitech G402 HP NC364T 
CPUGraphicsRAMHard Drive
Intel Core I3 M370 Intel HD Toshiba Samsung 850 EVO 
OSOS
Windows 7 Ultimate Fedora 21 
  hide details  
Reply
post #3 of 21
Thread Starter 
Yes correct, it doesn't have any trouble getting to the website it's loading it up to view that is the problem. It more or less hangs for 30-40 seconds then finishes rendering the page.

It's why I am curious as to what attributes are the primary factors that enable a pleasant browsing experience. My hardware must be faulty. For brevity I'll post it here too.

I7 2670qm
20gb 1333 (8 + 4 + 4 + 4)
128gb c300 msata ssd
2.5 TB of HDD ( 2x sata + 1x USB 3.0)
quadro 1000m (consumer version is 540m)
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
post #4 of 21
Thread Starter 
bump
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
post #5 of 21
Is your browser up to date? I didn't see an answer to that. What kinds of extensions do you use? How about browser settings?

If you have firefox on your other computer, did you try setting this machine up in the exact same manner?

Have you tried both wired and wireless networking? Edit: saw the answer in your other thread
Edited by maddangerous - 9/30/16 at 4:18pm
Deepthought
(15 items)
 
Baldr
(14 items)
 
Terminal Dogma
(6 items)
 
CPUMotherboardGraphicsRAM
AMD A10-7850K MSI A88XM-GAMING Integrated Crucial Ballistix Sport  
Hard DriveCoolingCoolingCooling
Samsung 850 EVO  Prolimatech Genesis Black 2x Phanteks PH-F140HP 3x Noctua NF-P14S 
OSMonitorKeyboardCase
Debian 8 Samsung UN55H6350AFXZA Dell Generic Nanoxia Deep Silence 5 
MouseOther
Logitech G402 HP NC364T 
CPUGraphicsRAMHard Drive
Intel Core I3 M370 Intel HD Toshiba Samsung 850 EVO 
OSOS
Windows 7 Ultimate Fedora 21 
  hide details  
Reply
Deepthought
(15 items)
 
Baldr
(14 items)
 
Terminal Dogma
(6 items)
 
CPUMotherboardGraphicsRAM
AMD A10-7850K MSI A88XM-GAMING Integrated Crucial Ballistix Sport  
Hard DriveCoolingCoolingCooling
Samsung 850 EVO  Prolimatech Genesis Black 2x Phanteks PH-F140HP 3x Noctua NF-P14S 
OSMonitorKeyboardCase
Debian 8 Samsung UN55H6350AFXZA Dell Generic Nanoxia Deep Silence 5 
MouseOther
Logitech G402 HP NC364T 
CPUGraphicsRAMHard Drive
Intel Core I3 M370 Intel HD Toshiba Samsung 850 EVO 
OSOS
Windows 7 Ultimate Fedora 21 
  hide details  
Reply
post #6 of 21
Does this problem occur on all browsers?

Do you have an adblocker, if not try one(I recommend uBlock Origin), I've seen browsers hang on ads before for reasons I've yet to find out.

Does your antivirus have any browser related extensions? If so, switch them off.

If all else fails, try a clean Windows install.
post #7 of 21
Quote:
Originally Posted by Gilles3000 View Post

Does this problem occur on all browsers?

Do you have an adblocker, if not try one(I recommend uBlock Origin), I've seen browsers hang on ads before for reasons I've yet to find out.

Does your antivirus have any browser related extensions? If so, switch them off.

If all else fails, try a clean Windows install.

I was just thinking... do you think maybe he should reinstall firefox? Maybe something is corrupted?
Deepthought
(15 items)
 
Baldr
(14 items)
 
Terminal Dogma
(6 items)
 
CPUMotherboardGraphicsRAM
AMD A10-7850K MSI A88XM-GAMING Integrated Crucial Ballistix Sport  
Hard DriveCoolingCoolingCooling
Samsung 850 EVO  Prolimatech Genesis Black 2x Phanteks PH-F140HP 3x Noctua NF-P14S 
OSMonitorKeyboardCase
Debian 8 Samsung UN55H6350AFXZA Dell Generic Nanoxia Deep Silence 5 
MouseOther
Logitech G402 HP NC364T 
CPUGraphicsRAMHard Drive
Intel Core I3 M370 Intel HD Toshiba Samsung 850 EVO 
OSOS
Windows 7 Ultimate Fedora 21 
  hide details  
Reply
Deepthought
(15 items)
 
Baldr
(14 items)
 
Terminal Dogma
(6 items)
 
CPUMotherboardGraphicsRAM
AMD A10-7850K MSI A88XM-GAMING Integrated Crucial Ballistix Sport  
Hard DriveCoolingCoolingCooling
Samsung 850 EVO  Prolimatech Genesis Black 2x Phanteks PH-F140HP 3x Noctua NF-P14S 
OSMonitorKeyboardCase
Debian 8 Samsung UN55H6350AFXZA Dell Generic Nanoxia Deep Silence 5 
MouseOther
Logitech G402 HP NC364T 
CPUGraphicsRAMHard Drive
Intel Core I3 M370 Intel HD Toshiba Samsung 850 EVO 
OSOS
Windows 7 Ultimate Fedora 21 
  hide details  
Reply
post #8 of 21
Thread Starter 
Quote:
Originally Posted by maddangerous View Post

Is your browser up to date? I didn't see an answer to that. What kinds of extensions do you use? How about browser settings?

If you have firefox on your other computer, did you try setting this machine up in the exact same manner?

Have you tried both wired and wireless networking? Edit: saw the answer in your other thread

This is all a fresh install within the last week or so, besides ublock there isn't much anything I ever did with Firefox besides maybe a cosmetic skin which I haven't done yet

Quote:
Originally Posted by maddangerous View Post

I was just thinking... do you think maybe he should reinstall firefox? Maybe something is corrupted?

I could try that, I've been busy with preparation for going to Korea so I haven't been able to really sit down with it and try the obvious.


@gilles3000 sorry on mobile and it's difficult to multi quote for some reason.

The only extension I use lately is ublock and no anti-virus at this time. Also this is a fresh install of windows 7.

I'm going to try pulling the ssd from my sig rig and install Windows on it on the laptop. I'm pretty darn sure this is hardware related and not software. Maybe the ssd is just on its last leg? I figure the ssd or the gpu must be due for retirement.
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 4930mx 3.5Ghz .97v AW17 Ranger 780m 1006c/2800m 16GB DDR3 1600Mhz 
Hard DriveHard DriveHard DriveHard Drive
256GB SSD 2TB FireCuda 7mm 2TB Firecuda 7mm 1TB Seagate SSHD 
OSMonitorPowerMouse
Windows 10 x64 Pro 17" 1080p120hz TrueColor  330w Delta  G502 Proteus Spectrum 
Audio
SHP9500 w/ HM5 pads & MM4 
  hide details  
Reply
post #9 of 21
Quote:
Originally Posted by TheReciever View Post

This is all a fresh install within the last week or so, besides ublock there isn't much anything I ever did with Firefox besides maybe a cosmetic skin which I haven't done yet

@gilles3000 sorry on mobile and it's difficult to multi quote for some reason.

The only extension I use lately is ublock and no anti-virus at this time. Also this is a fresh install of windows 7.

I'm going to try pulling the ssd from my sig rig and install Windows on it on the laptop. I'm pretty darn sure this is hardware related and not software. Maybe the ssd is just on its last leg? I figure the ssd or the gpu must be due for retirement.

The SSD is possible, the older 128GB models were never very good to begin with, and yours being msata surely doesn't help I think.

My 128GB ADATA SP900 was quickly retired and replace by a 256GB Crucial M550, massive improvement.
post #10 of 21
You'd think if it was the SSD though it would affect the whole OS experience, and not just loading webpages. This is a long shot, but have you tried turning off (or on, whatever you don't have it set to now) hardware acceleration in Firefox? I've seen this cause some strange issues.
Angel Wings
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6700k ASUS Z170-PRO Zotac Geforce GTX 970 G. Skill Trident Z 
Hard DriveHard DriveOptical DriveCooling
MyDigitalSSD BPX Crucial MX300 LG Black Blu-Ray Burner Custom Liquid Cooling 
OSMonitorKeyboardPower
Windows 10 46" 1080p Samsung TV Logitech K800 Seasonic SS-750KM3 
CaseMouseAudio
Phanteks “Enthoo Pro Series" Logitech M215 5.1 Polk Audio Setup 
  hide details  
Reply
Angel Wings
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6700k ASUS Z170-PRO Zotac Geforce GTX 970 G. Skill Trident Z 
Hard DriveHard DriveOptical DriveCooling
MyDigitalSSD BPX Crucial MX300 LG Black Blu-Ray Burner Custom Liquid Cooling 
OSMonitorKeyboardPower
Windows 10 46" 1080p Samsung TV Logitech K800 Seasonic SS-750KM3 
CaseMouseAudio
Phanteks “Enthoo Pro Series" Logitech M215 5.1 Polk Audio Setup 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › What elements provide a snappy browser experience?