Overclock.net › Forums › Graphics Cards › AMD/ATI › AMD GPU 270x black screen during any driver install, black screen after windows gets to desktop.
New Posts  All Forums:Forum Nav:

AMD GPU 270x black screen during any driver install, black screen after windows gets to desktop.

post #1 of 7
Thread Starter 

One of my older computers wont seem to work now lol.  It has a 270x in it and soon as it gets to desktop it gives a black screen.

 

Any time i try to install any driver it black screens.

 

 

The one time i got it to get to desktop it reported there was NO amd drivers installed when there was, and GPUz or any programmes don't pick up there's even a GPU.

 

 

After i told me there was no Drivers, i just used AMD utility to uninstall all drivers, then every driver i try to install makes the windows disconnect sound while installing and black screens.

 

Is this card bricked or what?


Edited by Dragonsyph - 9/29/16 at 3:19am
Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k/5.0Ghz/1.37vBios Gigabyte z97x gaming 5 EVGA 1080 FTW HYBRID(2164core-12,012mem) Mushkin 8x2 16gb 2133mhzOC 
Hard DriveOptical DriveCoolingOS
840 evo 250g and 1tb None Cpu:H100i--Gpu:Hybrid Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Acer Predator x34 Logitech wirless Dell 875.  On a table 
MouseMouse PadAudioOther
Razor Naga Chroma Powercolor Full table pad Onboard Liquid PRO 
  hide details  
Reply
Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k/5.0Ghz/1.37vBios Gigabyte z97x gaming 5 EVGA 1080 FTW HYBRID(2164core-12,012mem) Mushkin 8x2 16gb 2133mhzOC 
Hard DriveOptical DriveCoolingOS
840 evo 250g and 1tb None Cpu:H100i--Gpu:Hybrid Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Acer Predator x34 Logitech wirless Dell 875.  On a table 
MouseMouse PadAudioOther
Razor Naga Chroma Powercolor Full table pad Onboard Liquid PRO 
  hide details  
Reply
post #2 of 7
Uh no, its probably that Windows is trying to install its own certified drivers that ends up conflicting with the one you are trying to install. Try going to My Computer > Properties > Advanced System Settings > Hardware > Device Installation Settings > No > Never install.

Reboot, go to device manager, Uninstall the Graphic Adapter, download the latest drivers from AMD, try to install it.
Desktop PC
(22 items)
 
ASUS ROG G72GX
(6 items)
 
 
CPUMotherboardGraphicsGraphics
AMD FX-8320 ASRock Fatal1ty 990FX Killer Sapphire Nitro+ RX480 Sapphire R9 290 Tri-X 
GraphicsRAMHard DriveHard Drive
XFX RX470 Singlefan Mushkin Redline 996996 2x4GB 2133Mhz Maxtor 6Y080L0 80GB 7200 RPM 8MB Western Digital 160GB 7200RPM 8MB 
Hard DriveHard DriveHard DriveOptical Drive
Maxtor 250GB 7200RPM 8MB Corsair Force LS WesternDigital Blue 500GB 7200RPM 16MB ASUS DVD-RW 
CoolingOSOSOS
ThermalTake Frio Silent 14 Windows 10 Enterprise Linux Mint 17.3 Rosa OphCrack 
MonitorKeyboardPowerCase
ASUS VS228HR Logitech K120 Corsair VS650 ThermalTake View 27 
MouseAudio
Bloody V5 Corsair HS30 Raptor 
CPUMotherboardGraphicsRAM
Intel Mobile Core 2 Duo P8700 G72GX NVIDIA GeForce GTX 260M  Hyundai Electronics  
RAMRAM
Hyundai Electronics  Hyundai Electronics  
  hide details  
Reply
Desktop PC
(22 items)
 
ASUS ROG G72GX
(6 items)
 
 
CPUMotherboardGraphicsGraphics
AMD FX-8320 ASRock Fatal1ty 990FX Killer Sapphire Nitro+ RX480 Sapphire R9 290 Tri-X 
GraphicsRAMHard DriveHard Drive
XFX RX470 Singlefan Mushkin Redline 996996 2x4GB 2133Mhz Maxtor 6Y080L0 80GB 7200 RPM 8MB Western Digital 160GB 7200RPM 8MB 
Hard DriveHard DriveHard DriveOptical Drive
Maxtor 250GB 7200RPM 8MB Corsair Force LS WesternDigital Blue 500GB 7200RPM 16MB ASUS DVD-RW 
CoolingOSOSOS
ThermalTake Frio Silent 14 Windows 10 Enterprise Linux Mint 17.3 Rosa OphCrack 
MonitorKeyboardPowerCase
ASUS VS228HR Logitech K120 Corsair VS650 ThermalTake View 27 
MouseAudio
Bloody V5 Corsair HS30 Raptor 
CPUMotherboardGraphicsRAM
Intel Mobile Core 2 Duo P8700 G72GX NVIDIA GeForce GTX 260M  Hyundai Electronics  
RAMRAM
Hyundai Electronics  Hyundai Electronics  
  hide details  
Reply
post #3 of 7
Thread Starter 
Quote:
Originally Posted by ku4eto View Post

Uh no, its probably that Windows is trying to install its own certified drivers that ends up conflicting with the one you are trying to install. Try going to My Computer > Properties > Advanced System Settings > Hardware > Device Installation Settings > No > Never install.

Reboot, go to device manager, Uninstall the Graphic Adapter, download the latest drivers from AMD, try to install it.

The thing is it was working just fine then black screened.   I put in another GPU and installed the newest drivers just fine.  Then tried putting that card back in and right after windows logo when starting PC  black screen.

Only time this card will get to desktop is when there are no drivers installed, and if you tried to install drivers with that card in it would just black screen.

 

Any other GPu works fine in that computer with the newest AMD driver installed.  Tried 5970, a 7850, 7870, they all worked fine.  Its just that 270x that black screens.

Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k/5.0Ghz/1.37vBios Gigabyte z97x gaming 5 EVGA 1080 FTW HYBRID(2164core-12,012mem) Mushkin 8x2 16gb 2133mhzOC 
Hard DriveOptical DriveCoolingOS
840 evo 250g and 1tb None Cpu:H100i--Gpu:Hybrid Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Acer Predator x34 Logitech wirless Dell 875.  On a table 
MouseMouse PadAudioOther
Razor Naga Chroma Powercolor Full table pad Onboard Liquid PRO 
  hide details  
Reply
Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k/5.0Ghz/1.37vBios Gigabyte z97x gaming 5 EVGA 1080 FTW HYBRID(2164core-12,012mem) Mushkin 8x2 16gb 2133mhzOC 
Hard DriveOptical DriveCoolingOS
840 evo 250g and 1tb None Cpu:H100i--Gpu:Hybrid Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Acer Predator x34 Logitech wirless Dell 875.  On a table 
MouseMouse PadAudioOther
Razor Naga Chroma Powercolor Full table pad Onboard Liquid PRO 
  hide details  
Reply
post #4 of 7
Can you get a Linux Mint live USB to check if it will run fine on it?

Also, have you tried selective boot - stopping all, but the basic windows services (safe mode actually).

Any other system where you can test the GPU?

Black screen means 90% of the time driver/OS issues, not hardware ones. If you can go into BIOS and you see the Windows logo during OS boot, its probably the drivers that are gone bad.
Edited by ku4eto - 9/29/16 at 6:39am
Desktop PC
(22 items)
 
ASUS ROG G72GX
(6 items)
 
 
CPUMotherboardGraphicsGraphics
AMD FX-8320 ASRock Fatal1ty 990FX Killer Sapphire Nitro+ RX480 Sapphire R9 290 Tri-X 
GraphicsRAMHard DriveHard Drive
XFX RX470 Singlefan Mushkin Redline 996996 2x4GB 2133Mhz Maxtor 6Y080L0 80GB 7200 RPM 8MB Western Digital 160GB 7200RPM 8MB 
Hard DriveHard DriveHard DriveOptical Drive
Maxtor 250GB 7200RPM 8MB Corsair Force LS WesternDigital Blue 500GB 7200RPM 16MB ASUS DVD-RW 
CoolingOSOSOS
ThermalTake Frio Silent 14 Windows 10 Enterprise Linux Mint 17.3 Rosa OphCrack 
MonitorKeyboardPowerCase
ASUS VS228HR Logitech K120 Corsair VS650 ThermalTake View 27 
MouseAudio
Bloody V5 Corsair HS30 Raptor 
CPUMotherboardGraphicsRAM
Intel Mobile Core 2 Duo P8700 G72GX NVIDIA GeForce GTX 260M  Hyundai Electronics  
RAMRAM
Hyundai Electronics  Hyundai Electronics  
  hide details  
Reply
Desktop PC
(22 items)
 
ASUS ROG G72GX
(6 items)
 
 
CPUMotherboardGraphicsGraphics
AMD FX-8320 ASRock Fatal1ty 990FX Killer Sapphire Nitro+ RX480 Sapphire R9 290 Tri-X 
GraphicsRAMHard DriveHard Drive
XFX RX470 Singlefan Mushkin Redline 996996 2x4GB 2133Mhz Maxtor 6Y080L0 80GB 7200 RPM 8MB Western Digital 160GB 7200RPM 8MB 
Hard DriveHard DriveHard DriveOptical Drive
Maxtor 250GB 7200RPM 8MB Corsair Force LS WesternDigital Blue 500GB 7200RPM 16MB ASUS DVD-RW 
CoolingOSOSOS
ThermalTake Frio Silent 14 Windows 10 Enterprise Linux Mint 17.3 Rosa OphCrack 
MonitorKeyboardPowerCase
ASUS VS228HR Logitech K120 Corsair VS650 ThermalTake View 27 
MouseAudio
Bloody V5 Corsair HS30 Raptor 
CPUMotherboardGraphicsRAM
Intel Mobile Core 2 Duo P8700 G72GX NVIDIA GeForce GTX 260M  Hyundai Electronics  
RAMRAM
Hyundai Electronics  Hyundai Electronics  
  hide details  
Reply
post #5 of 7
I have an XFX 290x that one day started doing what you describe. In my case the card had been working fine for a couple years and then it black screened. After a lot of trial and error I figured out I could boot to desktop just fine if no drivers were installed. Installing drivers would complete just fine... until you reboot. That process with the motherboard splash screen all works just fine until windows comes up and its just a black screen.

I pulled the card out of storage a couple days ago and actually got drivers to install and was playing a game... then *tada* it black screened.

Never found a solution to the problem.. not sure if my card went bad or what. All I know is that it seems to work just fine until drivers are installed.
post #6 of 7
Thread Starter 
Quote:
Originally Posted by Digitalwolf View Post

I have an XFX 290x that one day started doing what you describe. In my case the card had been working fine for a couple years and then it black screened. After a lot of trial and error I figured out I could boot to desktop just fine if no drivers were installed. Installing drivers would complete just fine... until you reboot. That process with the motherboard splash screen all works just fine until windows comes up and its just a black screen.

I pulled the card out of storage a couple days ago and actually got drivers to install and was playing a game... then *tada* it black screened.

Never found a solution to the problem.. not sure if my card went bad or what. All I know is that it seems to work just fine until drivers are installed.

I'll probably just toss mine in the trash or take a hammer to it for fun.   Like you this card worked fine then just black screen black screen black screen black screen.  So it has to do with the card it self my guess.  I would only think it could be the drivers if you installed drivers then it did this.  But it worked fine with the drivers it had then didn't work with no changes to the PC it was in. And all other cards work in that PC so its not the motherboard.  I even tried like 7 dif drivers and the card still black screens right after windows logo screen when turning on the PC.   And most of the time windows makes the disconnect sound so I'm guessing the GPU is not even registering or something after that. 

 

I'm not to worried about it as we only use that pc to surf the net or steam movies.  Ill just toss in a 7850 or something. 

Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k/5.0Ghz/1.37vBios Gigabyte z97x gaming 5 EVGA 1080 FTW HYBRID(2164core-12,012mem) Mushkin 8x2 16gb 2133mhzOC 
Hard DriveOptical DriveCoolingOS
840 evo 250g and 1tb None Cpu:H100i--Gpu:Hybrid Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Acer Predator x34 Logitech wirless Dell 875.  On a table 
MouseMouse PadAudioOther
Razor Naga Chroma Powercolor Full table pad Onboard Liquid PRO 
  hide details  
Reply
Beast
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k/5.0Ghz/1.37vBios Gigabyte z97x gaming 5 EVGA 1080 FTW HYBRID(2164core-12,012mem) Mushkin 8x2 16gb 2133mhzOC 
Hard DriveOptical DriveCoolingOS
840 evo 250g and 1tb None Cpu:H100i--Gpu:Hybrid Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Acer Predator x34 Logitech wirless Dell 875.  On a table 
MouseMouse PadAudioOther
Razor Naga Chroma Powercolor Full table pad Onboard Liquid PRO 
  hide details  
Reply
post #7 of 7
Another thing, have you guys tried increasing the GPU voltage? It may work, as it could as well degradation.
Desktop PC
(22 items)
 
ASUS ROG G72GX
(6 items)
 
 
CPUMotherboardGraphicsGraphics
AMD FX-8320 ASRock Fatal1ty 990FX Killer Sapphire Nitro+ RX480 Sapphire R9 290 Tri-X 
GraphicsRAMHard DriveHard Drive
XFX RX470 Singlefan Mushkin Redline 996996 2x4GB 2133Mhz Maxtor 6Y080L0 80GB 7200 RPM 8MB Western Digital 160GB 7200RPM 8MB 
Hard DriveHard DriveHard DriveOptical Drive
Maxtor 250GB 7200RPM 8MB Corsair Force LS WesternDigital Blue 500GB 7200RPM 16MB ASUS DVD-RW 
CoolingOSOSOS
ThermalTake Frio Silent 14 Windows 10 Enterprise Linux Mint 17.3 Rosa OphCrack 
MonitorKeyboardPowerCase
ASUS VS228HR Logitech K120 Corsair VS650 ThermalTake View 27 
MouseAudio
Bloody V5 Corsair HS30 Raptor 
CPUMotherboardGraphicsRAM
Intel Mobile Core 2 Duo P8700 G72GX NVIDIA GeForce GTX 260M  Hyundai Electronics  
RAMRAM
Hyundai Electronics  Hyundai Electronics  
  hide details  
Reply
Desktop PC
(22 items)
 
ASUS ROG G72GX
(6 items)
 
 
CPUMotherboardGraphicsGraphics
AMD FX-8320 ASRock Fatal1ty 990FX Killer Sapphire Nitro+ RX480 Sapphire R9 290 Tri-X 
GraphicsRAMHard DriveHard Drive
XFX RX470 Singlefan Mushkin Redline 996996 2x4GB 2133Mhz Maxtor 6Y080L0 80GB 7200 RPM 8MB Western Digital 160GB 7200RPM 8MB 
Hard DriveHard DriveHard DriveOptical Drive
Maxtor 250GB 7200RPM 8MB Corsair Force LS WesternDigital Blue 500GB 7200RPM 16MB ASUS DVD-RW 
CoolingOSOSOS
ThermalTake Frio Silent 14 Windows 10 Enterprise Linux Mint 17.3 Rosa OphCrack 
MonitorKeyboardPowerCase
ASUS VS228HR Logitech K120 Corsair VS650 ThermalTake View 27 
MouseAudio
Bloody V5 Corsair HS30 Raptor 
CPUMotherboardGraphicsRAM
Intel Mobile Core 2 Duo P8700 G72GX NVIDIA GeForce GTX 260M  Hyundai Electronics  
RAMRAM
Hyundai Electronics  Hyundai Electronics  
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › AMD GPU 270x black screen during any driver install, black screen after windows gets to desktop.