Overclock.net › Forums › Graphics Cards › Graphics Cards - General › All games seem to be foggy/blurry?
New Posts  All Forums:Forum Nav:

All games seem to be foggy/blurry?

post #1 of 11
Thread Starter 
I've noticed this for a while now. My PC is less than 4 months old. I mainaly noticed it when I started playing Rocket League a few months ago. Then I noticed it again when playing BF1 Beta, but wasn't sure because there was a lot of sand and dust anyway.
Now I'm playing H1Z1, it seems to be foggy/blurry.

What can cause such a problem? I've tired everything. It's annoying, because something doesn't seem right.
post #2 of 11
whats your specs on your PC? Laptop or desktop?

Does it look blurry only in game or the whole time your on your PC?
post #3 of 11
Thread Starter 
Quote:
Originally Posted by Cloudforever View Post

whats your specs on your PC? Laptop or desktop?

Does it look blurry only in game or the whole time your on your PC?

Only games.

post #4 of 11

Have you updated your graphics driver recently?

 

Check the driver settings for anti-aliasing, tone curve, etc,... 

 

Also are you using a DVI, HDMI, or D-Sub cable??? Analog radio interference on a D-Sub cable can create all kinds of unwanted video problems.

 

If you cant fix the problem thru the driver or monitor settings, the next step in my opinion would be to check your cabling before exploring anything else.

 

And finally, could you have accidentally changed the refresh rate on your monitor? 


Edited by KonaJoe - 9/30/16 at 2:26pm
White Trash
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX-8350 Crosshair V Formula Z EVGA GTX 760 SC 2gb EVGA GTX 760 SC 2gb 
RAMHard DriveHard DriveOptical Drive
G.Skill Ripjaws Crucial M4 128gb Sata3/6gbps SSD WD Caviar 500gb 7200rpm Sata2 HDD Asus DVRW  
CoolingCoolingCoolingOS
Corsair H60 Liquid Cooling System 3 - 120mm Case fans 3 - 140mm Case Fans Win 7/64 Home Edition 
MonitorPowerCaseAudio
Asus VG248QE 24" 144htz Gaming monitor Raidmax RX-1000AE 80+ Gold Certified Modular PSU NZXT Source 210 ATX Midtower white/black trim Sony 7.1 Home Theather system 
Other
NZXT Sentry-2 Touchscreen Fan Controller 
  hide details  
Reply
White Trash
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX-8350 Crosshair V Formula Z EVGA GTX 760 SC 2gb EVGA GTX 760 SC 2gb 
RAMHard DriveHard DriveOptical Drive
G.Skill Ripjaws Crucial M4 128gb Sata3/6gbps SSD WD Caviar 500gb 7200rpm Sata2 HDD Asus DVRW  
CoolingCoolingCoolingOS
Corsair H60 Liquid Cooling System 3 - 120mm Case fans 3 - 140mm Case Fans Win 7/64 Home Edition 
MonitorPowerCaseAudio
Asus VG248QE 24" 144htz Gaming monitor Raidmax RX-1000AE 80+ Gold Certified Modular PSU NZXT Source 210 ATX Midtower white/black trim Sony 7.1 Home Theather system 
Other
NZXT Sentry-2 Touchscreen Fan Controller 
  hide details  
Reply
post #5 of 11
word ^

Does it look blurry only in game or the whole time your on your PC?
post #6 of 11
Thread Starter 
Quote:
Originally Posted by KonaJoe View Post

Have you updated your graphics driver recently?

Check the driver settings for anti-aliasing, tone curve, etc,... 

Also are you using a DVI, HDMI, or D-Sub cable??? Analog radio interference on a D-Sub cable can create all kinds of unwanted video problems.

If you cant fix the problem thru the driver or monitor settings, the next step in my opinion would be to check your cabling before exploring anything else.

And finally, could you have accidentally changed the refresh rate on your monitor? 

DVI to my 144hz monitor. All cables are fine,
post #7 of 11
Thread Starter 
Quote:
Originally Posted by Cloudforever View Post

word ^

Does it look blurry only in game or the whole time your on your PC?

Already said, only for games./
post #8 of 11
Probably just a case of too aggressive post-processing anti-aliasing. Check both in-game and your video drivers.
Arcane
(33 items)
 
Sanctum
(9 items)
 
Fukurou
(15 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 MSI B350M Mortar Arctic RX Vega 64 G.Skill TridentZ  
Hard DriveHard DriveOSPower
Samsung EVO 960 Consatellation Windows 10 Pro Corsair HX 1050 
Case
Raijintek Aeneas White Window 
CPUMotherboardRAMHard Drive
Core i5-661 GA-H55-USB3 12GB DDR3 1333 WD Caviar Black AALS 640GB 
Hard DriveHard DriveOptical DriveCooling
WD Caviar Green EARS 2TB Vertex Turbo 60GB (SSD) Samsung Blu-ray, Samsung DVD Burner H50 (With push/pull nocturas) 
OSMonitorKeyboardPower
Windows 10 Professional 64 LG 47inch LED LCD Saitek Eclipse Lite-touch Wireless Seasonic X750 Gold 
CaseAudio
CM690 II Passive bookshelfspeakers + amp. 
  hide details  
Reply
Arcane
(33 items)
 
Sanctum
(9 items)
 
Fukurou
(15 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 MSI B350M Mortar Arctic RX Vega 64 G.Skill TridentZ  
Hard DriveHard DriveOSPower
Samsung EVO 960 Consatellation Windows 10 Pro Corsair HX 1050 
Case
Raijintek Aeneas White Window 
CPUMotherboardRAMHard Drive
Core i5-661 GA-H55-USB3 12GB DDR3 1333 WD Caviar Black AALS 640GB 
Hard DriveHard DriveOptical DriveCooling
WD Caviar Green EARS 2TB Vertex Turbo 60GB (SSD) Samsung Blu-ray, Samsung DVD Burner H50 (With push/pull nocturas) 
OSMonitorKeyboardPower
Windows 10 Professional 64 LG 47inch LED LCD Saitek Eclipse Lite-touch Wireless Seasonic X750 Gold 
CaseAudio
CM690 II Passive bookshelfspeakers + amp. 
  hide details  
Reply
post #9 of 11
Thread Starter 
Quote:
Originally Posted by Zero4549 View Post

Probably just a case of too aggressive post-processing anti-aliasing. Check both in-game and your video drivers.



Everything ok?
post #10 of 11
What your describing does happen n Win10 with applications, the resolution is:

https://support.microsoft.com/en-us/kb/2900023
Quote:
Resolution
In some cases, the application vendor may be able to provide an updated software version that better supports high-DPI displays.

If there is no updated DPI-aware version of the application available, you may be able to alter the appearance of the application by using one of the following methods. Be aware that this may result in less desirable results, depending on the application.

Disable DPI virtualization for the application. To do this, right-click the application’s shortcut and then click Properties. On the Compatibility tab, select Disable Display Scaling On High DPI Settings, and then click OK. This causes the text in the application to appear clearer. However, if the application does not correctly handle high DPI settings, this procedure may have adverse side effects such as truncated text and incorrectly sized graphical elements.

I have had to do that with certain applications that were not rendering clearly.

Not a perfect solution but still a step in the analysis.

As others have stated install the latest nVidia drivers - but before you do run DDU firstly to properly clean out the old drivers.

Seriously consider doing an advanced install of the drivers and only install the drivers and deselect the bloatware.

That is:
http://cdn.ghacks.net/wp-content/uploads/2012/12/nvidia-custom-component-installation.jpg
Edited by Bold Eagle - 9/30/16 at 3:21pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards - General
Overclock.net › Forums › Graphics Cards › Graphics Cards - General › All games seem to be foggy/blurry?