Overclock.net › Forums › Components › Mice › Zowie FK1 unresponsive?
New Posts  All Forums:Forum Nav:

Zowie FK1 unresponsive?

post #1 of 23
Thread Starter 
I have a Zowie FK1 and for some reason it just feels unresponsive compared to my other mice. It's not unplayable, i can still use it OK but it just doesn't feel right. I have 2 other mice with the 3310 sensor and both of them feel much less laggy. This is the BenQ FK1.. Did i just get a defective copy or what?
Edit: i already tried putting on new skates, still doesn't feel right.
Edited by s0rry - 9/30/16 at 6:28pm
post #2 of 23
I have a ZA11 and Fk1+, both feel OK, but both also felt very bad using Goliathus Speed, if you got colored mousepad, then thats it, try a black one.
post #3 of 23
Thread Starter 
i have a black mouse pad. it still tracks completely fine it just feels like it responds to motions later than my other mice.. idk why
post #4 of 23
Quote:
Originally Posted by s0rry View Post

I have a Zowie FK1 and for some reason it just feels unresponsive compared to my other mice. It's not unplayable, i can still use it OK but it just doesn't feel right. I have 2 other mice with the 3310 sensor and both of them feel much less laggy. This is the BenQ FK1.. Did i just get a defective copy or what?
Edit: i already tried putting on new skates, still doesn't feel right.

Zowie mice use the 3310 and a 10 year old MCU, the cursor feeling is known for being pretty rough around here. I didn't enjoy any of my 3310 Zowie mice.
    
CPUMotherboardGraphicsRAM
Intel Core i7 4790K SABERTOOTH Z97 MARK 1 NVIDIA GeForce GTX 760 Corsair  
RAMHard DriveOptical DriveCooling
Corsair  Seagate ST31500341AS MSI DH24ABS Stock 
OSMonitorMonitorKeyboard
Windows 10 64 bit Samsung 2233RZ BenQ XL2411Z Filco Majestouch-2 (Cherry MX Black) 
MouseMouse PadAudio
Logitech G403 Razer Gigantus ROG Thunderbolt 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 4790K SABERTOOTH Z97 MARK 1 NVIDIA GeForce GTX 760 Corsair  
RAMHard DriveOptical DriveCooling
Corsair  Seagate ST31500341AS MSI DH24ABS Stock 
OSMonitorMonitorKeyboard
Windows 10 64 bit Samsung 2233RZ BenQ XL2411Z Filco Majestouch-2 (Cherry MX Black) 
MouseMouse PadAudio
Logitech G403 Razer Gigantus ROG Thunderbolt 
  hide details  
Reply
post #5 of 23
Thread Starter 
but i have a Logitech MX518 and a WMO which are both over 10 years old and they feel better.. i don't get it lol
post #6 of 23
Quote:
Originally Posted by s0rry View Post

but i have a Logitech MX518 and a WMO which are both over 10 years old and they feel better.. i don't get it lol

The A3080E and MLT04 had very little to no smoothing, the 3310 has noticeable amounts of smoothing on top of an old MCU.
    
CPUMotherboardGraphicsRAM
Intel Core i7 4790K SABERTOOTH Z97 MARK 1 NVIDIA GeForce GTX 760 Corsair  
RAMHard DriveOptical DriveCooling
Corsair  Seagate ST31500341AS MSI DH24ABS Stock 
OSMonitorMonitorKeyboard
Windows 10 64 bit Samsung 2233RZ BenQ XL2411Z Filco Majestouch-2 (Cherry MX Black) 
MouseMouse PadAudio
Logitech G403 Razer Gigantus ROG Thunderbolt 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 4790K SABERTOOTH Z97 MARK 1 NVIDIA GeForce GTX 760 Corsair  
RAMHard DriveOptical DriveCooling
Corsair  Seagate ST31500341AS MSI DH24ABS Stock 
OSMonitorMonitorKeyboard
Windows 10 64 bit Samsung 2233RZ BenQ XL2411Z Filco Majestouch-2 (Cherry MX Black) 
MouseMouse PadAudio
Logitech G403 Razer Gigantus ROG Thunderbolt 
  hide details  
Reply
post #7 of 23
Zowie MCUs, a bit aged. 10 years old, 5th grade.
post #8 of 23
It's not delayed, it just has a smoothed kind of feeling - it won't affect your aim.. pretty sure deathadders have the same thing
post #9 of 23
Thread Starter 
The deathadder's sensor is more responsive though. this one feels like it's lagging. does every zowie just feel like this?
post #10 of 23
Quote:
Originally Posted by s0rry View Post

The deathadder's sensor is more responsive though. this one feels like it's lagging. does every zowie just feel like this?

Ummm I plugged in my ZA and can't see this lag you're referring to.. what mousepad are you using? Are you on 500hz or 1000hz? I can see it feeling 'smoothed' but not lag... as in falling behind motion
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Zowie FK1 unresponsive?