Overclock.net › Forums › Intel › Intel CPUs › How to auto disable C1E w/ script
New Posts  All Forums:Forum Nav:

How to auto disable C1E w/ script - Page 2

post #11 of 16
Might find something interesting here

A reminder to backup your registry before trying anything. Scroll down a bit for the interesting bits. This is from a different problem, but seeking the same result of disabling C-state manually then creating a task in task scheduler to run on startup.

Edit:

Older, but possibly still relevant. Registry edit, 4th post
Edited by ForNever - 10/3/16 at 6:24pm
The Grey Box
(22 items)
 
  
CPUMotherboardGraphicsRAM
3770k delid 4.6 at 1.25 Gigabyte Z77X-UD5H Gigabyte 1080 Ti Aorus Xtreme Corsair Vengeance 
Hard DriveHard DriveHard DriveCooling
Intel 730 WD20002FAEX Raid1 Samsung 850 Pro Heatkiller 3.0 
CoolingCoolingCoolingCooling
DDC-1 & Swiftech Micro Res x3 HW Labs GTX 360 Radiator (Pelts Hot Side) Aquacomputer Aquaero 6 XT Coolit FreeZone (pelts & pelt water block only) 
CoolingCoolingOSMonitor
Custom Copper Heat Exchanger For Pelts HW Labs 120 Radiator (VGA) Win7 64/Linux SuSe Samsung 22" 1080 
KeyboardPowerCaseMouse
Saitek Eclipse II EVGA supernova 750 G2 Coolermaster Cosmos V1 Logitech mx518 
Mouse Pad
Allsop 
  hide details  
Reply
The Grey Box
(22 items)
 
  
CPUMotherboardGraphicsRAM
3770k delid 4.6 at 1.25 Gigabyte Z77X-UD5H Gigabyte 1080 Ti Aorus Xtreme Corsair Vengeance 
Hard DriveHard DriveHard DriveCooling
Intel 730 WD20002FAEX Raid1 Samsung 850 Pro Heatkiller 3.0 
CoolingCoolingCoolingCooling
DDC-1 & Swiftech Micro Res x3 HW Labs GTX 360 Radiator (Pelts Hot Side) Aquacomputer Aquaero 6 XT Coolit FreeZone (pelts & pelt water block only) 
CoolingCoolingOSMonitor
Custom Copper Heat Exchanger For Pelts HW Labs 120 Radiator (VGA) Win7 64/Linux SuSe Samsung 22" 1080 
KeyboardPowerCaseMouse
Saitek Eclipse II EVGA supernova 750 G2 Coolermaster Cosmos V1 Logitech mx518 
Mouse Pad
Allsop 
  hide details  
Reply
post #12 of 16
Quote:
Originally Posted by ForNever View Post

Might find something interesting here

A reminder to backup your registry before trying anything. Scroll down a bit for the interesting bits. This is from a different problem, but seeking the same result of disabling C-state manually then creating a task in task scheduler to run on startup.

Edit:

Older, but possibly still relevant. Registry edit, 4th post

Have I misunderstood the problem the OP is having? I thought he basically wanted to keep his processor from down clocking (ie. stay at max frequency all the time) and cannot disable C1E from Bios (no option).

Why are you suggesting registry tweaks, dual booting, swapping OS altogether, when there is a windows setting that solves the problem (min processor state: 100%).

OP if power plans aren't working, try creating a new plan, make sure Min processor and Max processor are both 100%, set it and reboot. I have C1E enabled, but when my high performance plan is set, frequency never changes.

I'm struggling to see how changing OS could be seen as a solution.
Quote:
Originally Posted by ForNever View Post

If it's for work, I would absolutely consider dual booting with Linux if it would save him a trip (possibly to another building he has to drive to).

Where is this talk of buildings and driving coming into it?
Ol'Faithful
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon x5660 P6X58D-E XFX AMD Radeon R9 280X Corsair Vengeance 24 GB Triple Chanel 6x4GB 
Optical DriveCoolingOSMonitor
Lite-On DVD-RW Noctua DH-14 CPU Cooler Windows 7 Pro x64 Samsung 24" LED 1080p 5ms DVI (S23A300B) 
PowerMouseAudio
Thermaltake Toughpower 750W Gold Corsair M95 Onboard :S 
  hide details  
Reply
Ol'Faithful
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon x5660 P6X58D-E XFX AMD Radeon R9 280X Corsair Vengeance 24 GB Triple Chanel 6x4GB 
Optical DriveCoolingOSMonitor
Lite-On DVD-RW Noctua DH-14 CPU Cooler Windows 7 Pro x64 Samsung 24" LED 1080p 5ms DVI (S23A300B) 
PowerMouseAudio
Thermaltake Toughpower 750W Gold Corsair M95 Onboard :S 
  hide details  
Reply
post #13 of 16
Hmmm, never mind. Guess they fixed that.
Edited by Forceman - 10/3/16 at 7:14pm
post #14 of 16
Thread Starter 
Quote:
Originally Posted by spinFX View Post

Have I misunderstood the problem the OP is having? I thought he basically wanted to keep his processor from down clocking (ie. stay at max frequency all the time) and cannot disable C1E from Bios (no option).

Why are you suggesting registry tweaks, dual booting, swapping OS altogether, when there is a windows setting that solves the problem (min processor state: 100%).

OP if power plans aren't working, try creating a new plan, make sure Min processor and Max processor are both 100%, set it and reboot. I have C1E enabled, but when my high performance plan is set, frequency never changes.

I'm struggling to see how changing OS could be seen as a solution.


Where is this talk of buildings and driving coming into it?

You understood my issue correctly. My issue is with my multiplier fluction causing downlocking. Even after reboots, it persists until I uncheck the C1E box in Realtemp.

I really wish I knew what CLI / Powershell command this was invoking - but I cant find anything anywhere...
6950X
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6950X @ 4.2 (100x42) ASUS Rampage V Extreme 3701 Geforce 1080Ti Founders Edition x2 SLI 64GB DDR4 3200MHz 14-14-14-34-1T 
Hard DriveCoolingOSMonitor
1.2TB Intel 750 PCIe Corsair H115i GTX Windows 10 Fall Creators Acer Predator 27" 1440p 144Hz x3 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX1500i Corsair Carbide Air 540 Cube Razer DeathAdder Chroma 2015 
Audio
Soundblaster X7 Limited Edition External DAC 
  hide details  
Reply
6950X
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6950X @ 4.2 (100x42) ASUS Rampage V Extreme 3701 Geforce 1080Ti Founders Edition x2 SLI 64GB DDR4 3200MHz 14-14-14-34-1T 
Hard DriveCoolingOSMonitor
1.2TB Intel 750 PCIe Corsair H115i GTX Windows 10 Fall Creators Acer Predator 27" 1440p 144Hz x3 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX1500i Corsair Carbide Air 540 Cube Razer DeathAdder Chroma 2015 
Audio
Soundblaster X7 Limited Edition External DAC 
  hide details  
Reply
post #15 of 16
Quote:
Originally Posted by DMac84 View Post

You understood my issue correctly. My issue is with my multiplier fluction causing downlocking. Even after reboots, it persists until I uncheck the C1E box in Realtemp.

I really wish I knew what CLI / Powershell command this was invoking - but I cant find anything anywhere...

yeah, like I said, I've had the exact same behavior: ie. set minimum processor percentage to 100% but it does nothing, multiplier still drops when not under load. Usually creating a new profile, or switching between profiles with reboots in between sorts out whatever bug causes it not to recognize the setting.

following this guide is a solution too,
http://www.dozty.com/how-to-unlock-the-hidden-features-of-processor-power-management/
but I really think the solution is as simple as getting the basic power profile settings to work correctly.
Ol'Faithful
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon x5660 P6X58D-E XFX AMD Radeon R9 280X Corsair Vengeance 24 GB Triple Chanel 6x4GB 
Optical DriveCoolingOSMonitor
Lite-On DVD-RW Noctua DH-14 CPU Cooler Windows 7 Pro x64 Samsung 24" LED 1080p 5ms DVI (S23A300B) 
PowerMouseAudio
Thermaltake Toughpower 750W Gold Corsair M95 Onboard :S 
  hide details  
Reply
Ol'Faithful
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon x5660 P6X58D-E XFX AMD Radeon R9 280X Corsair Vengeance 24 GB Triple Chanel 6x4GB 
Optical DriveCoolingOSMonitor
Lite-On DVD-RW Noctua DH-14 CPU Cooler Windows 7 Pro x64 Samsung 24" LED 1080p 5ms DVI (S23A300B) 
PowerMouseAudio
Thermaltake Toughpower 750W Gold Corsair M95 Onboard :S 
  hide details  
Reply
post #16 of 16
Quote:
Originally Posted by spinFX View Post

Why are you suggesting registry tweaks, dual booting, swapping OS altogether, when there is a windows setting that solves the problem (min processor state: 100%).

As stated in OP. eh-smiley.gif
Quote:
Originally Posted by DMac84 View Post

Hello all - Not sure where this goes but I need some help

I just got a Lenovo Thinkstation P410 (Broadwell - E Xeon) but there is no option to disable C1E in the BIOS and therefor I am getting some fluctuation in core speed while in Windows. I need max clock speed for low latency application this thing will be running. I am able to turn off C1E via RealTemp with a simple uncheck, and clock speed ramps up to max. But its a manual process, and upon reboot, C1E comes back.

What is this checkmark doing in Windows? Is there a reg key I can perm change? If not, anyway I can do this with powershell or script something out to do this upon reboot?
The Grey Box
(22 items)
 
  
CPUMotherboardGraphicsRAM
3770k delid 4.6 at 1.25 Gigabyte Z77X-UD5H Gigabyte 1080 Ti Aorus Xtreme Corsair Vengeance 
Hard DriveHard DriveHard DriveCooling
Intel 730 WD20002FAEX Raid1 Samsung 850 Pro Heatkiller 3.0 
CoolingCoolingCoolingCooling
DDC-1 & Swiftech Micro Res x3 HW Labs GTX 360 Radiator (Pelts Hot Side) Aquacomputer Aquaero 6 XT Coolit FreeZone (pelts & pelt water block only) 
CoolingCoolingOSMonitor
Custom Copper Heat Exchanger For Pelts HW Labs 120 Radiator (VGA) Win7 64/Linux SuSe Samsung 22" 1080 
KeyboardPowerCaseMouse
Saitek Eclipse II EVGA supernova 750 G2 Coolermaster Cosmos V1 Logitech mx518 
Mouse Pad
Allsop 
  hide details  
Reply
The Grey Box
(22 items)
 
  
CPUMotherboardGraphicsRAM
3770k delid 4.6 at 1.25 Gigabyte Z77X-UD5H Gigabyte 1080 Ti Aorus Xtreme Corsair Vengeance 
Hard DriveHard DriveHard DriveCooling
Intel 730 WD20002FAEX Raid1 Samsung 850 Pro Heatkiller 3.0 
CoolingCoolingCoolingCooling
DDC-1 & Swiftech Micro Res x3 HW Labs GTX 360 Radiator (Pelts Hot Side) Aquacomputer Aquaero 6 XT Coolit FreeZone (pelts & pelt water block only) 
CoolingCoolingOSMonitor
Custom Copper Heat Exchanger For Pelts HW Labs 120 Radiator (VGA) Win7 64/Linux SuSe Samsung 22" 1080 
KeyboardPowerCaseMouse
Saitek Eclipse II EVGA supernova 750 G2 Coolermaster Cosmos V1 Logitech mx518 
Mouse Pad
Allsop 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › How to auto disable C1E w/ script