Overclock.net › Forums › Intel › Intel Motherboards › Bios is not working and Im not sure how to go about fixing this...
New Posts  All Forums:Forum Nav:

Bios is not working and Im not sure how to go about fixing this...

post #1 of 4
Thread Starter 
Like an idiot, I did the fast ring for win 10 and that created a whole new set of problems, but My bios is not working properly
and that may be why other things are not running well.

I dont know why ROG has not upgraded the bios in a long time, but the original one that came with the game
is a lower number then the one that I see online that can be downloaded, Both are the same size.

3003 is not listed for the Watchdog one I purchased, instead 2902 is:

MAXIMUS VII FORMULA BIOS 2902
Improve system stability.
File Size 5.67 MBytesupdate 2015/10/16




Description MAXIMUS VII FORMULA BIOS 3003
Improve system stability.
File Size 5.68 MBytesupdate 2015/11/23

Why are they not supporting this with any newer upgrades? Two years have gone by ....



OK, so now I have tried both bios and problem is still happening. When I hit the Del button and go into bios,
neither my mouse nor my keyboard are allowing me to pick or choose anything. My settings are all messed
up and I cant change a thing and I really need some help with this. PLEASE email me at ctguy1955@yahoo.com
with any help with this as its driving me nuts. If I try to change any settings, such as turning off the numlock
or not allowing audio or anything, it just skips around and I cannot change anything.

All of the ROG site posts are old and no info and I was hoping someone here could help.

Thanks Brothers

Mike Kelly



https://www.asus.com/ROG-Republic-Of-Gamers/Motherboards-Products/?_ga=1.240020099.1682208817.1491910743
When You go to this link, the VII Formula is not even listed.......
post #2 of 4
Thread Starter 
I did have someone suggest I take out my battery, but I guess I would have to take the whole computer apart as the armor
is covering the area the battery is in. This is just really terrible to be going through all of this.
post #3 of 4


If you look at the bottom of this image you should see that there is a "Clear CMOS" button on the back panel. Try hitting that.

Here's the manual for your mobo if you want try to flash a new BIOS
post #4 of 4
Thread Starter 
When I hit the clear bios button, when the screen comes on it wants me to hit the F1 key to reset the bios, nothing happens that
changes anything. So I have water cooled gpu's and sound card, if I take them out, can I then just unscrew my armor
to get to the cmos battery and try to reset my bios to get it to actually respond to my keyboard or mouse ?

So many of my settings are wrong now, and I cant change them and my pc is working terrible.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Bios is not working and Im not sure how to go about fixing this...