Overclock.net › Forums › Components › Power Supplies › Did my psu die?? Need help urgent!!
New Posts  All Forums:Forum Nav:

Did my psu die?? Need help urgent!!

post #1 of 35
Thread Starter 
Okay everything was fine . Till today when i installed my gtx 1080ti. Everything was fine when i installed the gtx 1080ti also i even played games on it for about 2 hours. And i started to play again 5 hours later and while gaming my whole pc just shutdown. And it wont power back on at all. No led lights from mobo , no fans worling . The whole thing is dead. Can it be the psu? Since it was working perfectly fine till i started playing games again? I also checked if it was the gpu so i used my old gtx 1070 and its still not starting up again.
Im using a 650 watt seasonic which should have enough power
https://m.newegg.com/products/N82E16817151118?nm_mc=KNC-GoogleAdwords-Mobile&cm_mmc=KNC-GoogleAdwords-Mobile-_-pla-_-Power+Supplies-_-N82E16817151118&gclid=Cj0KEQjwofHHBRDS0Pnhpef89ucBEiQASEp6LD1HXWmu18RwEEtzx7Yr3RhIPth0LmKGVYVDpeUpFVkaAuZL8P8HAQ&gclsrc=aw.ds
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
post #2 of 35
Thread Starter 
Okay wrong psu its the 550 watt version ,not the 650 . Same g series model though
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
post #3 of 35
System specs? Dont seem up to date.
PC shutdown as in windows closed down or it literally cut out and stayed off?
Le Box of Black
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 Gigabyte X58A-UD7 r2.0 GTX 770 16GB Corsair Vengeance in Triple channel mode ;) 
Hard DriveHard DriveHard DriveHard Drive
Ocz Vertex 2  Samsung F1  Samsung F3 Samsung F1 
Optical DriveOSMonitorKeyboard
Sammie Dvd rw Windows 7 64Bit HZ281HPB 1200p / HP IPS 1080p / Samsung Syncmas... Qpad MK80 (Blue switch), SteelSeries 7G (Cherry... 
PowerCaseMouseMouse Pad
HX1000 CM-Stacker 832 Flipped Naos 3200,G5,G400,G400s, G300, Kone+ Razor Destructor and Steelseries Qck 
AudioAudioAudio
X-Fi Fatal1ty  ATH-T500 / AH-D510 Samson CO1U PAK Condenser Mic  
  hide details  
Reply
Le Box of Black
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 Gigabyte X58A-UD7 r2.0 GTX 770 16GB Corsair Vengeance in Triple channel mode ;) 
Hard DriveHard DriveHard DriveHard Drive
Ocz Vertex 2  Samsung F1  Samsung F3 Samsung F1 
Optical DriveOSMonitorKeyboard
Sammie Dvd rw Windows 7 64Bit HZ281HPB 1200p / HP IPS 1080p / Samsung Syncmas... Qpad MK80 (Blue switch), SteelSeries 7G (Cherry... 
PowerCaseMouseMouse Pad
HX1000 CM-Stacker 832 Flipped Naos 3200,G5,G400,G400s, G300, Kone+ Razor Destructor and Steelseries Qck 
AudioAudioAudio
X-Fi Fatal1ty  ATH-T500 / AH-D510 Samson CO1U PAK Condenser Mic  
  hide details  
Reply
post #4 of 35
Thread Starter 
I was in the middle of a game . And it just shut up right away . It didnt reboot or anything. It stayed off and when i pressed the power button no response at all. No lights no fans working . Nothing.
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
post #5 of 35
Overheating possibly. Something still too hot to just turn back on. CPU cooler mounted well?
I have Ryzen!
(13 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 5 1600 3.7GHz 1.3v MSI B350M Mortar Arctic Asus Strix RX470 4GB Corsair Vengance LPX 3200 16GB 
Hard DriveHard DriveCoolingOS
Intel 520 240GB Transcend 480GB Wraith Spire Windows 10 Pro x64 
MonitorKeyboardPowerCase
Dell UltraSharp U2412M CM Quick Fire (Brown Switches) Rosewill Valens 500W Gold Corsiar Carbide Air 240 
Mouse
Zowie 
  hide details  
Reply
I have Ryzen!
(13 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 5 1600 3.7GHz 1.3v MSI B350M Mortar Arctic Asus Strix RX470 4GB Corsair Vengance LPX 3200 16GB 
Hard DriveHard DriveCoolingOS
Intel 520 240GB Transcend 480GB Wraith Spire Windows 10 Pro x64 
MonitorKeyboardPowerCase
Dell UltraSharp U2412M CM Quick Fire (Brown Switches) Rosewill Valens 500W Gold Corsiar Carbide Air 240 
Mouse
Zowie 
  hide details  
Reply
post #6 of 35
Normally if a PSU dies it will stink and give of a burnt smell.
post #7 of 35
well again, what do you have?

a 1080ti on a intel 115x platform, a 550 watt PSU should be fine but a HEDT and some AMD chips will use ~100+watts more and trip (immediate shutdown) the PSU.

btw, unplug the power cord going to unit? (then yes, plug in back in and hit the power button again)
loon 3.2
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770K Asus P8Z77-V Pro EVGA 980TI SC+ 16Gb PNY ddr3 1866 
Hard DriveHard DriveHard DriveOptical Drive
PNY 1311 240Gb 1 TB Seagate 3 TB WD Blue DVD DVDRW+/- 
CoolingCoolingOSMonitor
EKWB P280 kit EK-VGA supremacy Win X LG 24MC57HQ-P 
KeyboardPowerCaseMouse
Ducky Zero [blues] EVGA SuperNova 750 G2 Stryker M [hammered and drilled] corsair M65 
AudioAudio
SB Recon3D Klipsch ProMedia 2.1  
  hide details  
Reply
loon 3.2
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770K Asus P8Z77-V Pro EVGA 980TI SC+ 16Gb PNY ddr3 1866 
Hard DriveHard DriveHard DriveOptical Drive
PNY 1311 240Gb 1 TB Seagate 3 TB WD Blue DVD DVDRW+/- 
CoolingCoolingOSMonitor
EKWB P280 kit EK-VGA supremacy Win X LG 24MC57HQ-P 
KeyboardPowerCaseMouse
Ducky Zero [blues] EVGA SuperNova 750 G2 Stryker M [hammered and drilled] corsair M65 
AudioAudio
SB Recon3D Klipsch ProMedia 2.1  
  hide details  
Reply
post #8 of 35
Quote:
Originally Posted by looniam View Post

well again, what do you have?

a 1080ti on a intel 115x platform, a 550 watt PSU should be fine but a HEDT and some AMD chips will use ~100+watts more and trip (immediate shutdown) the PSU.

btw, unplug the power cord going to unit? (then yes, plug in back in and hit the power button again)

Do this except when the power cord is unplugged, hold the power button for 30 seconds or so, then plug back in, wait 10 seconds and try again.
I have Ryzen!
(13 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 5 1600 3.7GHz 1.3v MSI B350M Mortar Arctic Asus Strix RX470 4GB Corsair Vengance LPX 3200 16GB 
Hard DriveHard DriveCoolingOS
Intel 520 240GB Transcend 480GB Wraith Spire Windows 10 Pro x64 
MonitorKeyboardPowerCase
Dell UltraSharp U2412M CM Quick Fire (Brown Switches) Rosewill Valens 500W Gold Corsiar Carbide Air 240 
Mouse
Zowie 
  hide details  
Reply
I have Ryzen!
(13 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 5 1600 3.7GHz 1.3v MSI B350M Mortar Arctic Asus Strix RX470 4GB Corsair Vengance LPX 3200 16GB 
Hard DriveHard DriveCoolingOS
Intel 520 240GB Transcend 480GB Wraith Spire Windows 10 Pro x64 
MonitorKeyboardPowerCase
Dell UltraSharp U2412M CM Quick Fire (Brown Switches) Rosewill Valens 500W Gold Corsiar Carbide Air 240 
Mouse
Zowie 
  hide details  
Reply
post #9 of 35
^YEP!

nice catch. also when installing the card;

lose a screw? (goes under mobo and causes a short)

connections firm?

maybe then try removing the card.

lot o' stuff to do. smile.gif

how you wanted to spend a sunday, eh? tongue.gif
loon 3.2
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770K Asus P8Z77-V Pro EVGA 980TI SC+ 16Gb PNY ddr3 1866 
Hard DriveHard DriveHard DriveOptical Drive
PNY 1311 240Gb 1 TB Seagate 3 TB WD Blue DVD DVDRW+/- 
CoolingCoolingOSMonitor
EKWB P280 kit EK-VGA supremacy Win X LG 24MC57HQ-P 
KeyboardPowerCaseMouse
Ducky Zero [blues] EVGA SuperNova 750 G2 Stryker M [hammered and drilled] corsair M65 
AudioAudio
SB Recon3D Klipsch ProMedia 2.1  
  hide details  
Reply
loon 3.2
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770K Asus P8Z77-V Pro EVGA 980TI SC+ 16Gb PNY ddr3 1866 
Hard DriveHard DriveHard DriveOptical Drive
PNY 1311 240Gb 1 TB Seagate 3 TB WD Blue DVD DVDRW+/- 
CoolingCoolingOSMonitor
EKWB P280 kit EK-VGA supremacy Win X LG 24MC57HQ-P 
KeyboardPowerCaseMouse
Ducky Zero [blues] EVGA SuperNova 750 G2 Stryker M [hammered and drilled] corsair M65 
AudioAudio
SB Recon3D Klipsch ProMedia 2.1  
  hide details  
Reply
post #10 of 35
Thread Starter 
yea i tried unplugging the pus and plugging it back in no response . the reason why i don't think its the mobo,cpu,ram is because it was running fine AFTER i installed the gtx 1080ti. i was browsing the internet , watching videos, playing games, and i was checking the temps. everything was perfectly fine, then i played games again 5 hours later and it was running fine again with no high temps and it just shut down after it was running everything fine. then i thought it was the 1080ti since it was the only thing i changed so i plugged back in my 1070 and again no response at all.

i just tried the paperclip method on my psu and the psu fan isn't spinning at all. Is this 100% legit to check if its dead? a paperclip into the green wire and the black wire right next to it and turning it on.
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD 955BE MSI 870-C43 Sapphire 6850 4GB Kingston HyperX DDR3 SDRAM 1600 
Hard DriveOptical DriveOSMonitor
500GB WD Caviar Blue WD5000AAKX Pioneer DVR-219CHV 24X24 Windows 7 Ultimate 64bit Samsung Syncmaster P2770 27' + Acer G205H 20' 
KeyboardPowerCaseMouse
something Coolermaster GX 650w Coolermaster Elite 430 something 
Mouse Pad
something 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Did my psu die?? Need help urgent!!